Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

Data Domain: DDOS / DDMC 7.1.x veya sonraki bir sürüme yükselttikten sonra GUI'ye artık erişilemez

Summary: DDOS/DDMC 7.1.x ve sonraki sürümlerden sonra DD ve DDMC GUI arka uçlarındaki daha sıkı güvenlik denetimleri nedeniyle, daha önce kabul edilen güvenilir DD ana bilgisayarlar için bazı sertifikalar yükseltmeden sonra kabul edilmeyebilir ve bu da DDOS yükseltmesi sonrasında GUI'nın başlatılamamasına neden olabilir ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Bir müşteri, DDOS veya DDMC'yi 7.1.x veya sonraki bir sürüme yükseltir (bundan sonra hem DDOS hem de DDMC'yi ifade etmek için DDOS kullanacağız) ve yükseltme tamamlandıktan sonra GUI'ye erişmenin artık mümkün olmadığını öğrenir. HTTP / HTTPS hizmetlerini komut satırından yeniden başlatmak da işe yaramaz. GUI'ye erişmek için bir tarayıcı kullanırken, aşağıdaki hata sayfası şunları gösterir: 
 

Hizmet Mevcut Değil

GUI Hizmeti geçici olarak kullanılamıyor. Tekrar denemek için tarayıcıyı yenileyin. Sorun devam ederse yardım için Dell EMC destek birimine başvurun

Cause

GUI arka ucu, Java tabanlı bir uygulamadan çalışıyor. GUI arka ucu çalışmıyor. Bu DD, DDOS 7.1.x veya daha yeni bir sürüme yükseltildiyse ve GUI o zamandan beri başarısız oluyorsa, DD'nin diğer DD'lerle bir güven ilişkisi varsa ve bunlardan herhangi biri 2048 bit'ten daha kısa bir genel anahtara sahip bir sertifikaya sahipse, DD GUI'nin başlatılamamasının nedeni bu olabilir. çünkü daha yeni paketle sunulan JDK'deki daha sıkı kontroller, güvenilir DD ana bilgisayarlarının bazıları için başarısız olur.

Resolution

İlk olarak, karşı karşıya kalınan sorunun tam olarak bu olduğundan emin olmak gerekir. Bunun böyle olması için, aşağıdaki koşulların tümünün geçerli olması gerekir:
  1. GUI'nin başlatılamadığı DD, yalnızca DDOS 7.1.x veya daha sonraki bir sürüme yükselttikten sonra GUI sorunlarıyla karşılaşıyor
  2. Bu DD'nin, bir veya daha fazla geçmişte DDOS 5.4.x sürümünü (veya daha eskisini) ya da DDMC 1.1 (veya daha eskisini) çalıştıran diğer DD'ler ile güven ilişkisi vardır
  3. Bu DD, GUI arka ucunun başlatılamamasına yönelik belirli bir günlük kümesine sahiptir

Yukarıdaki 1. madde açıklayıcıdır. Yukarıdaki 2'nin geçerli olup olmadığını belirlemek için önce DD'deki güvenilir ana bilgisayarların listesini alın:

# adminaccess trust show

Bu ana bilgisayarların her birinin güvendiği DDOS 5.4 (veya öncesi) veya DDMC 1.1 (veya öncesi) ile yüklenip yüklenmediğini görmek üzere yükseltme geçmişlerini kontrol edin: 

# sistem yükseltme geçmişi

Yukarıdaki sürümlerden herhangi biriyle yüklenen sistemlerde, DDOS / DDMC 7.1'e yükseltildikten sonra JDK tarafından artık kabul edilmeyen, yalnızca 1024 bit uzunluğundaki genel anahtarlarla kurulum sırasında oluşturulan bir CA kendinden imzalı sertifika olması muhtemeldir. Bu ana bilgisayarların küçük ortak anahtarlara sahip sertifikalara sahip olup olmadığını öğrenmenin olası bir yolu, onlara GUI'yi açmak ve bir tarayıcıdan sertifika ayrıntılarını kontrol etmektir (bunu yapmanın yolu, tarayıcılar arasında biraz farklılık gösterir).


Öğe 3'ü onaylamak için (DD GUI arıza günlükleri bu soruna yönelikse), "em.info" günlük dosyasını açmak için aşağıdaki komutu çalıştırın:

# log view debug/sm/em.info


Ve bu günlükleri aramak için arama yapın (eğik çizgi kullanın) ("..." Bazı günlüklerin kısaca aşağıda gösterilmediğini gösterir) :

 

+-----+-----+-----+ SISTEM (YENIDEN)BAŞLATMA +-----+-----+-----+
...
26 Feb 2021 10:33:04,172 INFO [main] Oturum çerezi adını 'JSESSIONID-ddem___HTTPS'
olarak ayarlama26 Feb 2021 10:33:04,172 INFO [main] xsrf çerez adını 'DD_SSO_TOKEN___HTTPS'
olarak ayarlama26 Feb 2021 10:33:04,382 INFO [main] Doğrulama sorunlarını
düzeltmek için SUN sağlayıcısının X.509 fabrikasına enjekte ediliyor...
26 Feb 2021 10:33:05,093 INFO [main] İstemci ve sunucu arasındaki sertifikaları yeniden başlatma

26 Feb 2021 10:33:05,093 INFO [main] Sistem için sertifika depolarını yeniden yükleme

26 Feb 2021 10:33:05,097 INFO [main] Finished reloading the certificate stores
26 Feb 2021 10:33:05,097 ERROR [main] Exception during command execution: javax.net.ssl.SSLException - Error creating premaster secret. , tekrar deneyecek, Deneme# 1
26 Feb 2021 10:33:05,243 INFO [main] İstemci ve sunucu
arasındaki sertifikaları yeniden başlatma 26 Feb 2021 10:33:05,243 INFO [main] Sistem
için sertifika depolarını yeniden yükleme 26 Feb 2021 10:33:05,246 INFO [main] Sertifika depolarının yeniden yüklenmesi tamamlandı

 Bu, bu DD'nin güvenilir olarak içe aktardığı bazı sertifikaların kısa bir anahtara sahip olduğunu ve bu nedenle GUI'nin başlatılamadığını gösterir.

DDOS 7.1 veya sonraki sürümlerde küçük ortak anahtarlara sahip sertifikalar sunulduğunda GUI yüklenirken başarısız olmaya devam edecek olsa da sorun, DDOS 6.2.1.40 ve sonraki sürümler ile DDOS 7.2.0.50 ve sonraki sürümlerin kodunda çözülmüştür. Bu nedenle, bu tür bir sürüme yükseltme yaparken yerel CA sertifikasında küçük bir ortak anahtar varsa, Sertifika, daha uzun bir anahtarla yeniden oluşturulur.
 

Bu yazı itibariyle (Ağustos 2022) DDOS 6.2.1.x (yalnızca DD2200 ve DD250 donanımı için) ve DDOS 7.x dışında hiçbir sürümün artık desteklenmediği göz önüne alındığında, herhangi bir geçici çözüm sağlanmamıştır, ancak sorunlu DD'ler için ana bilgisayarı ve CA sertifikasını daha uzun anahtarlarla yeniden oluşturmayı deneyebilir, ardından etkilenen cihazlar arasında güveni kaldırıp yeniden ekleyebilirsiniz: 

# adminaccess trust del host dd-trusted-1 type mutual
# adminaccess certificate generate self-signed-cert regenerate-ca
# adminaccess trust add host dd-trusted-1 type mutual


 

Affected Products

Data Domain
Article Properties
Article Number: 000202263
Article Type: Solution
Last Modified: 21 Mar 2023
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.