Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

Data Domain: Po upgradu na systém DDOS nebo DDMC 6.2.1.90, 7.2.0.95 či 7.7.2.x nebo novější není možné získat přístup k uživatelskému rozhraní.

Summary: Z důvodu přísnějších bezpečnostních kontrol v backendech uživatelského rozhraní DD a DDMC po systému DDOS či DDMC 7.7.2.x, 7.7.3.x, 7.8.x nebo 7.9.x nemusí být některé certifikáty pro důvěryhodné hostitele DD přijaty, i když dříve přijaty byly, kvůli čemuž nemusí být možné spustit uživatelské rozhraní po upgradu systému DDOS. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Uživatel upgraduje systém DDOS nebo DDMC na verzi 7.7.2.x, 7.7.3.x, 7.8.x nebo 7.9.x a po dokončení upgradu zjistí, že není možné získat přístup k uživatelskému rozhraní. Restartování služeb HTTP nebo HTTPS z příkazového řádku nefunguje. Při pokusu o získání přístupu do uživatelského rozhraní pomocí prohlížeče se zobrazí následující chybová stránka: 
Service Not Available
The GUI Service is temporarily unavailable. Refresh browser to try again. If the problem persists, contact Dell EMC support for assistance.

Cause

Backend uživatelského rozhraní je spuštěn v aplikaci na bázi jazyka Java. Backend uživatelského rozhraní není spuštěn. Příčinou toho, proč se nespustí uživatelské rozhraní DD, může být upgrade systému DD na některou z uvedených verzí, kdy selhává uživatelské rozhraní, pokud má systém DD vztah důvěryhodnosti s jinými systémy DD a některý z nich má nesprávný certifikát. Přísnější kontrola v novějším balíčku JDK pro některé důvěryhodné hostitele DD neproběhne bez problémů.

Resolution

Pomoc s kontrolou připojení nástroje DLm naleznete v článku znalostní databáze Dell 207823: 
Data Domain + DLm: Po upgradu na systém DDOS nebo DDMC 6.2.1.90, 7.2.0.95 nebo 7.7.2.x nebo novější není možné získat přístup k uživatelskému rozhraní.
https://www.dell.com/support/kbdoc/en-us/000207823 Data Domain + DLm: Po upgradu na systém DDOS nebo DDMC 6.2.1.90, 7.2.0.95 či 7.7.2.x nebo novější není možné získat přístup k uživatelskému rozhraní.

 
VAROVÁNÍ: Pokud je připojen nástroj DLm, NEPOUŽÍVEJTE řešení uvedení níže v tomto článku znalostní databáze.

Je třeba určit, zda se skutečně jedná o daný problém. Aby tomu tak bylo, musí platit všechny níže uvedené podmínky:
  1. V systému DD, ve kterém nelze spustit uživatelské rozhraní, dochází k tomuto problému pouze od upgradu na jednu z následujících verzí:
    • DDOS 7.7.2.x
    • DDOS 7.7.3.x
    • DDOS 7.8.x
    • DDOS 7.9.x
  2. Tento systém DD má vztah důvěryhodnosti s jinými systémy DD, z nichž jeden nebo více byly v minulosti ve verzi DDOS 4.7–5.4.
  3. Tento systém DD má konkrétní sadu protokolů pro selhání týkající se spouštění uživatelského rozhraní backendu.

První položka je zřejmá.

Chcete-li zjistit, zda platí položka dvě, získejte seznam důvěryhodných hostitelů v systému DD:

# adminaccess trust show

Subject                  Type         Valid From                 Valid Until                Fingerprint
----------------------   ----------   ------------------------   ------------------------   -----------------------------------------------------------
dd-upgraded-7.7.2.x      trusted-ca   Tue Jul  6 15:36:35 2021   Mon Jul  5 15:36:35 2027   BA:59:F0:6E:93:47:02:7C:6C:C1:39:71:46:6D:1F:2B:81:09:E9:46
dd-trusted-1             trusted-ca   Mon Feb  7 10:26:48 2011   Thu Jan 30 10:26:48 2042   7B:96:6B:06:D9:A4:6A:B1:A0:3A:4C:E7:12:28:07:AD:29:F3:8E:F2
dd-trusted-2             trusted-ca   Mon Aug 21 10:18:52 2017   Thu Aug 13 10:18:52 2048   16:BC:09:02:F5:39:CB:EC:C2:A8:9E:5D:21:90:19:38:2B:36:47:EA
----------------------   ----------   ------------------------   ------------------------   -----------------------------------------------------------

V tomto případě je „dd-upgraded-7.7.2.x“ systém, u kterého selhává uživatelské rozhraní, a další dva jsou důvěryhodné systémy DD (protože mají kontexty replikace nastavené na místní systém DD). Pokud později nedojde k opětovnému vygenerování certifikátu DD použitého k získání důvěry, bude platný od data instalace. Ve výše uvedeném výstupu je nejpravděpodobnější možností pro spuštění starého systému DDOS 4.7–5.4 systém „dd-trusted-1“.

Přihlaste se k tomuto systému DD a zkontrolujte jej (nebo vyhledejte část „System Upgrade History“ v souborech ASUP):

# system upgrade history
Version           Partition   State     Time                Package
                  Number
---------------   ---------   -------   -----------------   ------------
5.1.0.5-269447    1           INSTALL   12/29/11 01:02:59
5.1.0.9-282511    2           UPGRADE   02/07/12 13:31:42   ddr
5.4.5.0-477080    1           UPGRADE   05/04/15 10:22:42   ddr
5.5.4.10-536339   2           UPGRADE   04/17/18 08:51:19   ddr
5.7.5.0-569395    1           UPGRADE   04/17/18 09:41:17   ddr
---------------   ---------   -------   -----------------   ------------

V tomto výstupu se systém „dd-trusted-1“ shoduje s položkou dvě a je pravděpodobné, že má nesprávný certifikát, který způsobuje selhání načítání uživatelského rozhraní pomocí vztahu důvěryhodnosti hostitele DD systému „dd-upgraded-7.7.2.x“.

Chcete-li potvrdit položku tři (pokud jsou k dispozici protokoly selhání uživatelského rozhraní DD pro tento konkrétní problém), otevřete soubor protokolu „em.info“ spuštěním následujícího příkazu:

# log view debug/sm/em.info

Vyhledejte tyto protokoly (použijte lomítko):

05 Jul 2022 13:57:38,737 INFO  [main] Reloading the certificate stores for the system
05 Jul 2022 13:57:38,899 ERROR [main] Exception during command execution: java.security.cert.CertificateException - Invalid X.509 Certificate version., will retry,  Attempt# 1
05 Jul 2022 13:57:39,001 ERROR [main] Exception during command execution: java.security.cert.CertificateException - Invalid X.509 Certificate version., will retry,  Attempt# 2
05 Jul 2022 13:57:39,103 ERROR [main] Exception during command execution: java.security.cert.CertificateException - Invalid X.509 Certificate version., will retry,  Attempt# 3



Okamžitým zástupným řešením je odebrat důvěru u libovolného hostitele DD, který v minulosti používal systém DDOS 4.7–5.4. Pokud totiž byl vytvořen nesprávný certifikát, spuštění místního uživatelského rozhraní DD již nebude selhávat. V tomto příkladu bychom mohli říci, že systém dd-trusted-1 je jediným z důvěryhodných systémů DD, který kdy používal systém DDOS 5.7–5.4. Chcete-li odebrat vzájemnou důvěru (tento systém DD důvěřuje systému dd-trusted-1 a naopak), proveďte následující kroky v systému DD, který se potýká s problémem s uživatelským rozhraním.
 

# adminaccess trust del host dd-trusted-1 type mutual


Odebrání důvěry způsobí selhání nastavení replikace s nyní nedůvěryhodným systémem DD, dokud nedojde k opětovnému obnovení důvěry. Pokud odebrání důvěry selže, protože vzdálený systém DD již není dosažitelný nebo ani neexistuje, opakujte příkaz bez možnosti „mutual“, aby se důvěra odebrala pouze místně, protože to stačí pro opětovné fungování uživatelského rozhraní.

V případech, v nichž je důvěryhodný systém DD stále používán a je třeba zachovat vztah důvěryhodnosti, je nutné vytvořit nový certifikát CA:

  1. V problematickém systému vytvořte pomocí příkazového řádku nový certifikát CA podepsaný držitelem:
# adminaccess certificate generate self-signed-cert regenerate-ca

 

  1. Opravte důvěru, kterou tento systém DD udržuje se všemi ostatními systémy DD nebo DDMC (vzájemná možnost „adminaccess trust del“ následovaná „adminaccess trust add“ z každého zařízení).
  2. Nakonec na libovolném z dotčených zařízení vypněte a zapněte webovou službu:

    # adminaccess disable https
    # adminaccess enable https

Pokud výše uvedené uživatelské rozhraní systému DD stále nefunguje, obraťte se na podporu DELL pro systém Data Domain.

Chcete-li obnovit důvěru, je nutné nejprve zajistit, aby byl certifikát DD CA v umístění „dd-trusted-1“ znovu vytvořen bez jakýchkoli chyb. Z tohoto příkazového řádku hostitele to lze provést spuštěním níže uvedených příkazů a podle případných pokynů: 

# adminaccess certificate generate self-signed-cert regenerate-ca


Pokud je tento systém DD založený na důvěře s jinými systémy DD nebo replikací, je nutné odstranit a poté znovu přidat důvěru všech podobných partnerů.

Nakonec znovu přidejte důvěru mezi systémem „dd-upgraded-7.7.2.x“ a „dd-trusted-1“ buď:

  • Spuštěním příkazu „adminaccess trust add host dd-trusted-1 type mutual“ ze systému „dd-upgraded-7.7.2.x“ nebo 
  • spuštěním příkazu „adminaccess trust add host dd-upgraded-7.7.2.x type mutual“ ze systému „dd-trusted-1“.

Affected Products

Data Domain, PowerProtect Data Domain Management Center
Article Properties
Article Number: 000202177
Article Type: Solution
Last Modified: 16 Mar 2023
Version:  12
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.