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Data Domain: DDOS 또는 DDMC 6.2.1.90, 7.2.0.95 또는 7.7.2.x 이상으로 업그레이드한 후 UI에 액세스할 수 없음

Summary: DDOS 또는 DDMC 7.7.2.x, 7.7.3.x, 7.8.x 또는 7.9.x 이후의 DD 및 DDMC UI 백엔드에서 보다 엄격한 보안 검사로 인해 업그레이드 후에 수락된 신뢰할 수 있는 DD 호스트의 일부 인증서가 수락되지 않아 DDoS 업그레이드 이후 UI를 시작할 수 없습니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

사용자가 DDOS 또는 DDMC를 7.7.2.x, 7.7.3.x, 7.8.x 또는 7.9.x 버전으로 업그레이드하고 업그레이드가 완료된 후 UI에 액세스할 수 없습니다. 명령줄에서 HTTP 또는 HTTPS 서비스를 다시 시작해도 작동하지 않습니다. 브라우저를 사용하여 UI에 액세스할 때 다음 오류 페이지가 표시됩니다. 
Service Not Available
The GUI Service is temporarily unavailable. Refresh browser to try again. If the problem persists, contact Dell EMC support for assistance.

Cause

UI 백엔드가 Java 기반 애플리케이션에서 실행 중입니다. UI 백엔드가 실행되고 있지 않습니다. DD를 위에서 언급한 릴리스로 업그레이드한 후 UI에 장애가 발생한 경우 DD에 다른 DDS와 트러스트 관계가 있고 그 중 하나라도 잘못된 인증서가 있는 경우 DD UI가 시작되지 않는 원인이 될 수 있습니다. 일부 신뢰할 수 있는 DD 호스트에 대해 최신 번들 JDK에서 보다 엄격한 검사가 통과되지 않습니다.

Resolution

DLm이 연결되어 있는지 확인하는 방법은 다음을 참조하십시오. Dell KB 문서 207823: 
Data Domain + DLM: DDOS 또는 DDMC 6.2.1.90, 7.2.0.95 또는 7.7.2.x 이상으로 업그레이드한 후 UI에 액세스할 수 없습니다.
https://www.dell.com/support/kbdoc/en-us/000207823 Data Domain + DLM: DDOS 또는 DDMC 6.2.1.90, 7.2.0.95 또는 7.7.2.x 이상으로 업그레이드한 후 UI에 액세스할 수 없음

 
주의: DLm이 첨부된 경우 이 KB 문서의 아래 해결 방법을 수행하지 마십시오.

이것이 정확히 직면하고 있는 문제인지 확인할 필요가 있습니다. 이 경우 아래의 모든 조건이 참이어야 합니다.
  1. UI가 시작되지 않는 DD에서는 다음 중 하나로 업그레이드한 이후에만 UI 문제가 발생합니다.
    • DDOS 7.7.2.x
    • DDOS 7.7.3.x
    • DDOS 7.8.x
    • DDOS 7.9.x
  2. 이 DD는 다른 DDS와 트러스트 관계가 있으며, 이 중 하나 이상의 DDOS 버전이 과거 DDOS 4.7~5.4 버전이었습니다.
  3. 이 DD에는 UI 백엔드를 시작하지 못한 경우에 대한 특정 로그 세트가 있습니다.

항목 1은 설명이 필요 없습니다.

항목 2가 적용되는지 확인하려면 DD에서 신뢰할 수 있는 호스트 목록을 가져옵니다.

# adminaccess trust show

Subject                  Type         Valid From                 Valid Until                Fingerprint
----------------------   ----------   ------------------------   ------------------------   -----------------------------------------------------------
dd-upgraded-7.7.2.x      trusted-ca   Tue Jul  6 15:36:35 2021   Mon Jul  5 15:36:35 2027   BA:59:F0:6E:93:47:02:7C:6C:C1:39:71:46:6D:1F:2B:81:09:E9:46
dd-trusted-1             trusted-ca   Mon Feb  7 10:26:48 2011   Thu Jan 30 10:26:48 2042   7B:96:6B:06:D9:A4:6A:B1:A0:3A:4C:E7:12:28:07:AD:29:F3:8E:F2
dd-trusted-2             trusted-ca   Mon Aug 21 10:18:52 2017   Thu Aug 13 10:18:52 2048   16:BC:09:02:F5:39:CB:EC:C2:A8:9E:5D:21:90:19:38:2B:36:47:EA
----------------------   ----------   ------------------------   ------------------------   -----------------------------------------------------------

이 경우 "dd-upgraded-7.7.2.x"는 UI에 장애가 발생한 상태이고 다른 두 개는 신뢰할 수 있는 DDS입니다(로컬 DD로 설정된 복제 컨텍스트가 포함되어 있기 때문). 나중에 다시 생성하지 않는 한, 신뢰에 사용되는 DD 인증서는 설치 날짜로부터 "유효"합니다. 위의 출력에서 이전 DDOS 4.7~5.4 릴리스를 실행할 가능성이 가장 높은 후보는 "dd-trusted-1"입니다.

해당 DD에 로그인하여 확인합니다(또는 ASP에서 "System Upgrade History" 섹션 확인).

# system upgrade history
Version           Partition   State     Time                Package
                  Number
---------------   ---------   -------   -----------------   ------------
5.1.0.5-269447    1           INSTALL   12/29/11 01:02:59
5.1.0.9-282511    2           UPGRADE   02/07/12 13:31:42   ddr
5.4.5.0-477080    1           UPGRADE   05/04/15 10:22:42   ddr
5.5.4.10-536339   2           UPGRADE   04/17/18 08:51:19   ddr
5.7.5.0-569395    1           UPGRADE   04/17/18 09:41:17   ddr
---------------   ---------   -------   -----------------   ------------

이 출력에서 "dd-trusted-1"은 항목 2와 일치하며 잘못된 인증서를 가지고 있어 "dd-upgraded-7.7.2.x" DD 호스트가 트러스트 관계를 통해 UI를 로드하지 못할 수 있습니다.

항목 3을 확인하려면(DD UI 오류 로그가 이 특정 문제에 대한 것인 경우) 다음 명령을 실행하여 "em.info"로그 파일을 엽니다.

# log view debug/sm/em.info

다음 로그를 검색합니다(슬래시 사용).

05 Jul 2022 13:57:38,737 INFO  [main] Reloading the certificate stores for the system
05 Jul 2022 13:57:38,899 ERROR [main] Exception during command execution: java.security.cert.CertificateException - Invalid X.509 Certificate version., will retry,  Attempt# 1
05 Jul 2022 13:57:39,001 ERROR [main] Exception during command execution: java.security.cert.CertificateException - Invalid X.509 Certificate version., will retry,  Attempt# 2
05 Jul 2022 13:57:39,103 ERROR [main] Exception during command execution: java.security.cert.CertificateException - Invalid X.509 Certificate version., will retry,  Attempt# 3



가장 즉각적인 해결 방법은 과거에 DDOS 4.7~5.4를 실행했던 모든 DD 호스트에서 트러스트를 제거하여 잘못된 인증서가 생성된 경우 로컬 DD UI가 더 이상 로드되지 않도록 하는 것입니다. 이 예에서 DDOS 5.7~5.4를 실행하는 신뢰할 수 있는 DD는 dd-trusted-1뿐입니다. UI 문제가 있는 DD에서 상호 트러스트(이 DD trusting dd-trusted-1 및 그 반대)를 제거하려면 다음 단계를 수행합니다.
 

# adminaccess trust del host dd-trusted-1 type mutual


트러스트를 제거하면 트러스트가 다시 설정될 때까지 현재 신뢰할 수 없는 DD로 설정된 복제가 실패합니다. 원격 DD에 더 이상 연결할 수 없거나 원격 DD가 존재하지 않아 트러스트 제거에 실패한 경우 사용자 인터페이스가 다시 작동하기에 충분하므로 "mutual" 옵션 없이 명령을 반복하여 로컬에서만 트러스트를 제거합니다.

신뢰할 수 있는 DD가 아직 사용 중이고 트러스트 관계를 유지해야 하는 경우 새 CA 인증서를 생성해야 합니다.

  1. CLI에서 문제가 있는 시스템에서 자체 서명된 새 CA 인증서를 생성합니다.
# adminaccess certificate generate self-signed-cert regenerate-ca

 

  1. 이 DD 시스템이 다른 모든 DD 또는 DDMC 시스템을 통해 유지하는 트러스트를 수정합니다(각 디바이스에서 상호 "adminaccess trust del" 다음에 "adminaccess trust add")
  2. 마지막으로 영향을 받는 모든 디바이스에서 웹 서비스를 순환합니다.

    # adminaccess disable https
    # adminaccess enable https

위의 작업을 수행한 후에도 DD 사용자 인터페이스가 작동하지 않으면 DELL Data Domain 지원 팀에 문의하십시오.

트러스트를 다시 설정하려면 먼저 "dd-trusted-1"의 DD CA 인증서가 오류 없이 다시 생성되었는지 확인해야 합니다. 이 호스트 명령줄에서 아래 명령을 실행하고 프롬프트에 따르십시오(있는 경우). 

# adminaccess certificate generate self-signed-cert regenerate-ca


이 DD에 다른 DDS 또는 복제를 통해 트러스트가가 설정된 경우 이러한 모든 피어에 대해 트러스트를 삭제한 후 재추가해야 합니다.

마지막으로 "dd-upgraded-7.7.2.x"와 "dd-trusted-1" 사이에 트러스트를 다시 추가하려면 다음 중 하나를 수행합니다.

  • "dd-upgraded-7.7.2.x"에서 "adminaccess trust add host dd-trusted-1 type mutual"을 실행하거나 
  • "dd-trusted-1"에서 "adminaccess trust add host dd-upgraded-7.7.2.x type mutual"을 실행합니다.

Affected Products

Data Domain, PowerProtect Data Domain Management Center
Article Properties
Article Number: 000202177
Article Type: Solution
Last Modified: 16 Mar 2023
Version:  12
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