Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

Data Domain:DDOSまたはDDMC 6.2.1.90、7.2.0.95、7.7.2.x以降にアップグレードした後、UIにアクセスできない」

Summary: DDOSまたはDDMC 7.7.2.x、7.7.3.x、7.8.x、7.9.xへのアップグレード後、DDおよびDDMC UIバックエンドのセキュリティ チェックがより厳しくなったため、以前は受け入れられた信頼できるDDホストの一部の証明書がアップグレード後に受け入れられず、結果としてDDOSアップグレード後にUIを起動できなくなる場合があります。

This article applies to   This article does not apply to 

Symptoms

ユーザーがDDOSまたはDDMCのいずれかをバージョン7.7.2.x、7.7.3.x、7.8.x、7.9.xのいずれかにアップグレードする場合、アップグレード完了後にUIにアクセスできないことが判明することがあります。コマンド ラインからHTTPまたはHTTPSサービスを再起動してもUIにアクセスできません。ブラウザーを使用してUIにアクセスすると、次のエラー ページが表示されます。 
Service Not Available
The GUI Service is temporarily unavailable. Refresh browser to try again. If the problem persists, contact Dell EMC support for assistance.

Cause

UIバックエンドがJavaベースのアプリケーションで動作している。UIバックエンドが動作していない。DDが前述のリリースのいずれかにアップグレードされ、UIにエラーが発生している場合、DDが他のDDと信頼関係を持ちそのうちのどれかが不正な証明書を持っている場合は、DD UIが起動しない原因である可能性があります。新しいバンドルJDKにおけるより厳格なチェックで、信頼できるDDホストの一部が不合格になります。

Resolution

DLmが接続されているかどうかを確認する方法については、次のDell KB記事207823を参照してください:「
Data Domain + DLM:DDOSまたはDDMC 6.2.1.90、7.2.0.95、7.7.2.x以降にアップグレードした後、UIにアクセスできない」。
https://www.dell.com/support/kbdoc/en-us/000207823「Data Domain + DLM:DDOSまたはDDMC 6.2.1.90、7.2.0.95、7.7.2.x以降にアップグレードした後、UIにアクセスできない」

 
警告:DLmが接続されている場合は、このKB記事の以下の解決策を実行しないでください

これが実際に直面している問題であるかどうかを確認する必要があります。このケースに該当するためには、以下のすべての条件が満たされている必要があります。
  1. UIが起動しないDDでは、次のいずれかにアップグレードしてからUIの問題が発生しています。
    • DDOS 7.7.2.x
    • DDOS 7.7.3.x
    • DDOS 7.8.x
    • DDOS 7.9.x
  2. このDDは、他のDDと信頼関係があり、そのうちの1つ以上が過去にDDOS 4.7~5.4のバージョンを持っています。
  3. このDDには、UIバックエンドを起動できない場合の特殊なログ セットがあります。

項目1は、自明です。

項目2が適用されるかどうかを判断するには、DD内の信頼できるホストのリストを取得します。

# adminaccess trust show

Subject                  Type         Valid From                 Valid Until                Fingerprint
----------------------   ----------   ------------------------   ------------------------   -----------------------------------------------------------
dd-upgraded-7.7.2.x      trusted-ca   Tue Jul  6 15:36:35 2021   Mon Jul  5 15:36:35 2027   BA:59:F0:6E:93:47:02:7C:6C:C1:39:71:46:6D:1F:2B:81:09:E9:46
dd-trusted-1             trusted-ca   Mon Feb  7 10:26:48 2011   Thu Jan 30 10:26:48 2042   7B:96:6B:06:D9:A4:6A:B1:A0:3A:4C:E7:12:28:07:AD:29:F3:8E:F2
dd-trusted-2             trusted-ca   Mon Aug 21 10:18:52 2017   Thu Aug 13 10:18:52 2048   16:BC:09:02:F5:39:CB:EC:C2:A8:9E:5D:21:90:19:38:2B:36:47:EA
----------------------   ----------   ------------------------   ------------------------   -----------------------------------------------------------

この場合、「dd-upgraded-7.7.2.x」はUIにエラーが発生しているDDで、残りの2つは信頼できるDDです(ローカルDDで設定されたレプリケーション コンテキストがあるため)。後で再生成されない限り、信頼のために使用されるDD証明書は、インストール日から「有効」になります。上記の出力では、古いDDOS 4.7~5.4リリースを実行している可能性が最も高い候補は「dd-trusted-1」です。

そのDDにログインして確認します(または、ASUPの[System Upgrade History]セクションを探します)。

# system upgrade history
Version           Partition   State     Time                Package
                  Number
---------------   ---------   -------   -----------------   ------------
5.1.0.5-269447    1           INSTALL   12/29/11 01:02:59
5.1.0.9-282511    2           UPGRADE   02/07/12 13:31:42   ddr
5.4.5.0-477080    1           UPGRADE   05/04/15 10:22:42   ddr
5.5.4.10-536339   2           UPGRADE   04/17/18 08:51:19   ddr
5.7.5.0-569395    1           UPGRADE   04/17/18 09:41:17   ddr
---------------   ---------   -------   -----------------   ------------

この出力では、「dd-trusted-1」は項目2と一致しており、「dd-upgraded-7.7.2.x」DDホストが信頼関係を通じてUIのロードに失敗する原因となる誤った証明書がある可能性があります。

項目3(DD UIの障害ログがこの特定の問題のものである場合)を確認するには、次のコマンドを実行して「em.info」ログ ファイルを開きます。

# log view debug/sm/em.info

次のログを検索します(スラッシュを使用)。

05 Jul 2022 13:57:38,737 INFO  [main] Reloading the certificate stores for the system
05 Jul 2022 13:57:38,899 ERROR [main] Exception during command execution: java.security.cert.CertificateException - Invalid X.509 Certificate version., will retry,  Attempt# 1
05 Jul 2022 13:57:39,001 ERROR [main] Exception during command execution: java.security.cert.CertificateException - Invalid X.509 Certificate version., will retry,  Attempt# 2
05 Jul 2022 13:57:39,103 ERROR [main] Exception during command execution: java.security.cert.CertificateException - Invalid X.509 Certificate version., will retry,  Attempt# 3



最も直接的な回避策は、過去にDDOS 4.7~5.4を実行していたDDホストとの信頼関係を削除することです。これにより、万一間違った証明書が作成されても、ローカルDD UIのロードに失敗することはなくなります。次の例を見てみましょう。dd-trusted-1は、DDOS 5.7~5.4を実行した唯一の信頼できるDDです。UIの問題があるDDから相互信頼(このDDがdd-trusted-1を信頼すること、およびその逆)を削除するには、次の手順を実行します。
 

# adminaccess trust del host dd-trusted-1 type mutual


信頼を取り除くと、信頼が再確立されるまで、信頼されていないDDで設定されたレプリケーションが失敗します。リモートDDがアクセス不能、または存在していないために信頼の削除に失敗した場合は、「mutual」オプションなしでコマンドを繰り返して、ローカルでのみ信頼を削除します。ユーザー インターフェイスを再度動作させるにはこれで十分であるからです。

信頼できるDDがまだ使用されていて、信頼関係を維持する必要がある場合は、新しいCA証明書を作成する必要があります。

  1. CLIから、問題のあるシステムで新しい自己署名CA証明書を生成します。
# adminaccess certificate generate self-signed-cert regenerate-ca

 

  1. このDDシステムが他のすべてのDDまたはDDMCシステムと維持する信頼を修正します(相互の「adminaccess trust del」の後に各デバイスの「adminaccess trust add」を指定します)
  2. 最後に、影響を受けるデバイスのいずれかでWebサービスの有効/無効を切り替えます。

    # adminaccess disable https
    # adminaccess enable https

上記の手順を実行してもDDユーザー インターフェイスがまだ機能しない場合は、Dell Data Domainサポートにお問い合わせください。

信頼を再確立するには、最初に「dd-trusted-1」のDD CA証明書がエラーなしで再作成されていることを確認する必要があります。このホスト コマンド ラインから、次のコマンドを実行して証明書を確認し、プロンプトが表示されたらそれに従います。 

# adminaccess certificate generate self-signed-cert regenerate-ca


このDDが他のDDまたはレプリケーションと信頼を確立している場合は、そのようなすべてのピアの信頼を削除してから再度追加する必要があります。

最後に、「dd-upgraded-7.7.2.x」と「dd-trusted-1」の間の信頼を再度追加するために、次のいずれかを実行します。

  • 「dd-upgraded-7.7.2.x」から「adminaccess trust add host dd-trusted-1 type mutual」を実行する、または、 
  • 「dd-trusted-1」から「adminaccess trust add host dd-upgraded-7.7.2.x type mutual」を実行する

Affected Products

Data Domain, PowerProtect Data Domain Management Center