Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

PowerProtect: PPDM Backup: SQL backups can be hung and the subsequent jobs are stuck in Queued state

Summary: This article describes a workaround for SQL backups that gets hung in versions 19.10 and 19.11.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

This problem manifests by the UI showing Backups that has not completed for days and the SQL computer does not show the process ddbmsqlsv running in Windows Task Manager.

ADM log (/var/log/brs/adm/adm.log) shows the following errors.


c
om.emc.dpsg.ecdm.baseresourceservice.exception.ValidationServiceException: The value of state field is invalid.
2022-07-26T03:07:45.556Z ERROR [] [adm-backupRequest-exec-18096] [00000000-0000-4000-a000-000000000000][][][TRACE_ID:8c9d36eb157e41b5;EXEC_ID:bb31a15258157f64][] [c.e.d.e.a.s.s.p.v.v.AgentBackupRequestor.getFuture(809)] - Exception caught from callable Exception Details : com.emc.dpsg.ecdm.baseresourceservice.exception.ValidationServiceException: The value of state field is invalid.
Thrown from
com.emc.dpsg.ecdm.baseresourceservice.sp.common.Validations.check(Validations.java:678)
com.emc.dpsg.ecdm.commonresourceservice.sp.activity.BaseActivityResourceModifierAndDecorator.validateFieldsWithCurrentDBValues(BaseActivityResourceModifierAndDecorator.java:776)
com.emc.dpsg.ecdm.commonresourceservice.sp.activity.BaseActivityResourceModifierAndDecorator.checkBeforeUpdate(BaseActivityResourceModifierAndDecorator.java:812) , exception java.util.concurrent.ExecutionException: com.emc.dpsg.ecdm.baseresourceservice.exception.ValidationServiceException: The value of state field is invalid

 
NOTE: This article only applies if the previous error is seen in adm.log or adm*gz

Cause

ADM service tries to fail the tasks that are stopping responding. However, during this process, the code encounters some exceptions leaving the jobs stopping responding. It is expected that this problem be resolved in the next version.

Resolution

Contact PowerProtect Data Manager Support to apply a workaround to this problem.

Products

PowerProtect Software
Article Properties
Article Number: 000202096
Article Type: Solution
Last Modified: 13 Jul 2023
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.