Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

PowerScale:Isilon:OneFS:升級后,升級後的工作可能會對效能造成影響。

Summary: 認可 OneFS 升級後,系統類型升級工作 (在軟體版本升級後升級文件系統) 會自動啟動,且必須允許執行直到完成為止。如果升級的 OneFS 版本之間有 Inode 結構變更,升級工作會在每個檔案上執行 Inode 結構變更。當這種情況發生時,執行升級工作可能會導致暫時的效能問題。

This article applies to   This article does not apply to 

Symptoms

在 OneFS 升級期間,必須將我們先前版本的 inode 設計遷移至新版本;必須進行必要的強制移轉;無法延後或阻止此遷移。  這會觸碰 OneFS 叢集中的每一個檔案,包括用戶空間 (/ifs) 和所有系統類型檔案。

此程式會在升級程式中「已提交」OneFS 叢集升級後開始。

在某些情況下,大規模這項工作和部署可能會導致暫時的效能問題。
 

認可 OneFS 升級後,軟體版本升級後升級文件系統的類型升級系統工作會自動啟動,且必須允許執行直到完成為止。  如果升級的 OneFS 版本之間有 Inode 結構變更,升級工作會在每個檔案上執行 Inode 結構變更。  當這種情況發生時,執行升級工作可能會因為執行 Inode 結構變更所需的 IOPS 增加而導致暫時的效能問題。  您可以將升級工作的原則從目前的中等預設值變更為Low,以緩解這種情況。

哪些系統可能會受到影響?

產品 (與版本) 適用於Isilon的所有 OneFS/PowerScale 叢集,升級至具有 inode 變更的版本。
執行此核心軟體
(作業系統 (OS) 或作業環境 (OE))

Inode 結構變更的 OneFS 版本:

• OneFS 7
• OneFS 8
• OneFS 9.2

當確認發生此狀況時 如果發生此問題,則會在一般升級完成後的小時或幾天內發生,而此結束遷移工作執行時會發生。
並確認發生此狀況時

這種情況發生的可能性並不確定,並取決於許多暫時性因素,例如整體叢集健全狀況、硬體類型、操作員和用戶原則和工作流程對系統的一般影響、/ifs 下的檔對象數量及其他因素。

Cause

在此期間,確實會將儲存平臺上的所有檔案快速遷移至新的 inode 版本。一般實驗室觀察到的硬體平臺更新速度,以及使用預設的工作原則,每小時可以達到數千萬個整體檔案物件的速度。請注意,此上下文中的「檔案」不只指「用戶上傳」檔案,您會在配額和報表底下看到。這包括所有系統層級的檔案和物件。

遷移進行後,如在 CLI 中以名為「升級」的工作,在預設的中等原則下執行,Isilon 叢集可能會在進行此升級時遇到暫時和暫時的效能問題。從我們觀察到的有限報告數量來看,根據中等原則,升級 inode 遷移可能需要花費數小時到數天的時間。

Resolution

您可以將升級工作的原則從目前中低的預設值變更為降低。

如果出現效能影響,若要減輕這些影響,請將升級工作的原則從中低。將原則變更為 Low 可減少工作執行時的整體影響,但會增加工作完成時間。
 

若要將目前執行升級工作的原則變更為 Low,請執行下列命令:

isi job modify Upgrade --policy=Low


若要將日後升級工作的原則變更為 Low,請執行下列命令:

isi 工作類型修改升級 --policy=Low

 

注意:此工作是此特定升級類型的關鍵部分。雖然工作優先順序等事項可能會改變,但執行此工作的絕對要求也無法變更。如果「工作」不知何故被取消或失敗,該工作會再次恢復。inode 變更必須完成。

Affected Products

PowerScale OneFS
Article Properties
Article Number: 000194551
Article Type: Solution
Last Modified: 14 Jul 2023
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.
Article Properties
Article Number: 000194551
Article Type: Solution
Last Modified: 14 Jul 2023
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.