Dell Unity: CIFS Pool:SMB2 BLOCKED Threads when CA enabled on windows shares (User Correctable)

Summary: Customer CIFS or NFS outage due to CIFS Pool:SMB2 BLOCKED Threads when CA enabled on windows shares.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Customer CIFS or NFS outage due to CIFS Pool:SMB2 BLOCKED Threads

Perform the following via service shell (cli):
grep BLOCKED 02_emc_c4core_log/c4_safe_ktrace*|more
sade:KERNEL: 3: 3:[core]  ThreadsServicesSupervisor: Service:CIFS Pool:SMB2 BLOCKED for 1321 seconds: Server operations may be impac
sade:SOCK_STREAM: 3:[core]  T_DATA_REQ: (fd=0xffffffff, NS=0) not connected

Cause

Cause

Blocking of threads is because of SMB Oplocks which is due to CA enabled on windows shares

Analysis 

In SMB2, the durable handle feature was introduced. The feature keeps file handles for the client that have lost connectivity, so that when connectivity returns to the client they client can use the same file after the network issue has been resolved. 

The function File_NamingNode::checkPersistentOpens() returns TRUE if there is a persistent open associated. This function is called inside File_DirNode::removeLocked(). The function File_DirNode::removeLocked() returns File_Busy status to the client if there is already persistent open associated with the file.

For this issue the NAS Server waits on the "sendBreak" function to notify, which it does not get, and blocked threads begin to occur.

Resolution

Fix

Upgrade to Unity OE 5.1.3.0.5.003 or newer
 

Workaround

  1. Disable CA on the CIFS share
  2. In Unisphere, click "File" under the STORAGE heading.  Then choose the "SMB Shares" tab. 
  3. For each SMB share, click it and select Properties (click the pencil icon after selecting the share). 
  4. In the Properties dialog, click the Advanced tab. 
  5. Ensure that "Continuous Availability" is off. 

Affected Products

Dell EMC Unity
Article Properties
Article Number: 000193615
Article Type: Solution
Last Modified: 14 Oct 2022
Version:  2
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