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RecoverPoint for VMs:ESXiホストで[VMKernel.Boot.execInstalledOnly]を[True]に設定すると、ESXiスプリッターのvibのインストールと起動の問題が発生します。

Summary: VMkernel.Boot.execInstalledOnlyがtrueに設定されているESXiホストで、Kdriverのインストールまたは起動が失敗します。スプリッターが見つからないため、RecoverPoint for VMsのインストールが失敗する可能性もあります。

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Symptoms

Kdriver vibのインストールは、次のような多くのエラーで失敗します。
[root@localhost:~] esxcli software vib install -v /scratch/kdriver_RPESX-00.5.3.1.1.0.m.149.000.vib --no-sig-check
 [LiveInstallationError]
 Error in running ['/etc/init.d/rp-splitterd', 'start', 'install']:
 Return code: 1
 Output: Wed Nov 10 18:24:18 UTC 2021: rp_splitterd: Starting rp_splitter
 Wed Nov 10 18:24:18 UTC 2021: rp_splitterd: DEBUG (notice true==0): isKdriverRunning=1, isSplitterRunning=1
 --- /etc/vmware/esx.conf
 +++ /tmp/auto-backup.2100162//etc/vmware/esx.conf
 @@ -1,18 +1,299 @@
 -/adv/UserVars/RP_IP_Discovery_5 = ""
 -/adv/UserVars/RP_IP_Discovery_8 = ""
...
 Saving current state in /bootbank
 Clock updated.
 Time: 18:24:19   Date: 11/10/2021   UTC
 Successfully created /opt/emc/rp/kdriver/mod/esx_splitter
 Creating symbolic link /usr/lib/vmware/vmkmod/esx_splitter ...
 Ready to load ESX splitter
 Cannot load module esx_splitter: Failure
 Cannot load module esx_splitter: Failure

 Failed to launch splitter. For assistance, please run launch_splitter.sh --help

 Wed Nov 10 18:24:20 UTC 2021: rp_splitterd: start_kdriver_from_boot.sh Failed to execute. failing service.

 It is not safe to continue. Please reboot the host immediately to discard the unfinished update.
 Please refer to the log file for more details.

/var/run/log/vmkernel.logのイベント:
2021-11-10T18:24:18.411Z cpu1:2100089)VisorFSTar: 1994: emcrpspl.t00 (797949359604956901) as emcrpspl.t00 for 44144640 bytes
2021-11-10T18:24:20.285Z cpu3:2100373)UserMem: 7388: mmap denied: boot opt execInstalledOnly is set: file not installed

ESXiホストの再起動後にESXiスプリッターが起動に失敗し、/var/run/log/vmkernel.logに次のエラーが表示されます。
2021-11-12T15:53:29.004Z cpu2:525352)UserMem: 7576: mmap denied: boot opt execInstalledOnly is set: file not installed
2021-11-12T15:53:29.029Z cpu0:525042)Jumpstart plugin rp-splitterd activation failed: Method invocation failed
注:この問題は、ESXiスプリッタの導入中にエラーが発生したため、RecoverPoint for VMsクラスターのインストールが失敗する原因にもなります。

Cause

ESXiホストには、 VMKernel.Boot.execInstalledOnlytrueに設定されています。
この設定により、ライブ インストールを使用してkdriver vibが正しくインストールされるのを防ぐことができます。

RecoverPointスプリッターは、VMKernel.Boot.execInstalledOnly をtrueに設定すると機能できません

Resolution

解決策:
1.ESXiホストで、 VMKernel.Boot.execInstalledOnly 設定をfalseに変更 します。
  • 次のESXCLIコマンドを実行します。
esxcli system settings encryption set --require-exec-installed-only=F
  • 変更を確認します。 
esxcli system settings encryption get
Mode: TPM
Require Executables Only From Installed VIBs: false
Require Secure Boot: true

 
               Require Executables Only From Installed VIBs が false と表示されることを確認します
  • 設定を保存するには、次のコマンドを実行します。
/sbin/auto-backup.sh
    TPMは、execInstalledOnly起動オプションを強制しなくなりました。 
 
2.ESXiホストを再起動します。
3.vibのインストールを再度実行します。

VMwareドキュメント リンク:https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vsphere.security.doc/GUID-9047A43D-BB1F-4878-A971-EEFCAC183C86.html このハイパーリンクをクリックすると、デル・テクノロジーズ以外のWebサイトにアクセスします。

Additional Information

この問題は、お客様がSTIG強化手順を実行する際に、稼働中のRecoverPointシステムにも影響を与える可能性があります。

この手順では、パラメーター「VMKernel.Boot.execInstalledOnly」= Trueを変更するデフォルトのSTIG値を設定します。
この手順はESXi構成を変更しますが、次回の再起動/アップグレード時に適用され、アップグレードされたホストでRecoverPoint for VMs保護VMを実行できないため、VxRailのアップグレードの問題が発生する可能性があります。


オプション --no-live-install - を使用してvibをインストールすることはできますが、スプリッターは再起動後も機能しないように見えます。

Affected Products

RecoverPoint for Virtual Machines
Article Properties
Article Number: 000193437
Article Type: Solution
Last Modified: 21 Sep 2023
Version:  6
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