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Install of SupportAssist OS Recovery Causing Data Loss

Summary: SupportAssist for Home PCs and SupportAssist OS Recovery (SAOS) have recently launched a new feature that allows for installing SAOS on users machines that qualify via SA 3.9. This issue has resulted in some customers ending up contacting support regarding data loss on their PC’s because partitions that housed the data are now in an inaccessible state. ...

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Symptoms

Here you will find more information on SupportAssist and its features .

When experiencing this you may see issues with partitions showing up in Explorer with a drive letter and when clicked on you will be asked by the OS to format the partition.
 

Other scenarios would involve viewing disk management and seeing the partition show up either without a driver letter assigned or as unallocated space.

Cause

The partitioning process requires shrinking of disk space by 1GB in order to form a Dell Support partition to hold the SupportAssist OS Recovery rescue operating system. The partitioning process can be lengthy with either slow performing spinning drives or large amount of data. Since this process can be lengthy it may seem as if it has failed, do not stop or abandon the process.
 

When termination of the process happens before it is completed the partitioning software may not have committed its changes to the partition table. This will result in the above symptoms.

Resolution

Testing conducted by the SupportAssist OS Recovery has shown that the repair flow in SupportAssist OS Recovery can be used to correct the partitioning table in most cases.
 

Follow these steps to make a rescue USB key:

  1. Go to to OSRI on the Dell Support site .
  2. Download the Dell OSRI tool.
  3. Follow the onscreen prompts to create a bootable USB key.
  4. Insert the USB key into the affected system .
  5. Restart and press F12.
  6. Select the USB key that was inserted into the system.
  7. After booting to SuppportAssist OS Recovery you will see a Tutorial.
  8. Exit the tutorial and click on the repair tile on the home page.
  9. Follow the onscreen prompts and at the end of the process restart back to the main OS.
  10. Once inside the main OS, you will need to assign a drive letter to the partition to gain access to it again.
  11. To do this, you will need to open the Disk Management (Figure 1 [English-only]).
    Start the Disk Management by right clicking the Windows Start
    (Figure 1: Disk Management under Windows Start)
  12. Find the missing Data volume without Drive Letter (Figure 2 [English-only]).
    volume without Drive Letter Assigned
    (Figure 2: Volume without Drive Letter Assigned)
  13. Right click the volume and select the “Change Drive Letter and Paths” menu item (Figure 3 [English-only]).
    Change Drive Letter and Paths menu item
    (Figure 3: Change driver letter and paths menu item)
  14. Select the Drive Letter and click “OK” to confirm (Figure 4 [English-only]).
    Confirm the manually assigned drive letter
    (Figure 4: Confirm the manually assigned drive letter)
  15. Then the volume’s Drive Letter can be seen in Disk Management (Figure 5 [English-only]).
    Drive Letter back in Disk Management
    (Figure 5: Volume’s Drive Letter is back in Disk Management)
  16. The recovered volume is also accessible in File Explorer (Figure 6 [English-only]).
    volume is back in File Explorer
    (Figure 6: Volume is back in File Explorer)
  17. Open up the new drive letter and confirm you can see your data.

Affected Products

SupportAssist for Home PCs, SupportAssist OS Recovery
Article Properties
Article Number: 000187311
Article Type: Solution
Last Modified: 21 Sep 2023
Version:  7
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