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RecoverPoint: Unable to log in as Admin user, possible loss of connectivity due to file system filling

Summary: Unable to perform some activities such as: running commands, running scripts, performing NDU due to file system getting full. Sometimes RPAs will be unable to connect over WAN or LAN after a reboot. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

None.

Unable to perform some activities such as: running commands, running scripts, performing NDU. RPAs that are rebooted my display no LAN or WAN connectivity after coming back up until file systems are cleared and RPAs are rebooted again.

Symptoms found in the logs: 
./extracted.DR-RPA.KBox1.2019.04.09.06.28.40/processes/bin/df-h
Filesystem Size Used Avail Use% Mounted on
rootfs 969M 969M 0 100% /
/dev/root 969M 969M 0 100% /
tmpfs 3.2G 316K 3.2G 1% /run
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 10M 0 10M 0% /dev
tmpfs 16G 0 16G 0% /dev/shm
/dev/md2 1.1T 38G 998G 4% /home
/dev/md3 969M 57M 862M 7% /tmp
/dev/md6 969M 748M 171M 82% /usr
/dev/md5 969M 510M 409M 56% /var
none 16G 0 16G 0% /dev/shm

 

When trying to run commands that changes files (in this example, the sed command), we see messages such as:

sed: couldn't flush /etc/sedqGx931: No space left on device




Impacted Configuration and Settings:  
RecoverPoint Classic or RecoverPoint for Virtual Machines

Impact on RecoverPoint:
RecoverPoint still runs, but is unable to perform some actions as stated above.

 Affected versions:
5.0.X, 5.1.X

Cause

The root file system fills up and runs out of free space.

Resolution

This issue is addressed in the RecoverPoint 5.1.3 Classic and RecoverPoint for Virtual Machines 5.2.2.

Additional Information

Other types of issues seen due to this:
  • Set_password command works, but then user fails to connect with new password until RPA is rebooted.
This is due to change password failing to update the password files on the full file system. Management logs (extracted.*/files/home/kos/management/result.log) show something like:
 
2019/06/24 14:13:48.268 - #2 - 7075/5239 - Mgmt: setLocalPassword(security-admin) 
2019/06/24 14:13:48.376 - #1 - 7075/5239 - Mgmt: setLocalPassword() failed, rc: 256, cmd: echo 'security-admin'
  • RPAs that were rebooted may be unable to establish LAN or WAN connectivity due to having no room to run the needed process. This can result in DRU. 

Affected Products

RecoverPoint, RecoverPoint for Virtual Machines
Article Properties
Article Number: 000172459
Article Type: Solution
Last Modified: 02 Dec 2022
Version:  7
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