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NetWorker: A deleted or decommissioned policy does not disappear from the Monitoring Tab in the Networker Management Console (NMC)

Summary: After deleting a policy that previously ran, the policy gets grayed out and can't be removed from the monitor tab.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



After deleting a policy that previously ran, the policy gets grayed out and can't be removed from the monitoring tab. 
After deleting a policy, it gets automatically removed from the Policy tab:
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However, event though it will be grayed out, the policy will still show under the monitoring tab:
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Cause

The status of a policy as displayed in the Monitoring tab is stored in the jobsdb database. The nsrjobd daemon is one of the NetWorker server daemons. It is responsible for spawning and monitoring of  jobs  of NetWorker client binaries.This database is not automatically updated, therefore, the policy will show under the monitoring tab until the jobsdb retention period is met.

Resolution

The policy information is stored in the jobsdb database. The policy will disappear from the Monitoring tab when the Jobsdb is reset upon reaching the retention time.
To check or modify the jobsdb retention please do the following:

From the Networker Management Console (NMC) GUI:
  1.  Login to the NMC GUI.
  2. Go to the Protection TAB.
  3. On the top left you will find the name of the Networker Server, right click on it and open the Properties.
  4. Under the Networker Server Properties change to the "Configuration" tab:
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  1. Check or change the jobsdb retention. 
From the nsradmin
  1. Open an elevated command prompt or login as root in your Networker server.
  2. Initialize the Networker administrative program:
    1. >nsradmin
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  1. Display the Networker Server resources and verify what he retention time for the jobsdb is:
    1. >p type: nsr
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  1. If you would like to modify the retention time use the following command:
    1. > update Jobsdb retention in hours: <time in hours>
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Additional Information

This content is translated in different languages: 
https://downloads.dell.com/TranslatedPDF/PT-BR_KB535704.pdf
https://downloads.dell.com/TranslatedPDF/ZH-CN_KB535704.pdf
https://downloads.dell.com/TranslatedPDF/ES_KB535704.pdf
https://downloads.dell.com/TranslatedPDF/DE_KB535704.pdf
https://downloads.dell.com/TranslatedPDF/FR_KB535704.pdf
https://downloads.dell.com/TranslatedPDF/IT_KB535704.pdf
https://downloads.dell.com/TranslatedPDF/JA_KB535704.pdf
https://downloads.dell.com/TranslatedPDF/NL_KB535704.pdf
https://downloads.dell.com/TranslatedPDF/KO_KB535704.pdf
https://downloads.dell.com/TranslatedPDF/RU_KB535704.pdf
https://downloads.dell.com/TranslatedPDF/PT_KB535704.pdf
https://downloads.dell.com/TranslatedPDF/SV_KB535704.pdf

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000168599
Article Type: Solution
Last Modified: 28 Dec 2020
Version:  3
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