Symptoms
Discovering an Oracle database from AppSync for the first time fails with the following errors.
AppSync Agent Logs:
2019-03-26 14:45:05.600 acp.py[115]:main() Command: checkDatabase
2019-03-26 14:45:05.686 oracle.py[4146]:_sqlQuery() SQL*plus > ERROR:
2019-03-26 14:45:05.687 oracle.py[4146]:_sqlQuery() SQL*plus > ORA-12547: TNS:lost contact
2019-03-26 14:45:05.689 oracle.py[4146]:_sqlQuery() SQL*plus > Enter user-name: SP2-0306: Invalid option.
2019-03-26 14:45:05.693 oracle.py[4146]:_sqlQuery() SQL*plus > SP2-0157: unable to CONNECT to ORACLE after 3 attempts, exiting SQL*Plus
Cause
SQL*Plus fails to attach to the Oracle Instance when ORACLE_BASE is not set in the user profile for the Oracle user session invoked by AppSync.
This is only applicable to certain Oracle environments which require ORACLE_BASE to be explicitly set.
Resolution
AppSync Engineering has released a hotfix for this issue on AppSync version 3.8.
Please open a Service Request with DellEMC Technical Support and quote this article number in order to obtain the hotfix.