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Cómo utilizar Veeam con unidades de cinta y el controlador LTO de Microsoft en Windows 2012/2012R2

Summary: Cómo utilizar Veeam con unidades de cinta y controlador LTO de Microsoft en Windows 2012/2012R2.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Las unidades de cinta LTO esporádicas quedaron offline mediante Veeam en el PERC H330 con el controlador IBM.

Cause

Como posible solución a los problemas relacionados con el uso de Veeam con unidades de cinta LTO en el PERC H330 y el uso del controlador de IBM requerido por VEEAM, hemos probado el uso del controlador LTO de bandeja de entrada de Microsoft. Es una solución alternativa que se ha probado con éxito en nuestro laboratorio con ciertas versiones de hardware y software. Sin embargo, debido a las numerosas combinaciones posibles de hardware y software, no podemos garantizar que la solución funcione en todos los entornos:

Resolution

Entorno de pruebas:

- Power Edge T430 con adaptador PERC H330 y unidad
de cinta LTO 6- Windows 2012R2 con todos los parches (a 06/2016)
- Veeam Backup&Replication 9.0.0.1491
- Probado PERC H330 FW Stände: 25.3.0.0016; 25.4.0.0017; 25.4.1.0004
- Controlador PERC probado: 6.603.07.00

En el escenario dado, se grabaron 3 cintas LTO con Veeam utilizando los siguientes niveles de FW/controlador con diferentes tamaños de bloque (64 kB, 128 kB, 256 kB):

- PERC H330 FW: 25.3.0.0016
: controlador PERC H330: 6.603.07.00
- Controlador de cinta IBM: 6.2.5.6
- FW LTO6: F9A1

Las cintas escritas se validaron mediante la recuperación de archivos.
Posteriormente, el controlador de IBM se reemplazó por el controlador actual de la bandeja de entrada de Microsoft de Windows 2012R2 como se describe a continuación:

Al principio, el controlador instalado (6.2.5.6) se desinstaló con el "uninst.exe" del paquete de controladores de IBM:


SLN316530_en_US__1Veeam 01 SLN316530_en_US__2Veeam 02
SLN316530_en_US__3Veeam 03




SLN316530_en_US__5Veeam 05 SLN316530_en_US__4Veeam 04
Después del reinicio posterior, la unidad LTO se muestra con un signo de exclamación amarillo.
SLN316530_en_US__6Veeam 06

Ahora el controlador de Microsoft debe instalarse manualmente:
SLN316530_en_US__11Veeam 11

SLN316530_en_US__9Veeam 09 SLN316530_en_US__8Veeam 08




SLN316530_en_US__7Veeam 07 SLN316530_en_US__10Veeam 10


Después de otro reinicio, la unidad ahora debería mostrarse como Tapedrive LTO, el controlador instalado ahora es el controlador de Microsoft.
Versión: 6.3.9600.16384
SLN316530_en_US__12Veeam 12



SLN316530_en_US__13Veeam 13

SLN316530_en_US__14Veeam 14Después de eso, se hizo un inventario de un medio previamente escrito con Veeam y el controlador IBM:
SLN316530_en_US__15Veeam 15

SLN316530_en_US__16Veeam 16

Esto se hizo con los 3 medios escritos anteriormente (tamaño de bloque de 64 kB, 128 kB y 256 kB).
Al principio, cada medio se utilizó para restaurar 1 archivo del método de prueba y luego se llevó a cabo una copia de seguridad adicional en el medio respectivo. No hubo problemas.
En pruebas posteriores, se pudo determinar el comportamiento de Veeam con el controlador de Microsoft:
  1. Las cintas descritas anteriormente con esta instalación de Veaam se pueden inventariar sin restricciones. La recuperación de datos y su posterior uso para copias de seguridad es posible sin problemas e independientemente del tamaño del bloque. No fue necesario eliminar ni formatear la cinta.
  2. Las cintas nuevas no utilizadas se pueden inventariar fácilmente y utilizar por completo para respaldos y recuperaciones posteriores.
  3. Las cintas utilizadas previamente con otras aplicaciones de backup o herramientas de prueba, como ITDT, no se han podido inventariar, describir, eliminar o formatear con Veeam. Esto solo fue posible después de eliminar la cinta con una herramienta de terceros adecuada (en este caso, ITDT). Sin embargo, después de eliminar los medios, el uso sin restricciones era posible en Veeam.
El problema descrito en el punto 3 muestra el siguiente comportamiento:
El inventario en sí aparentemente no presenta errores, pero la unidad aún se mostrará como vacía, por lo que no es posible realizar respaldos ni eliminaciones en estos medios. En este caso, los medios se deben eliminar mediante una herramienta de otros fabricantes, como ITDT.
Después de eso, el medio se puede inventariar y utilizar fácilmente.
Para eliminar la cinta para su uso posterior con Veeam utilizando la utilidad ITDT, haga lo siguiente:

Inicie ITDT como administrador:


SLN316530_en_US__18Veeam 18
SLN316530_en_US__17Veeam 17
Escriba U para "[ U ] Tapeutil" y Enter.
SLN316530_en_US__19Veeam 19

Escriba 1 para "[ 1 ] Abra un dispositivo" e Intro.
SLN316530_en_US__20Veeam 20

Continúe con Intro.
SLN316530_en_US__21Veeam 21

Continúe con Intro.
SLN316530_en_US__22Veeam 22

Continúe con Intro.
SLN316530_en_US__23Veeam 23

El dispositivo se abrió correctamente, continúe con Intro.
SLN316530_en_US__24Veeam 24

Escriba 28 para "[ 28 ] Erase" y Enter.
SLN316530_en_US__25Veeam 25

Se inicia el proceso de eliminación.

Nota: el proceso de eliminación (es un "borrado largo") tarda varias horas. Se puede interrumpir reiniciando la unidad (presionando el botón de expulsión durante al menos 15 segundos), la cinta se puede usar sin problemas después de la recarga por parte de Veeam.

Si recibe el siguiente mensaje al iniciar el proceso de eliminación:
SLN316530_en_US__26Veeam 26

Realice los siguientes pasos y luego intente iniciar el proceso de eliminación nuevamente:
  1. Compruebe si la cinta está realmente cargada en la unidad y vuelva a cargarla si es necesario.
  2. Descargue/cargue la cinta.
  3. Reinicie el sistema.

El siguiente comportamiento aún no está claro:
  1. Las cintas previamente escritas con Veeam utilizando el controlador IBM son reconocidas por ITDT como de solo lectura cuando se utiliza el controlador de Microsoft. Después de eliminarlos, como se describió anteriormente, normalmente se pueden utilizar.
  2. Si IBM Tapedriver está instalado, a veces no es posible actualizar o degradar el firmware de PERC ("no se encontró ningún dispositivo compatible"). En algunos casos, es posible actualizar o degradar después de un reinicio, pero a veces solo después de que la unidad LTO se haya desconectado físicamente de la controladora.
  3. Si IBM Tapedriver está instalado, es parcialmente imposible actualizar o degradar el firmware de LTO. A veces, esto es posible después de un reinicio, en algunos casos solo después de actualizar o degradar el firmware de PERC o cambiar al controlador de Microsoft.

Affected Products

Dell EMC ML3, PowerVault 124T, Powervault LTO6, PowerVault ML6000, PowerVault TL2000, PowerVault TL4000, PowerVault TL1000
Article Properties
Article Number: 000144804
Article Type: Solution
Last Modified: 07 Oct 2022
Version:  4
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