Dell Networking PowerConnect 5500 management access lost while copying Boot software (Boot PROM)
Summary: This document is applicable to Dell Power Connect 5524/5548/5524P/5548P switches in standalone or stack.
Symptoms
While copying boot software (Boot PROM) in a PowerConnect 5500 switch, the copy operation is stopped responding and we loose management access to the switch. The only recovery method is to reboot.
Cause
If the Boot PROM (Boot software) version is already present in the switch, we do not upload it again. Doing so, may cause the management access to go unresponsive.
For example, if Boot Software is already 1.0.0.14, and we are trying to copy it again to switch, we might lose management access.
Check the release notes added along with the firmware .zip file for the appropriate firmware version.
Resolution
How to check boot code version.
Use the command "show version" to verify the bootcode version.
Sample output
console#show version Unit S W version Boot version HW version ------------------- ------------------- ------------------- ---------------- 1 4.1.0.1 1.0.0.14 00.00.02
* 1.0.0.14 is the bootcode version.
What if my boot software is already in the latest version?
Proceed with Firmware copying and upgrade. Skip copying Boot Software.
What if my boot software is Older?
Proceed with Firmware and Boot software update.
Firmware and Bootcode
Below table mentions some firmware version and their corresponding Boot software (Boot PROM)
| Firmware Version | Boot software (Boot PROM) |
|---|---|
|
4.1.0.22 |
1.0.0.14 |
|
4.1.0.21 |
1.0.0.14 |
|
4.1.0.20 |
1.0.0.14 |
|
4.1.0.19 |
1.0.0.14 |
|
4.1.0.16 |
1.0.0.14 |
|
4.1.0.15 |
1.0.0.14 |
|
4.1.0.12 |
1.0.0.14 |
|
4.1.0.10 |
1.0.0.14 |
|
4.1.0.8 |
1.0.0.14 |
|
4.1.0.5 |
1.0.0.14 |
|
4.1.0.1 |
1.0.0.14 |
|
4.0.1.12 |
1.0.0.12 |
*If a newer Firmware is released, check the release notes and find the appropriate Boot Prom Version.