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PowerStore Alerts: Node States

Summary: This article discusses Node State Failed alert.

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Symptoms

When Dell PowerStore encounters a problem, an error alert is generated to help identify the issue. This article explains the different possible causes and the relevant solutions for these error alerts. If your problem is not resolved despite the solution provided, check the technical support contact options.
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Cause

Cause is mentioned in the Resolution section under respective alerts.

Resolution

Alert ID XMS_NODE_FRU_STATE_FAILED
Alert Text Node has faulted
Description This article covers alerts for the storage controller node in the base enclosure. It covers only the failed state – for other node state alerts see KB 000132703 PowerStore Alerts: BaseEnclosure Node States. This article also covers node error conditions that may appear when setting up a new system reported by the Initial Config Wizard Hardware Check.  For details about the ICW HW check see KB 000139935 PowerStore: During Initial Configuration Wizard installation (ICW), or when adding an appliance to an existing cluster, the task fails with "Unconfigured Faulted".
Error Code (0x00304403)
Resolution Cause
Node failed state alerts occur when the system firmware detects a problem during self-testing which runs on power-up and on every reboot.    The platform software monitors the firmware for these errors and will report them by raising the alert as well as setting the FRU health state to FAILED.   Nodes in the failed state will not be put into normal operation so it's important to resolve the error condition to maintain the HA redundancy of the appliance.
For systems that have not been configured the Initial Config Wizard runs a Health Check (ICW HW) which checks for firmware for errors and will report the appliance is in an "Unconfigured Faulted" state if errors are present.   Appliances in the failed state cannot be configured and the error condition must be resolved before you can complete the configuration process.   Information about how to triage ICW HW issues can be found in KB 000139935 PowerStore: During Initial Configuration Wizard installation (ICW), or when adding an appliance to an existing cluster, the task fails with "Unconfigured Faulted".   Node related issues that ICW HW may report are Fault status register check: "Fault Status Register FLT | Node"  or unexpected values from the FRU status register  for the local or peer node: "FRU status: Unknown | Local Node | 0x****" and "FRU status: Unknown | Peer Node | 0x****"
For some classes of errors, the firmware may indicate multiple FRUs because it's not possible to determine exactly which FRU caused the error. For example, if the firmware detects sub-optimal PCI settings for an I/O module it's not possible to determine if the I/O module or Node is the cause of the issue.

Solution
Resolving these errors may require replacing the node or, in the case of multiple FRU alerts, one of the associated FRUs. There are also some known error conditions where it's possible to clear the condition without requiring any hardware replacement. Please contact technical support so they can review the underlying cause of the error to determine the best course of action.

Affected Products

PowerStore
Article Properties
Article Number: 000132707
Article Type: Solution
Last Modified: 21 Feb 2021
Version:  7
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Support Services
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Article Properties
Article Number: 000132707
Article Type: Solution
Last Modified: 21 Feb 2021
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.