Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

Viallisen osan tunnistaminen BUS DEVICE FUNCTION -virheen yhteydessä

Summary: Tässä artikkelissa on tietoja PowerEdge-palvelinten PCIe-väylien viallisten laitteiden tunnistamisesta ja vianmäärityksestä. Bus-, Device- ja Function-tiedot viittaavat tiettyyn PCI-väylän laitteeseen. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms


Sisällysluettelo

  1. virheilmoitus
  2. Bus/Device/Function-tietojen selvittäminen
  3. Vianmäärityksen vaiheet

1. virheilmoitus

Viallisten laitteiden virheilmoitukset näkyvät palvelimen tapahtumalokissa (SEL) tai PowerEdge-palvelinten LCD-näytössä.
PowerEdge-palvelinten LCD-näytön virhekoodit ennen 12. sukupolvea:
  • E171f
  • E1711
  • E1712.

Bus-, Device- ja Function-tiedot viittaavat tiettyyn PCI-väylän laitteeseen. Laitteessa voi ilmetä virhe muutamasta eri syystä. Ohjaimet tai laiteohjelmisto voivat saada laitteen käyttäytymään kuin se olisi viallinen, mikä johtaa virheilmoitukseen. Toinen vaihtoehto on, että laitteessa on toimintahäiriö. B# D# F# ilmaisee laitteen sijainnin PCI-väylässä.


2. Bus/Device/Function-tietojen selvittäminen

a. Bus/Device/Function-tiedot voi tarkistaa DSET-hakemistossa olevasta XML-tiedostosta

Kun järjestelmässä luodaan DSET-raportti, tiedosto binrawxmlslots.xml ilmestyy luodun kokoelman hakemistoon.

 

SLN78547_en_US__21306506864560.DSET_slot.xml
Kuva 1: DSET-kansio

 

Avaa tiedosto Internet Explorerissa tai muussa selaimessa kaksoisnapsauttamalla sitä. Kukin laite on lueteltu nimen mukaan, ja kunkin nimen alla on kohdat , ja .

SLN78547_en_US__31306507113938.DSET_BUSDEVFUNC
Kuva 2: Avattu IE:ssä


b. Voit tarkistaa Ominaisuudet-ikkunat Windowsin Laitehallinnasta

Avaa Windowsin Laitehallinta (vain Windows) ja napsauta hiiren kakkospainikkeella laitetta, jonka haluat tarkistaa. Valitse Ominaisuudet ja tarkista Yleiset-välilehden Sijainti-kohdan tiedot.

 

SLN78547_en_US__41266947466432.1
Kuva 3: Ominaisuudet-ikkuna


c. Tarkista rekisterimerkinnät

Rekisterin sijainti on Hklm\system\currentcontrolset\enum\PCI\. Kutakin alikansiota on napsautettava erikseen, jotta sen tiedot tulevat näkyviin oikeanpuoleiseen ruutuun.

 

SLN78547_en_US__51266947530527.2
Kuva 4: Rekisterieditori-ikkuna


Cause

Laitteessa voi ilmetä virhe muutamasta syystä. Ohjaimet tai laiteohjelmisto voivat saada laitteen käyttäytymään kuin se olisi viallinen, mikä johtaa virheilmoitukseen. Toinen vaihtoehto on, että laitteessa on toimintahäiriö.

 

Resolution

3. Vianmäärityksen vaiheet

Kun viallinen laite on tunnistettu, voit aloittaa vianmäärityksen.

  1. Järjestelmän kaikkien laiteohjelmistojen on oltava ajan tasalla ennen seuraavien vaiheiden aloittamista. Suosittelemme käyttämään ISO-käynnistystiedostoa.
  2. Aseta laite uudelleen paikalleen (jos mahdollista) ja käynnistä järjestelmä uudelleen. Palvelimen tapahtumaloki on poistettava ennen tätä. Muuten vanha virheilmoitus näkyy uudelleen.
  3. Irrota laite järjestelmästä ja käynnistä järjestelmä uudelleen. Palvelimen tapahtumaloki on poistettava ennen tätä. Muuten vanha virheilmoitus näkyy uudelleen.
  4. Testaa laitetta toisessa paikassa, jos mahdollista.

Affected Products

Servers
Article Properties
Article Number: 000131693
Article Type: Solution
Last Modified: 29 Aug 2023
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.