Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

Intel Wireless Display (WiDi) Users May Encounter Various Issues in the Windows 10 Operating System

Summary: This article provides the information about the Wireless Display (WiDi) feature encountering various issues in Windows 10.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

No symptom information.

Cause

No cause information.

Resolution

Wireless Display (WiDi) in Windows 10

Note: Intel WiDi has been discontinued by Intel. This article remains as general information knowledge.

During pre-release testing of Dell computers, Users encountered various problems when trying to use Intel WiDi External Link with Windows 10. These issues include but are not limited to:

  • Network Connectivity Issues
  • Degraded Audio
  • Jittery Video
  • Hanging of the Wireless Display

Solution

The issue was resolved with Windows 10 Threshold 2 (TH2), but ensure that the computer has been updated to the latest version of Windows 10.

Note: Under normal circumstances, most non-Domain configured Windows 10 computers should automatically install this update during the normal Windows update process.

Back to Top

Article Properties
Article Number: 000129852
Article Type: Solution
Last Modified: 06 Oct 2022
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.