Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

Řešení chyby "No Bootable Device Found ve starším režimu" v počítačích Dell

Summary: Řešení chyby "Nebyla nalezena žádná spouštěcí zařízení" na noteboocích a počítačích. Zjistěte, jak vyřešit problém, kdy není k dispozici, rozpoznáno nebo nalezeno spouštěcí zařízení přepnutím do režimu UEFI a přeinstalací systému Windows 10 nebo Linux. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Podle níže uvedených pokynů vyřešte následující chybovou zprávu:

Chyba No boot device Found se zobrazí, když je spouštěcí sekvence nastavena na režim Legacy nebo když je operační systém nainstalován v režimu Legacy.


Chyba „No boot device found“

Po instalaci operačního systému se může zobrazit následující chyba: Nebylo nalezeno žádné spouštěcí zařízení.
K této chybě dochází, když je spouštěcí sekvence systému BIOS zařízení nastavena na režim Legacy.

Chyba „No boot device found“

Pokud je operační systém nainstalován v režimu Legacy, zobrazí se po restartování počítače chybová zpráva. Chybu nelze opravit změnou nastavení systému BIOS zpět na Unified Extensible Firmware Interface (UEFI). Je třeba přeinstalovat operační systém.

Poznámka:
  • Tyto konkrétní počítače Dell podporují pouze operační systémy Windows 10 a vyšší a Linux v režimu spouštění UEFI.
  • Před pokusem o přeinstalaci operačního systému se ujistěte, že je v systému BIOS povolen režim UEFI.
  • Použití optické jednotky k instalaci operačního systému není ve režimu Legacy podporováno, protože v nabídce spouštění není k dispozici možnost optické jednotky.
  • Výše uvedené počítače Dell jsou vybaveny procesorem Coffee Lake 7. generace (a vyšší). Počítače jsou navrženy výhradně pro spouštění v UEFI; Spouštěcí prostředí.
  • V důsledku toho se operační systém nespustí, pokud je v těchto počítačích vybrán režim spouštění Legacy.

Cause

V systému BIOS je nastaven nesprávný režim spouštění.

Resolution

Pokud je operační systém nainstalován s rozhraním UEFI před změnou spouštěcí sekvence, lze počítač obnovit změnou spouštěcí sekvence zpět na UEFI.

Pokud je operační systém nainstalován v režimu Legacy, nelze počítač obnovit změnou spouštěcí sekvence zpět na režim UEFI.
Je třeba přeinstalovat operační systém.

Při přeinstalaci systému Windows 10 nebo vyššího postupujte následovně:

  1. Zapněte vypnutý počítač a pomocí klávesy F2 na obrazovce s logem Dell přejděte do nabídky nastavení systému BIOS.
  2. Vyberte možnost Boot sequence a změňte ji z hodnoty Legacy na UEFI . Poté klikněte na tlačítko Apply v pravém dolním rohu obrazovky.
    Změna možnosti Boot List Option z hodnoty Legacy na UEFI v nastavení systému BIOS
  3. Vyberte možnost Advanced Boot Options a zakažte možnost Enable Legacy Option ROMs. Poté klikněte na možnost Apply v pravém dolním rohu obrazovky:
    Možnost Enable Legacy Option ROMs v nastavení systému BIOS
  4. Vyberte možnost Secure Boot –> Secure Boot Enable a změňte nastavení z hodnoty Disabled na Enabled.
  5. Poté klikněte na tlačítko Apply v pravém dolním rohu obrazovky:
    Povolení možnost Secure Boot Enable v systému BIOS
  6. Klikněte na možnost Exit v pravém dolním rohu obrazovky a počkejte, až se počítač restartuje.
  7. Přeinstalujte operační systém Windows 10.

Operační systém Linux nainstalujete takto:

  1. Postupujte podle kroků 1 až 3 výše pro instalaci systému Windows 10 (tyto kroky jsou stejné pro instalaci systému Linux).
  2. Ověřte, zda je možnost Secure Boot > Enable v systému BIOS zakázána :
    Zakázání možnosti Secure Boot Enable v systému BIOS
  3. Vyberte možnost SATA Operation (> Operace SATA) – SATA Operation (Operace SATA) a změňte ji na režim AHCI :
    Povolení možnost SATA AHCI
  4. Klikněte na možnost Exit v pravém dolním rohu a počkejte, až se počítač restartuje.
  5. Přeinstalujte operační systém Linux.

Additional Information

Affected Products

OptiPlex 3060 Tower, OptiPlex 3060 Micro, OptiPlex 3060 Small Form Factor, OptiPlex 5060 Tower, OptiPlex 5060 Micro, OptiPlex 5060 Small Form Factor, OptiPlex 7060 Tower, OptiPlex 7060 Micro, OptiPlex 7060 Small Form Factor, Precision 3630 XL Tower , Precision 3430 Small Form Factor, Precision 3630 Tower ...
Article Properties
Article Number: 000128655
Article Type: Solution
Last Modified: 19 Nov 2024
Version:  11
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.