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Dell E2720HS Monitor Usage and Troubleshooting Guide

Summary: Learn how to set up and use Dell E2720HS monitor. Find troubleshooting instructions for common video or display issues.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Cause

No cause information available.

Resolution

For help with video or display issues such as no video or no display, blank or black screen, flickering, resolution or color issues, horizontal or vertical lines, etc. refer to an expanding section below.

The key features of Dell E2720HS monitor are:

  • 1920 x 1080 (16:9) resolution, plus full-screen support for lower resolutions
  • HDMI connection
  • On-Screen Display (OSD) adjustments for easy setup and screen optimization
  • Plug and play capable if supported by your computer
  • Tilt, swivel, height and rotating adjustment
  • 0.3 W standby power when in the sleep mode
  • Optimize eye comfort with a flicker-free screen
  • Dual built-in speakers
  • Height adjustment capable
  • Security-lock slot (optional)
WARNING: The possible long-term effects of blue light emission from the monitor may cause damage to the eyes, including eye fatigue or digital eye strain. ComfortView feature is designed to reduce the amount of blue light emitted from the monitor to optimize eye comfort.

This section provides some specifications of the Dell E2720HS monitor. To learn more about the specifications of the Dell E2720HS monitor, refer to the User Guide at the Dell Manuals website.

Panel technology
  • In-Plane Switching
Maximum resolution
  • 1920 x 1080 at 60Hz (16:9 aspect ratio)
Viewing angle
  • 178° (vertical) typical
  • 178° (horizontal) typical
Contrast ratio
  • 1000 to 1 (Typical)
Response time
  • 8 ms (Normal)
  • 5 ms (Fast)
Color gamut
  • 72% (CIE1931)/83%(CIE1976)
Color depth
  • 16.7 million colors
Ports and connectors
  • 1 x HDMI
  • 1 x VGA
  • 1 x Power Port

Ensuring that your Dell monitor is set up properly - assembling the monitor stand and setting up the monitor ergonomically, connecting the cables and organizing them, will only help make the viewing experience the best it possibly can be.


Attaching the stand

The standard monitor stand is detached when the monitor is shipped from the factory. To learn more about attaching the standard monitor stand, refer to the Setting Up the Monitor section in the User Guide of your Dell E2720HS monitor.
To learn how to set up any other stand with a monitor, refer to the respective stand setup guide for setup instructions.

CAUTION: Do not remove the monitor from the packaging box before attaching the stand.
 
NOTE: The Dell E2720HS monitor and stand is 6.11kg; handle with care when you lift or move this monitor.

Ergonomics

Where you put your monitor is almost as important as what model you buy. The monitor should be directly in front of you, at an arm’s length away (between 20-40 inches from your eyes), with the top edge of the screen at eye level when you’re sitting comfortably. You may need to adjust your chair height or the height of the monitor to achieve this.


Connecting your monitor to the PC

To connect your Dell E2720HS monitor to your PC:

  1. Turn off your PC and disconnect the power cable

  2. Connect the DisplayPort, or VGA cable to the corresponding video or display port on the back of your PC

To learn more about connecting your monitor to the PC, refer to the Dell knowledge-base article How do I connect a monitor to a PC?.

Use the buttons at the bottom of the monitor to access the On-Screen Display (OSD) menu of the monitor. To access the On-Screen Display (OSD) menu, press Button 5 (Figure 1) at the bottom of the monitor.

To learn more about how to use the On-Screen Display (OSD) menu, refer to the Operating Your Monitor section in the User Guide of Dell E2720HS monitor.

NOTE: Any changes you make are automatically saved when you move to another menu item, exit the OSD menu, or wait for the OSD menu to automatically close.

SLN320306_en_US__5E2220H_Front_Buttons_BK

Figure 1: Dell E2720HS Front Panel Buttons

Button Function Description
Button 1 Shortcut key/Preset Modes Use this button to choose from a list of preset color modes
Button 2 Shortcut key/Brightness/Contrast Use this button to adjust the brightness and contrast. Minimum is ‘0’ (-). Maximum is ‘100’ (+)
Button 3 Menu Use the MENU button to launch the On-Screen Display (OSD)
Button 4 Exit Use this button to exit the OSD main menu
Button 5 Power On/Off button (with LED indicator) A solid white light indicates the monitor is On and fully functional. Blinking white light indicates the power save mode
 

SLN320306_en_US__6E2220H_OSD_Controls_BK

Figure 2: Dell E2720HS OSD Controls

Button Function Description
Button 1 Up Use the Up button to increase values or move up
in a menu
Button 2 Down Use the Down button to decrease values or move
down in a menu
Button 3 OK Use the OK button to confirm your selection in a menu
Button 4 Back Use the Back button to go back to the previous menu

Resetting a monitor to factory defaults can help resolve many video or display issues. To reset your Dell E2720HS monitor to factory default settings, follow these instructions:

  1. Press Button 3 (Figure 2)on the monitor to enter the On-Screen Display (OSD) Menu.
  2. Press Button 1 or Button 2 to highlight Others option in the menu and press Button 3 to select.
  3. Press Button 1 or Button 2 to highlight Factory Reset option in the menu and press Button 3 to select.
  4. Press Button 3 to confirm the reset action.

SLN320306_en_US__6E2220H_OSD_Controls_BK

Figure 3: Dell E2720HS OSD Controls

If your Dell monitor has a blank or black screen, fuzzy or blurry image, flickering, distorted or any other screen abnormalities, running a diagnostic test will help determine if the Dell monitor is functioning normally. To learn more about diagnostic options on a Dell monitor, refer to the Dell knowledge-base article How do I run diagnostics on a Dell monitor?

It is always essential to isolate the monitor while troubleshooting your computer for the following scenarios:

  • No Power - Your computer is not powering ON or showing any signs of power.
  • No POST - Your computer is not showing any indication of activity, the screen might be blank and will not display the Dell logo during start-up.
  • No Video - You are unable to see any display on the screen, able to hear the windows chime but no display is seen.

Your Dell E2720HS Monitor provides a self-test feature check that allows you to check whether the monitor is functioning properly. If the monitor and computer are properly connected but the monitor screen remains dark, run the monitor self-test by performing the following steps:

  1. Turn off both your computer and the monitor.
  2. Unplug the video cable from the back of the computer. To ensure proper Self-Test operation, remove the video cables (VGA, DVI, HDMI or DisplayPort) from the back of the computer.
  3. Turn on the monitor.
  4. Turn off your monitor and reconnect the video cable: then turn on both your computer and the monitor.
  5. If your monitor screen remains blank after you use the previous procedure, check your video card (GPU) and computer, because your monitor is functioning properly.

Your Dell E2720HS monitor has a built-in diagnostic tool that helps to determine if the screen abnormality you are experiencing is a problem with the monitor or with the video card on your computer.

When you notice screen abnormalities like distortion, clarity, horizontal or vertical lines, color fade etc., it is always a good practise isolating the monitor by running the Built-In Diagnostics.

  1. Make sure that the screen is clean (no dust particles on the surface of the screen).
  2. Unplug the video cable(s) from the back of the computer or the monitor. The monitor will now enter self-test mode.
  3. On the front panel, press and hold Button 1 on the front panel for 5 seconds. A gray screen appears.
  4. Carefully inspect the screen for abnormalities.
  5. Press Button 1 on the front panel again. The color of the screen changes to red.
  6. Inspect the display for any abnormalities.
  7. Repeat step 5 and step 6 to inspect the display in green, blue, black, white and text screens.
  8. The test is complete when the white screen appears.
  9. Press Button 1 to exit the Built-In Self Test diagnostics.
NOTE: If you do not detect any screen abnormalities upon using the built-in diagnostic tool, the monitor is functioning properly. Check the video card (GPU) and the computer.
If you notice any abnormalities during Built-In Diagnostics, you may get the monitor repaired/replaced if it is under warranty by contacting Dell Technical Support.

During the LCD Monitor manufacturing process, it is not uncommon for one or more pixels to become fixed in an unchanging state which is hard to see and do not affect the display quality or usability. For more information, refer to the Dell knowledge-base article Dell LCD Monitor Pixel Guidelines.

This section provides information on troubleshooting steps that can help resolve the most common issues with the Dell E2720HS monitor. Alternatively, to learn more about troubleshooting common issues on Dell monitors, refer to the Dell knowledge-base article Troubleshooting Display or Video Issues on a Dell Monitor.

Common Problem What User Experiences Possible Solution
No Video - Power LED Off No picture
  • Make sure that the power cable connecting the monitor is properly connected and secure.
  • Verify that the power outlet is functioning properly using any other electrical equipment.
  • Make sure that the power button is depressed fully.
  • Test with known good cable and known good system if possible.
No Video - Power LED On No picture or no brightness.
  • Increase the brightness and contrast of the monitor through the On-Screen Display Menu (OSD).
  • Perform monitor self-test feature check.
  • Check for bent or broken pins in the video cable connector.
  • Reseat both ends of the video cable.
  • Try with a known good video cable.
  • Run the built-in diagnostics.
  • Make sure that the correct input source is selected via the Input Source Select button.
  • Test monitor with a known good system if available.
Poor Focus The picture is fuzzy, blurry or ghosting.
Shaky/Jittery Video Wavy picture or fine movement.
Missing Pixels The LCD screen has spots.
  • Cycle power on-off.
  • Pixel that is permanently off is a natural defect that can occur in LCD technology.
  • Run the built-in diagnostics.
Stuck-On/Off Pixels The LCD screen has a bright spot.
Brightness Problems Picture too dim or too bright.
Geometric Distortion Screen not centred correctly.
When using DisplayPort input, the positioning adjustments are not available.
Horizontal/Vertical Lines The screen has one or more lines.
When using DisplayPort input, the positioning adjustments are not available.
Synchronization Problems The screen is scrambled or appears torn.
  • Reset the monitor to the Factory Settings.
  • Perform Auto Adjust via On-Screen Display Menu (OSD).
  • Adjust Phase and Pixel Clock controls via On-Screen Display Menu (OSD).
  • Perform monitor self-test feature check to determine if the scrambled screen appears in self-test mode.
  • Check for bent or broken pins in the video cable connector.
  • Restart the computer in the power safe mode.
Safety-Related Issues Visible signs of smoke or sparks.
  • Do not perform any troubleshooting steps.
  • Contact Dell Technical Support immediately.
Intermittent Problems Monitor malfunctions on and off.
  • Make sure that the video cable is connected properly with the monitor and the computer.
  • Reset the monitor to the Factory Settings.
  • Run the self-test feature and determine if the intermittent problem occurs in the self-test mode.
Missing Color The picture does not have color.
  • Run the monitor self-test feature check.
  • Make sure that the video cable connecting the monitor to the computer is connected properly and is secure.
  • Check for bent or broken pins in the video cable connector.
Wrong Color Picture color is not good.
Image Retention from a Static Image Left on the Monitor for a Long Period Faint shadow from the static image appears on the screen.
  • Use the Power Management feature to turn off the monitor when it is not in use.
  • Alternatively, use a dynamically changing screensaver.
Screen image is too small Image is centred on the screen but does not fill the entire viewing area
Image Ghosting Fast-moving images leave a trail of shadow images

On certain video and applications with fast-moving images, imaging ghosting, which appears as a trailing shadow, may occur

Change the Response Time to Fastin the Display menu

No Input Signal when user controls are pressed No picture, the power LED light is white
  • Check the signal source. Ensure the computer is not in power saving mode by moving the mouse or pressing any key on the keyboard.
  • Make sure that the video cable is connected properly with the monitor and the computer.
  • Restart the computer.
The picture does not fill the entire screen The picture cannot fill the height or width of the screen
  • Due to different video formats (aspect ratio) of DVDs and videos, the monitor may display in the screen.
  • Run the built-in diagnostics.

To learn more about how to view or download the User Guides and Manuals for your Dell product, refer to the Dell knowledge-base article Manuals and Documentation for your Dell Product.


Frequently asked questions

Using Windows Display Settings

In Windows 10, Windows 8 or 8.1 and Windows 7:

  1. For Windows 8 and Windows 8.1 only, select the Desktop tile to switch to classic desktop view.
  2. Right-click on the desktop and click Screen Resolution.
  3. Click the dropdown list of the Screen Resolution and select 1920 x 1080.
  4. Click OK

Using the Nvidia Control Panel

To change the resolution using the Nvidia Control Panel:

  1. Right-click on the desktop and click Nvidia Control Panel.
  2. Click the + symbol next to Display on the left pane.
  3. Select Change Resolution under Display.
  4. In the dropdown menu on the right pane, select the resolution 1920 x 1080.
  5. Click Apply.

Using the AMD Catalyst Control Center

To change the resolution using the AMD Catalyst Control Center:

  1. Right-click on the desktop and click AMD Catalyst Control Center.
  2. Click the + symbol next to Display on the left pane.
  3. Select Change Resolution under Display.
  4. In the dropdown menu on the right pane, select the resolution 1920 x 1080.
  5. Click Apply.
NOTE: If you do not see the recommended resolution as an option, you may need to update the video card (GPU) driver by visiting the Dell Drivers & Downloads website or the video card (GPU) manufacturers website. To learn how to download and update a device driver, refer to the Dell knowledge-base article How do I download and install a device driver?

To reset the Dell E2720HS Monitor to factory defaults, refer to the Reset to Factory Settings section of this article.

The Dell E2720HS monitor has two built-in diagnostics that are available:

  • Self-Test Feature Check - The self-test feature check on the Dell E2720HS monitor allows you to check whether the monitor is functioning properly.
  • Built-In Self Test - The Dell E2720HS monitor has a built-in self-test that helps you identify if the screen abnormality is with the monitor or the video card (GPU) on your computer. When you notice screen abnormalities like distortion, clarity, horizontal or vertical lines, color fade etc., it is always a good practice to isolate the monitor by running the Built-In Diagnostics.

To learn how to run a diagnostic test, refer to the Running Diagnostics on Dell E2720HS Monitor section of this Dell knowledge-base article.

The Troubleshooting section of this Dell knowledge-base article provides information on troubleshooting common issues with the Dell E2720HS monitor. The section has troubleshooting steps on how to resolve power issues, video issues, color or clarity issues, distortion issues, horizontal or vertical lines, brightness issues or pixel issues etc.

To navigate the On-Screen Display (OSD) menu, use the buttons on the monitor. The monitor control buttons are usually on the right-hand side, either on the side, front or bottom of the monitor. To access the On-Screen Display (OSD) menu, press Button 3 on the monitor.

For more information on using the On-Screen Display (OSD) menu and different menu options, refer to the Operating Your Monitor section in the User Guide of your Dell E2720HS monitor.

Additional Information

Monitor icon More information and support for your Dell monitor, desktop, laptop, or tablet screen can be found on our Monitor Support site.


Out of Warranty support Out of warranty? No problem. Visit the Dell.com/support website and enter your Dell Service Tag and view our offers.

NOTE: Currently, offers are only available for US, Canada, UK, and France PC customers. Server and Storage not applicable.

Affected Products

Dell E2720HS
Article Properties
Article Number: 000123944
Article Type: Solution
Last Modified: 17 May 2024
Version:  6
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