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S2D ReadyNode - Cómo reemplazar un disco fallido

Summary: En este artículo, se explica cómo reemplazar un disco fallido en la configuración de S2D ReadyNode.

This article applies to   This article does not apply to 

Symptoms

Reemplazo del disco defectuoso

 

En caso de que el número de serie del disco objetivo sea "S400625X":

  1. Ejecute el siguiente comando para confirmar que el disco correspondiente se retiró del pool de almacenamiento.
    Si no se retiró, continúe con los pasos de la sección "Reemplazo de un disco no retirado".

    PS C:\> Get-PhysicalDisk -SerialNumber S400625X

    000122721_1.png

  2. Ejecute el siguiente comando para desconectar el disco correspondiente del pool de almacenamiento.

    PS C:\> $disk = Get-PhysicalDisk -SerialNumber S400625X
    
    	PS C:\> Get-StoragePool -FriendlyName s2d* | Remove-PhysicalDisk -PhysicalDisks ($disk)

    000122721_2.png

  3. Ejecute el siguiente comando para confirmar que se completó el trabajo de desconexión.

    PS C:\> Get-StorageJob

    000122721_3.PNG

  4. Reemplace el disco.

  5. Espere un momento y ejecute el comando del paso 3 para confirmar que el disco reemplazado se agregó al pool de almacenamiento.
    000122721_4.png

  6. Si es necesario, siga la matriz que aparece a continuación para actualizar el firmware del disco reemplazado.
    Matriz de soporte para las soluciones de Dell EMC para Microsoft Azure Stack HCI
    NOTA: Dado que la actualización de los conocimientos en japonés puede retrasarse, si se muestra el conocimiento de japonés, seleccione el inglés de la selección de idioma en la parte superior derecha y compruebe la información más reciente.

 

Cause

Reemplazo de un disco no retirado

 

Este paso es para el disco que no se retira debido a una falla predictiva, etc. Si lo desconecta del pool de almacenamiento para su reemplazo, cambie el estado a Retired manually.

NOTA: El siguiente comando es un ejemplo. Especifique el número de serie y continúe.

 

En caso de que el número de serie del disco objetivo sea "S400625X":

  1. Ejecute el siguiente comando para confirmar el disco de destino.

    PS C:\> Get-PhysicalDisk -SerialNumber S400625X

    000122721_5.png

  2. Ejecute el siguiente comando para cambiar el disco de destino a retirado.

    PS C:\ > Get-PhysicalDisk -SerialNumber S400625X | Set-PhysicalDisk -Usage Retired
  3. Ejecute el siguiente comando para confirmar que el disco de destino se retire.

    PS C:\Windows\system32> Get-PhysicalDisk -SerialNumber KZJRPYWG

    000122721_6.png

  4. Continúe con los pasos del 2 al 6 en la sección "Reemplazo del disco defectuoso".

 

Resolution

Información adicional (para identificar manualmente la ubicación del disco)

 

Para el administrador del servidor:

  1. Seleccione Servicio de archivos y servicio dealmacenamiento-Volumen-Pool>>de almacenamiento.

  2. Haga clic con el botón secundario en el disco objetivo en el que se encuentra el estado de uso, como Cancelar en el campo Disco físico, y seleccione Cambiar luz de unidad.

  3. Compruebe el indicador de estado de los discos en la parte frontal de un servidor e identifique la ubicación en la que parpadea el indicador.

  4. Después de identificarla, seleccione Cambiar luz de unidad nuevamente para dejar de parpadear.

 

Para PowerShell:

  1. Inicie PowerShell con privilegios de administrador.

  2. Ejecute el siguiente comando para confirmar el disco en el que OperationalStatus no es OK o HealthStatus no es Healthy.

    Get-PhysicalDisk | Where-Object {$_.OperationalStatus -ne "OK" -or $_.HealthStatus -ne "Healthy"} | ft FriendlyName,SerialNumber,OperationalStatus,HealthStatus,AdapterSerialNumber
  3. Ejecute el siguiente comando para identificar el host al que pertenece el disco correspondiente.

    NOTA: Para NVME, utilice AdapterSerialNumber en lugar de SerialNumber.
    NOTA: Ingrese la IP de iDRAC del nodo que configura S2D en el $ips.
    NOTA: Ingrese el valor del disco confirmado en el paso 2 en el $SerialNumber.
    NOTA: Cuando ejecute $cred, dado que se muestra la siguiente ventana emergente, ingrese la información de inicio de sesión de la consola web de iDRAC.
    000122721_7.png

    $CimOptions = New-CimSessionOption -SkipCACheck -SkipCNCheck -SkipRevocationCheck -Encoding Utf8 -UseSsl
    
    	$cred=(Get-Credential)
    
    	$ips=@('xx.xx.xx.xx','xx.xx.xx.xx','xx.xx.xx.xx','xx.xx.xx.xx')
    
    	$serialNumber = "xxxxxxxxxxxx"
    
    	foreach ($ip in $ips) {
    
    	$Session = New-CimSession -Authentication Basic -Credential $cred -ComputerName $ip -Port 443 -SessionOption $CimOptions
    
    	Get-CimInstance -Cimsession $Session -ClassName DCIM_PhysicalDiskView -Namespace 'root/dcim' |? {$_.serialNumber -eq $serialNumber} | ft PSComputerName, serialnumber,slot, DeviceDescription
    
    	}

    000122721_8.png

    Ejemplo de salida del número de serie del disco S400625X:
    000122721_9.png

  4. Si no se pudo identificar el disco fallido, haga parpadear todos los discos en buen estado para identificar el disco fallido.

    • Para Power Shell:

      Get-PhysicalDisk | Where-Object -Property HealthStatus -eq Healthy | Enable-PhysicalDiskIdentification

      Después de identificar, deje de parpadear.

      Get-PhysicalDisk | Where-Object -Property HealthStatus -eq Healthy | Disable-PhysicalDiskIdentification
    • Para iDRAC7/8: Marque todo, excepto el disco defectuoso, y parpadee y deje de parpadear.
      000122721_10.png

    • Para iDRAC9: Marque todo, excepto el disco defectuoso, y parpadee y deje de parpadear.
      000122721_11.png

Affected Products

Servers, Storage
Article Properties
Article Number: 000122721
Article Type: Solution
Last Modified: 28 Jul 2023
Version:  6
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