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S2D ReadyNode - How to replace a failed disk

Summary: This article provides how to replace a failed disk in the S2D ReadyNode configuration.

This article applies to   This article does not apply to 

Symptoms

Replacing the faulty disk

 

In case the serial number of the target disk is “S400625X”:

  1. Run the following command to confirm that the applicable disk is retired from the storage pool.
    If it is not retired, proceed with steps in the "Replacing a not retired disk" section.

    PS C:\> Get-PhysicalDisk -SerialNumber S400625X

    000122721_1.png

  2. Run the following command to detach the applicable disk from the storage pool.

    PS C:\> $disk = Get-PhysicalDisk -SerialNumber S400625X
    
    	PS C:\> Get-StoragePool -FriendlyName s2d* | Remove-PhysicalDisk -PhysicalDisks ($disk)

    000122721_2.png

  3. Run the following command to confirm that the detach job is completed.

    PS C:\> Get-StorageJob

    000122721_3.PNG

  4. Replace the disk.

  5. Wait for a while and run the command in step 3 to confirm that replaced disk is added to the storage pool.
    000122721_4.png

  6. If necessary, follow the Matrix below to update the firmware of the replaced disk.
    Support Matrix for Dell EMC Solutions for Microsoft Azure Stack HCI
    NOTE: Since the update of knowledge in Japanese might be delayed, if the Japanese knowledge is displayed select the English from the language selection at the upper right and check the latest information.

 

Cause

Replacing a not retired disk

 

This step is for the disk that is not retired due to predictive failure so on. If you detach it from the storage pool for replacement, change the status to Retired manually.

NOTE: The following command is an example. Specify the SerialNumber and proceed.

 

In case the serial number of the target disk is “S400625X”:

  1. Run the following command to confirm the target disk.

    PS C:\> Get-PhysicalDisk -SerialNumber S400625X

    000122721_5.png

  2. Run the following command to change the target disk to Retired.

    PS C:\ > Get-PhysicalDisk -SerialNumber S400625X | Set-PhysicalDisk -Usage Retired
  3. Run the following command to confirm that the target disk becomes Retired.

    PS C:\Windows\system32> Get-PhysicalDisk -SerialNumber KZJRPYWG

    000122721_6.png

  4. Proceed the steps 2-6 in the "Replacing the faulty disk" section.

 

Resolution

Additional Information (For identifying the disk location manually)

 

For Server Manager:

  1. Select File service and storage service->Volume->Storage pool.

  2. Right-click the target disk that the usage status is in such as cancel from the physical disk field and select Switch drive light.

  3. Check the status indicator of disks on the front of a server and identify the location where the indicator is blinking.

  4. After identifying, select Switch drive light again to stop blinking.

 

For PowerShell:

  1. Launch the PowerShell with administrator privileges.

  2. Run the following command to confirm the disk in which the OperationalStatus is not OK or the HealthStatus is not Healthy.

    Get-PhysicalDisk | Where-Object {$_.OperationalStatus -ne "OK" -or $_.HealthStatus -ne "Healthy"} | ft FriendlyName,SerialNumber,OperationalStatus,HealthStatus,AdapterSerialNumber
  3. Run the following command to identify the host that the applicable disk belongs to.

    NOTE: For NVME, use the AdapterSerialNumber instead of the SerialNumber.
    NOTE: Enter the iDRAC IP of the node that configures S2D to the $ips.
    NOTE: Enter the value of the disk that is confirmed in step 2 to the $SerialNumber.
    NOTE: When running $cred, since the following pop-up is displayed, enter the login information of the iDRAC Web console.
    000122721_7.png

    $CimOptions = New-CimSessionOption -SkipCACheck -SkipCNCheck -SkipRevocationCheck -Encoding Utf8 -UseSsl
    
    	$cred=(Get-Credential)
    
    	$ips=@('xx.xx.xx.xx','xx.xx.xx.xx','xx.xx.xx.xx','xx.xx.xx.xx')
    
    	$serialNumber = "xxxxxxxxxxxx"
    
    	foreach ($ip in $ips) {
    
    	$Session = New-CimSession -Authentication Basic -Credential $cred -ComputerName $ip -Port 443 -SessionOption $CimOptions
    
    	Get-CimInstance -Cimsession $Session -ClassName DCIM_PhysicalDiskView -Namespace 'root/dcim' |? {$_.serialNumber -eq $serialNumber} | ft PSComputerName, serialnumber,slot, DeviceDescription
    
    	}

    000122721_8.png

    Example output of disk serial number S400625X:
    000122721_9.png

  4. If the failed disk could not be identified, blink all the healthy disks to identify the failed disk.

    • For Power Shell:

      Get-PhysicalDisk | Where-Object -Property HealthStatus -eq Healthy | Enable-PhysicalDiskIdentification

      After identifying, stop blinking.

      Get-PhysicalDisk | Where-Object -Property HealthStatus -eq Healthy | Disable-PhysicalDiskIdentification
    • For iDRAC7/8: Tick all except the failed disk and blink and unblinking.
      000122721_10.png

    • For iDRAC9: Tick all except the failed disk and blink and unblinking.
      000122721_11.png

Affected Products

Servers, Storage
Article Properties
Article Number: 000122721
Article Type: Solution
Last Modified: 28 Jul 2023
Version:  6
Find answers to your questions from other Dell users
Support Services
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Article Properties
Article Number: 000122721
Article Type: Solution
Last Modified: 28 Jul 2023
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.