Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

S2D ReadyNode - Arızalı diski değiştirme

Summary: Bu makalede, S2D ReadyNode yapılandırmasında başarısız bir diskin nasıl değiştirileceği açıklanmaktadır.

This article applies to   This article does not apply to 

Symptoms

Arızalı diski değiştirme

 

Hedef diskin seri numarasının "S400625X" olması durumunda:

  1. İlgili diskin depolama havuzundan kaldırıldığını onaylamak için aşağıdaki komutu çalıştırın.
    Kullanımdan kaldırılmamışsa "Kullanımdan kaldırılmamış bir diski değiştirme" bölümündeki adımlarla devam edin.

    PS C:\> Get-PhysicalDisk -SerialNumber S400625X

    000122721_1.png

  2. İlgili diski depolama havuzundan ayırmak için aşağıdaki komutu çalıştırın.

    PS C:\> $disk = Get-PhysicalDisk -SerialNumber S400625X
    
    	PS C:\> Get-StoragePool -FriendlyName s2d* | Remove-PhysicalDisk -PhysicalDisks ($disk)

    000122721_2.png

  3. Ayırma işinin tamamlandığını onaylamak için aşağıdaki komutu çalıştırın.

    PS C:\> Get-StorageJob

    000122721_3.PNG

  4. Diski değiştirin.

  5. Bir süre bekleyin ve değiştirilen diskin depolama havuzuna eklendiğini onaylamak için 3. adımdaki komutu çalıştırın.
    000122721_4.png

  6. Gerekirse değiştirilen diskin bellenimini güncellemek için aşağıdaki Matrisi izleyin.
    Microsoft Azure Stack HCI için Dell EMC Çözümlerine Yönelik Destek Matrisi
    NOT: Japonca bilgi güncellemesi gecikebileceğinden, Japonca bilgisi görüntüleniyorsa sağ üstteki dil seçiminden İngilizce'yi seçin ve en son bilgileri kontrol edin.

 

Cause

Kullanımdan kaldırılmamış bir diski değiştirme

 

Bu adım, tahmini başarısızlık vb. nedeniyle kullanımdan kaldırılmayan disk içindir. Değiştirme için depolama havuzundan ayırırsanız durumu manuel olarak Kullanımdan Kaldırıldı olarak değiştirin.

NOT: Aşağıdaki komut bir örnektir. SerialNumber değerini belirtin ve devam edin.

 

Hedef diskin seri numarasının "S400625X" olması durumunda:

  1. Hedef diski onaylamak için aşağıdaki komutu çalıştırın.

    PS C:\> Get-PhysicalDisk -SerialNumber S400625X

    000122721_5.png

  2. Hedef diski Kullanımdan Kaldırılmış olarak değiştirmek için aşağıdaki komutu çalıştırın.

    PS C:\ > Get-PhysicalDisk -SerialNumber S400625X | Set-PhysicalDisk -Usage Retired
  3. Hedef diskin kullanımdan kaldırıldığını onaylamak için aşağıdaki komutu çalıştırın.

    PS C:\Windows\system32> Get-PhysicalDisk -SerialNumber KZJRPYWG

    000122721_6.png

  4. "Arızalı diski değiştirme" bölümündeki 2-6 arasındaki adımlara devam edin.

 

Resolution

Ek Bilgiler (Disk konumunu manuel olarak tanımlamak için)

 

Sunucu Yöneticisi için:

  1. Dosya hizmeti ve depolama hizmeti-Birim-Depolama>>havuzu'nu seçin.

  2. Fiziksel disk alanından iptal et gibi kullanım durumunun bulunduğu hedef diske sağ tıklayın ve Sürücü ışığını değiştir seçeneğini belirleyin.

  3. Sunucunun önündeki disklerin durum göstergesini kontrol edin ve göstergenin yanıp söndüğü konumu belirleyin.

  4. Tanımladıktan sonra, yanıp sönmeyi durdurmak için Sürücü ışığını tekrar değiştir öğesini seçin.

 

PowerShell için:

  1. PowerShell'i yönetici ayrıcalıklarıyla başlatın.

  2. OperationalStatus'un OK olmadığı veya HealthStatus'un Healthy olmadığı diski onaylamak için aşağıdaki komutu çalıştırın.

    Get-PhysicalDisk | Where-Object {$_.OperationalStatus -ne "OK" -or $_.HealthStatus -ne "Healthy"} | ft FriendlyName,SerialNumber,OperationalStatus,HealthStatus,AdapterSerialNumber
  3. İlgili diskin ait olduğu ana bilgisayarı belirlemek için aşağıdaki komutu çalıştırın.

    NOT: NVME için SerialNumber yerine AdapterSerialNumber kullanın.
    NOT: $ips S2D'yi yapılandıran düğümün iDRAC IP'sini girin.
    NOT: 2. adımda onaylanan diskin değerini $SerialNumber girin.
    NOT: $cred çalıştırırken aşağıdaki açılır pencere görüntülendiğinden, iDRAC Web konsolunun oturum açma bilgilerini girin.
    000122721_7.png

    $CimOptions = New-CimSessionOption -SkipCACheck -SkipCNCheck -SkipRevocationCheck -Encoding Utf8 -UseSsl
    
    	$cred=(Get-Credential)
    
    	$ips=@('xx.xx.xx.xx','xx.xx.xx.xx','xx.xx.xx.xx','xx.xx.xx.xx')
    
    	$serialNumber = "xxxxxxxxxxxx"
    
    	foreach ($ip in $ips) {
    
    	$Session = New-CimSession -Authentication Basic -Credential $cred -ComputerName $ip -Port 443 -SessionOption $CimOptions
    
    	Get-CimInstance -Cimsession $Session -ClassName DCIM_PhysicalDiskView -Namespace 'root/dcim' |? {$_.serialNumber -eq $serialNumber} | ft PSComputerName, serialnumber,slot, DeviceDescription
    
    	}

    000122721_8.png

    Disk seri numarası S400625X örnek çıktısı:
    000122721_9.png

  4. Arızalı disk belirlenemiyorsa arızalı diski belirlemek için tüm iyi durumdaki diskleri yanıp sönerek arızalı diski belirleyin.

    • Power Shell için:

      Get-PhysicalDisk | Where-Object -Property HealthStatus -eq Healthy | Enable-PhysicalDiskIdentification

      Tanımladıktan sonra yanıp sönmeyi durdurun.

      Get-PhysicalDisk | Where-Object -Property HealthStatus -eq Healthy | Disable-PhysicalDiskIdentification
    • iDRAC7/8 için: Arızalı disk hariç tümünü işaretleyin ve yanıp sönüyor ve yanıp sönüyor.
      000122721_10.png

    • iDRAC9 için: Arızalı disk hariç tümünü işaretleyin ve yanıp sönüyor ve yanıp sönüyor.
      000122721_11.png

Affected Products

Servers, Storage
Article Properties
Article Number: 000122721
Article Type: Solution
Last Modified: 28 Jul 2023
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.
Article Properties
Article Number: 000122721
Article Type: Solution
Last Modified: 28 Jul 2023
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.