Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

S2D ReadyNode - Як замінити вийшов з ладу диск

Summary: У цій статті описано, як замінити диск, що вийшов з ладу, в конфігурації S2D ReadyNode.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Заміна несправного диска

 

Якщо серійний номер цільового диска "S400625X":

  1. Виконайте наведену нижче команду, щоб підтвердити, що відповідний диск вилучено з пулу сховища.
    Якщо він не виведений з експлуатації, виконайте дії, описані в розділі «Заміна диска, який не вийшов з експлуатації».

    PS C:\> Get-PhysicalDisk -SerialNumber S400625X

    000122721_1.png

  2. Виконайте наступну команду, щоб від'єднати відповідний диск від пулу сховища.

    PS C:\> $disk = Get-PhysicalDisk -SerialNumber S400625X
    
    	PS C:\> Get-StoragePool -FriendlyName s2d* | Remove-PhysicalDisk -PhysicalDisks ($disk)

    000122721_2.png

  3. Виконайте наступну команду, щоб підтвердити, що завдання з від'єднання завершено.

    PS C:\> Get-StorageJob

    000122721_3.PNG

  4. Замініть диск.

  5. Зачекайте деякий час і виконайте команду на кроці 3, щоб підтвердити, що замінений диск додано до пулу зберігання.
    000122721_4.png

  6. При необхідності дотримуйтесь наведеної нижче матриці, щоб оновити прошивку заміненого диска.
    Матриця підтримки рішень Dell EMC для Microsoft Azure Stack HCI
    ПРИМІТКА: Оскільки оновлення знань японською мовою може затримуватися, якщо відображаються знання японської мови, виберіть англійську мову з вибору мови у верхньому правому куті та перевірте останню інформацію.

 

Cause

Заміна не списаного диска

 

Цей крок призначено для диска, який не виведено з експлуатації через передбачуваний збій тощо. Якщо ви від'єднаєте його від пулу зберігання для заміни, змініть статус на Вилучено вручну.

ПРИМІТКА: Прикладом є наступна команда. Вкажіть SerialNumber і продовжуйте.

 

Якщо серійний номер цільового диска "S400625X":

  1. Виконайте наступну команду, щоб підтвердити цільовий диск.

    PS C:\> Get-PhysicalDisk -SerialNumber S400625X

    000122721_5.png

  2. Виконайте наступну команду, щоб змінити цільовий диск на Retired.

    PS C:\ > Get-PhysicalDisk -SerialNumber S400625X | Set-PhysicalDisk -Usage Retired
  3. Виконайте наведену нижче команду, щоб підтвердити, що цільовий диск стає Вилучено.

    PS C:\Windows\system32> Get-PhysicalDisk -SerialNumber KZJRPYWG

    000122721_6.png

  4. Виконайте кроки 2-6 у розділі «Заміна несправного диска».

 

Resolution

Додаткова інформація (для визначення розташування диска вручну)

 

Для диспетчера серверів:

  1. Виберіть Служба обслуговування файлів і зберігання ->Пул томів-Сховища>.

  2. Клацніть правою кнопкою миші цільовий диск, на якому знаходиться статус використання, наприклад скасувати з поля фізичного диска, і виберіть Перемкнути світло диска.

  3. Перевірте індикатор стану дисків на передній панелі сервера та визначте місце, де блимає індикатор.

  4. Визначивши, знову виберіть Перемкнути індикатор приводу , щоб перестати блимати.

 

Для PowerShell:

  1. Запустіть оболонку PowerShell із правами адміністратора.

  2. Виконайте наступну команду, щоб підтвердити диск, на якому OperationalStatus не в порядку або HealthStatus не справний.

    Get-PhysicalDisk | Where-Object {$_.OperationalStatus -ne "OK" -or $_.HealthStatus -ne "Healthy"} | ft FriendlyName,SerialNumber,OperationalStatus,HealthStatus,AdapterSerialNumber
  3. Виконайте наступну команду, щоб визначити хост, до якого належить відповідний диск.

    ПРИМІТКА: Для NVME використовуйте AdapterSerialNumber замість SerialNumber.
    ПРИМІТКА: Введіть IP-адресу iDRAC вузла, який налаштовує S2D на $ips.
    ПРИМІТКА: Введіть у $SerialNumber значення диска, підтверджене на кроці 2.
    ПРИМІТКА: Під час запуску $cred, оскільки відображається наступне спливаюче вікно, введіть дані для входу у веб-консоль iDRAC.
    000122721_7.png

    $CimOptions = New-CimSessionOption -SkipCACheck -SkipCNCheck -SkipRevocationCheck -Encoding Utf8 -UseSsl
    
    	$cred=(Get-Credential)
    
    	$ips=@('xx.xx.xx.xx','xx.xx.xx.xx','xx.xx.xx.xx','xx.xx.xx.xx')
    
    	$serialNumber = "xxxxxxxxxxxx"
    
    	foreach ($ip in $ips) {
    
    	$Session = New-CimSession -Authentication Basic -Credential $cred -ComputerName $ip -Port 443 -SessionOption $CimOptions
    
    	Get-CimInstance -Cimsession $Session -ClassName DCIM_PhysicalDiskView -Namespace 'root/dcim' |? {$_.serialNumber -eq $serialNumber} | ft PSComputerName, serialnumber,slot, DeviceDescription
    
    	}

    000122721_8.png

    Приклад виведення серійного номера диска S400625X:
    000122721_9.png

  4. Якщо несправний диск визначити не вдалося, блимніть усіма справними дисками, щоб визначити несправний диск.

    • Для Power Shell:

      Get-PhysicalDisk | Where-Object -Property HealthStatus -eq Healthy | Enable-PhysicalDiskIdentification

      Після ідентифікації перестаньте моргати.

      Get-PhysicalDisk | Where-Object -Property HealthStatus -eq Healthy | Disable-PhysicalDiskIdentification
    • Для iDRAC7/8: Відзначте галочками всі, крім несправного диска, і блимайте і не блимають.
      000122721_10.png

    • Для iDRAC9: Відзначте галочками всі, крім несправного диска, і блимайте і не блимають.
      000122721_11.png

Affected Products

Servers, Storage
Article Properties
Article Number: 000122721
Article Type: Solution
Last Modified: 28 Jul 2023
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.