Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

Why does the HOST Operating System detect a Mass Storage Function device after I upgrade to iDRAC firmware 2.52.52.52 on 12G and 13G PowerEdge Servers?

Summary: This article shows how to resolve a Windows Mass Storage Function error , or as it is seen with a Linux environment, additional Avocent & Avocent Corp. Dell devices in LSUSB list

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Windows Users will notice a "Mass Storage Function" listed under Other Devices in Device Manager (Figure 1 [English-only]):

QNA44353_en_US__1I_12-13G-Error_Mass_Storage_Function_hs_v1 
Figure 1: The Mass Storage Function error in Device Manager

Linux Users will notice additional Avocent & Dell devices in LSUSB list, similar to those in Table 1 below:
Table 1: Additional Avocent & Dell devices in LSUSB list in [root@localhost ~]# lsusb list

Bus 001 Device 007: ID 0624:0252 Avocent Corp.
Bus 001 Device 006: ID 0624:0251 Avocent Corp. Virtual Mass Storage
Bus 001 Device 005: ID 413c:a102 Dell Computer Corp.

Resolution

Solution:

Fortunately, this is a cosmetic issue and has a few options to resolve the error message:

  • Option 1: Upgrade to the most recent version of iDRAC7/iDRAC8 firmware (minimally 2.60.60.60) or later version as available per platform.
  • Option 2: Ignore the devices from the Host Operating System as this is a cosmetic issue.
  • Option 3: If an iDRAC FW 2.60.60.60 or later is not available, optionally rollback the firmware to iDRAC firmware 2.50.50.50

Root Cause:

iDRAC7/iDRAC8 firmware release 2.52.52.52 included a kernel update that introduced this behavior. This is resolved in iDRAC firmware version 2.60.60.60 (minimum version) and later releases as available per platform.

 

Article Properties
Article Number: 000075157
Article Type: Solution
Last Modified: 21 Feb 2021
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.