Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

Il backup delle immagini delle macchine virtuali Avamar non riesce con errore: vSphere Task failed: 'Unable to access file since it is locked'.

Summary: Il problema si verifica normalmente quando il proxy non riesce ad annullare il mounting dei dischi dopo un backup con esito positivo, causando un problema di blocco.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



I log riportano l'errore che segue:
2020-01-27 09:31:25 avvcbimage Info <14631>: VM Disk Consolidation for '[Avamar_Prod_ClusterA_avamar] avamar03/avamar.vmx' task still in progress, sleep for 3 sec 2020-01-27 09:31:28 avvcbimage Error <16006>: vSphere Task failed: 'Unable to access file  since it is locked'. 2020-01-27 09:31:28 avvcbimage Error <14635>: VM Disk Consolidation for '[Avamar_Prod_ClusterA_avamar] avamar03/avamar03.vmx' task creation encountered a problem 2020-01-27 09:31:28 avvcbimage Info <40733>: VM Disk consolidation is not complete, moref 'vm-123456'. 2020-01-27 09:31:28 avvcbimage Warning <40644>: VM needs consolidation failed 
 

Cause

Il problema si verifica normalmente quando il proxy non riesce ad annullare il mounting dei dischi dopo un backup con esito positivo, causando un problema di blocco.

Resolution

Utilizzare la procedura riportata di seguito per risolvere il problema:

1) Assicurarsi che nessun backup sia in esecuzione e utilizzare i seguenti comandi sul nodo Avamar tramite Putty:

java -jar proxycp.jar --listsnapshots --cleanup
java -jar proxycp.jar --listproxydisk - cleanup
java -jar proxycp.jar --consolidatesnapshots --vm <REPLACEWITHVMNAME>

Se la procedura descritta in precedenza non funziona:

2) Eseguire manualmente il consolidamento tramite vSphere Web Client.

Se non funziona e il consolidamento ha esito negativo:

3) Contattare l'amministratore VMware e condividere il seguente articolo:
https://kb.vmware.com/s/article/2107795

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000069304
Article Type: Solution
Last Modified: 16 Oct 2021
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.