Symptoms
Trying to connect RecoverPoint clusters
When connecting RecoverPoint clusters (Normally newly installed) get error:
"Internal Error: Contact EMC support"
dm.log file shows no issue.
The RP installation log (/home/kos/installationLogs/server.log) shows:
2017-03-16 11:12:37,038 [CommandWorker-21] (Command.java:88) ERROR - Command#run() ServerException errorType[UNABLE_TO_EXECUTE_COMMAND] errorMessage[Unable to execute command. Can't add cluster. The Product Type of the cluster to be added is different] failure UID: 26e138b2-6abf-4a82-a5a0-d2d54a9b3967 com.kashya.installation.server.exceptions.CommandFailedException: Unable to execute command. Can't add cluster. The Product Type of the cluster to be added is different
Cause
Both clusters do not share the same product type.
One cluster was installed with the RecoverPoint/SE installer, the other was installed with the RecoverPoint installer.
This usually happens when one site is VNX and the other is Unity/VNXe/XtremIO
The VNX site was installed as RecoverPoint/SE, while the other site was installed with RecoverPoint for Unity/VNXe with RecoverPoint/SE license
Resolution
Resolution:
Both clusters must have the same installation type.
If there are only 2 clusters, each with VNX, they need to be installed with RecoverPoint/SE installer
If there any of the sites run on VNXe/Unity/XtremIO, ALL sites must be installed as RecoverPoint (Not RecoverPoint/SE)
Re-install the site that was installed wrongly
Affected Products
RecoverPoint SE
Products
RecoverPoint, RecoverPoint CL, RecoverPoint EX, RecoverPoint SE