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NetWorker: Solaris NetWorker Client Failed to Back up with "Cannot bind socket to connection port"

Summary: Connection ports: 10001-30000 allows the daemons to maintain connections on the Solaris host when backups report "Cannot bind socket to connection port in configured port range on system : Cannot assign requested address." ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • The scheduled backup of the Solaris host occasionally reports:
61320:savefs: Cannot bind socket to connection port in configured port range on system <Client_name>: Cannot assign requested address
61320:savefs: Cannot bind socket to connection port in configured port range on system <Client_name>: Cannot assign requested address
97512:savefs: Cannot access NetWorker server '<NetWorker_server_name>': Remote system error - Cannot assign requested address
savefs <Client_name>: failed.

 

  • The daemon.raw file on the client reports:
61320 1483533202 3 1 126 3 38646 0 <Client_name> nsrexecd SYSTEM error 79 Cannot bind socket to connection port in configured port range on system %s: %s 2 12 10 <Client_name> 24 31 Cannot assign requested address - Port is free

NetWorker: How to use nsr_render_log

 

  • The netstat command on the client has CLOSE_WAIT s for 7937 and 7938.
root@<Client_Name> # netstat -an | grep -i 7938
<ip_address_1>.37938 <ip_address_1>.9151 49878 0 49152 0 CLOSE_WAIT
<ip_address_1>.47938 <ip_address_1>.9151 49877 0 49152 0 CLOSE_WAIT
<ip_address_1>.57938 <ip_address_1>.9151 49877 0 49152 0 CLOSE_WAIT
 
root@fmsprochk1 # netstat -an | grep -i 7937
<ip_address_1>.37937 <ip_address_1>.9151 49875 0 49152 0 CLOSE_WAIT
<ip_address_1>.57937 <ip_address_1>.9151 49878 0 49152 0 CLOSE_WAIT
<ip_address_1>.47937 <ip_address_1>.9151 49878 0 49152 0 CLOSE_WAIT

 

  • The /etc/hosts file on the client has:
::1 localhost
127.0.0.1 localhost localhost.localdomain

 

  • Confirmed with ipfstat -io that the firewall (ip filter) is not running nor configured.

 

Cause

The Solaris host was unable to assign and maintain ports with the "connection ports: 0-0

 

Resolution

Update the connection ports used on the client.

  1. Log in to the client as root.

  2. Run the following nsrports command to set the connection port range from default (0-0) to the legacy port range (10001-30000):
    nsrports -C 10001-30000

  3. Verify the new port setting by running nsrports with no additional flags.

[root@lnx-client02]:~# nsrports
Service ports: 7937-9936
Connection ports: 10001-30000

 

Work around: Stopping the NetWorker daemons on the client, and using kill to end any remaining daemons, then starting the daemons allows the backups to work for some time.

 

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000054868
Article Type: Solution
Last Modified: 23 Feb 2024
Version:  5
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