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NetWorker: Impossibile eseguire il backup del client Solaris NetWorker con "Cannot bind socket to connection port"

Summary: Porte di connessione: 10001-30000 consente ai daemon di mantenere le connessioni sull'host Solaris quando i backup segnalano "Cannot bind socket to connection port in configured port range on system : Impossibile assegnare l'indirizzo richiesto." ...

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Article Content


Symptoms

  • Il backup pianificato dell'host Solaris segnala occasionalmente:
61320:savefs: Cannot bind socket to connection port in configured port range on system <Client_name>: Cannot assign requested address
61320:savefs: Cannot bind socket to connection port in configured port range on system <Client_name>: Cannot assign requested address
97512:savefs: Cannot access NetWorker server '<NetWorker_server_name>': Remote system error - Cannot assign requested address
savefs <Client_name>: failed.

 

  • Il file daemon.raw nei report del client:
61320 1483533202 3 1 126 3 38646 0 <Client_name> nsrexecd SYSTEM error 79 Cannot bind socket to connection port in configured port range on system %s: %s 2 12 10 <Client_name> 24 31 Cannot assign requested address - Port is free

NetWorker: Come utilizzare nsr_render_log (in inglese)

 

  • Il comando netstat sul client ha CLOSE_WAIT s per 7937 e 7938.
root@<Client_Name> # netstat -an | grep -i 7938
<ip_address_1>.37938 <ip_address_1>.9151 49878 0 49152 0 CLOSE_WAIT
<ip_address_1>.47938 <ip_address_1>.9151 49877 0 49152 0 CLOSE_WAIT
<ip_address_1>.57938 <ip_address_1>.9151 49877 0 49152 0 CLOSE_WAIT
 
root@fmsprochk1 # netstat -an | grep -i 7937
<ip_address_1>.37937 <ip_address_1>.9151 49875 0 49152 0 CLOSE_WAIT
<ip_address_1>.57937 <ip_address_1>.9151 49878 0 49152 0 CLOSE_WAIT
<ip_address_1>.47937 <ip_address_1>.9151 49878 0 49152 0 CLOSE_WAIT

 

  • Il file /etc/hosts sul client dispone di:
::1 localhost
127.0.0.1 localhost localhost.localdomain

 

  • Confermato con ipfstat -io che il firewall (filtro IP) non è in esecuzione né configurato.

 

Cause

L'host Solaris non è stato in grado di assegnare e gestire le porte con "porte di connessione: 0-0

 

Resolution

Aggiornare le porte di connessione utilizzate sul client.

  1. Accedere al client come utente root.

  2. Eseguire i seguenti passaggi: nsrports per impostare l'intervallo delle porte di connessione dall'intervallo predefinito (0-0) all'intervallo di porte legacy (10001-30000):
    nsrports -C 10001-30000

  3. Verificare la nuova impostazione della porta eseguendo nsrports senza flag aggiuntivi.

[root@lnx-client02]:~# nsrports
Service ports: 7937-9936
Connection ports: 10001-30000

 

Soluzione alternativa: Interrompendo i daemon di NetWorker sul client e utilizzando kill per terminare eventuali daemon rimanenti, l'avvio dei daemon consente ai backup di funzionare per un certo periodo di tempo.

 

Article Properties


Affected Product

NetWorker

Product

NetWorker

Last Published Date

23 Feb 2024

Version

5

Article Type

Solution