VxRail: Node May Show an Error with vSphere HA Agent Cannot Be Installed or Configured

Summary: During an upgrade, the node may show an error with the vSphere HA agent cannot be installed or configured.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

VxRail: During upgrade node may show error with "vSphere HA agent cannot be installed or configured".

The VxRail upgrade script is trying to place the server in maintenance mode which it is waiting to do but cannot. 
All the other three nodes show error: "vSphere HA agent cannot be installed or configured".

Cause

One node in the cluster may be running all the VMs. The VxRail upgrade script is trying to place the server in maintenance mode which it is waiting to do but cannot. All the other three nodes show error: "vSphere HA agent cannot be installed or configured".

Resolution

To resolve this issue, disable the HA on the cluster and reenable it. 

To disable vSphere HA in the vSphere Web Client:

  1. Log in to the vSphere Web Client. 
  2. From the Home screen, click Hosts and Clusters
  3. Locate the cluster. 
  4. Right-click the cluster and click Edit Settings
  5. Clear the Turn On VMware HA option. 
  6. Click OK.

To enable HA in the vSphere Web Client:

  1. Log in to the vSphere Web Client. 
  2. From the Home screen, click Hosts and Clusters
  3. Locate the cluster. 
  4. Right-click the cluster and click Edit Settings
  5. Select Turn On VMware HA option. 
  6. Click OK

Affected Products

VxRail 460 and 470 Nodes

Products

VxRail 460 and 470 Nodes
Article Properties
Article Number: 000054779
Article Type: Solution
Last Modified: 17 Apr 2026
Version:  10
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.