Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

Resolución de alto uso de la unidad de disco duro y CPU durante escaneos de Windows Defender

Summary: En el siguiente artículo, se aborda la resolución de un problema con el bloqueo de la laptop o la computadora de escritorio. Esto se debe al análisis de Windows Defender. Fuerza hasta un 100 % de uso de la unidad de disco duro (unidad de disco duro) y la unidad central de procesamiento (CPU) del dispositivo. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Cause

¿Se bloquea su laptop o computadora de escritorio durante los análisis de Windows Defender?

 

¿Su laptop o computadora de escritorio se bloquea durante los análisis de Windows Defender?

Cuando comprueba el rendimiento del sistema en una aplicación, como el Explorador de procesos, es MsMpEng.exe muestra un uso excesivo de los recursos de laptops o computadoras de escritorio?

¿Esto hace que el dispositivo se ralentice lentamente o se bloquee mediante el uso del 80 % al 100 % de los recursos de los dispositivos?

Si cualquiera de las afirmaciones anteriores es verdadera, debe leer la siguiente sección de este artículo.

Resolution

¿Por qué pasa esto?

 

Las siguientes secciones son los métodos que Recomienda Microsoft para detener el MxMpEng.exe el archivo cause un alto uso del disco duro y la CPU en su laptop o computadora de escritorio.

  • MsMpEng.exe es el proceso principal de la aplicación antimalware Windows Defender.
  • Windows Defender viene preinstalado en Windows 11 y Windows 10, pero es una descarga opcional en sistemas operativos antiguos como Windows 7 y 8.
  • Este problema con MsMpEng.exe Tomar el 100 % del disco duro y la CPU suele ocurrir cuando Windows Defender está escaneando la laptop o el escritorio en busca de malware. El análisis de Windows Defender se atasca en unos pocos archivos mientras se busca malware. Cuando eso sucede, se debe restringir o deshabilitar para volver a su uso normal.


Volver al principio


 

Método I: Asegúrese de que no haya otro software adware, antimalware o antivirus instalado o que no esté correctamente eliminado

 

MsMpEng.exe - Su función es escanear archivos en busca de spyware y ponerlos en cuarentena o eliminarlos si son sospechosos. También analiza su laptop o computadora de escritorio en busca de gusanos conocidos, software dañino, virus y otros programas de este tipo.

Nota: Una mejor práctica es tener solo UN programa antimalware, antivirus o antispyware en su laptop o computadora de escritorio a la vez. No tenga varios programas en ejecución o instalación simultánea. Estos programas entrarán en conflicto y se detectarán entre sí como archivos para enviar a cuarentena y borrarse.
 

Windows Defender viene instalado de manera predeterminada con Windows 11 y Windows 10.

Esto significa que cualquier software adicional se instala después de Windows Defender: Windows Defender evita que se instalen o se ejecuten correctamente.

  1. Haga clic con el botón secundario en el icono Inicio y seleccione Panel de control desde el menú.

  2. Vaya a Programas y características y elimine cualquiera de estos tipos de programas que aparezcan allí.

Windows Defender no viene instalado en Windows 8 y Windows 7.

Una vez instalado Windows Defender, este evitará que cualquier software nuevo se instale o se ejecute correctamente.

Si se instaló Windows Defender después de estos otros tipos de software, entonces estos programas de software evitarán que Windows Defender se instale correctamente.

  1. Abra el Panel de control desde el menú Inicio.

  2. Vaya a Programas y características y elimine cualquiera de estos tipos de programas que aparezcan allí, incluido Windows Defender.

  3. Instale el programa que desea seguir utilizando.


Volver al principio


 

Método II: Evitar que Windows Defender escanee una carpeta específica en su laptop o computadora de escritorio

 

Una de las razones de la carga alta es el MxMpEng.exe archivo escaneando su carpeta. Si tiene una carpeta conocida en su laptop o computadora de escritorio que está causando un problema con Windows Defender, puede hacer que Windows Defender la ignore.

 
  1. Haga clic en el icono Inicio y escriba Windows Defender. Haga doble clic en el icono cuando aparezca en la lista de búsqueda.

  2. Haga clic en Configuración y seleccione Agregar exclusión en la parte inferior de la ventana

  3. Elija Excluir una carpeta y escriba la ruta del directorio deseado. En este caso: C:\program files\windows defender

msmpeng exclusion windows defender

(Figura 1: Ventana de configuración de Agregar exclusión)

  1. Abra la utilidad Windows Defender. Abra las secciones Herramientas y Opciones avanzadas.

  2. Abra Archivos y ubicaciones excluidos

  3. Ingrese la ruta del directorio deseado. En este caso: C:\program files\windows defender


Volver al principio


 

Método III: Disminuya la afinidad establecida de Windows Defender en su laptop o equipo de escritorio para ralentizar el análisis

 

Puede configurar el MsMpEng.exe para utilizar un procesador específico en el dispositivo a fin de evitar un alto uso de CPU. Sin embargo, reduce la velocidad de análisis de Windows Defender y hará que el ventilador funcione más lento de lo habitual. ¿Es una velocidad de análisis más lenta es mejor para usted que un alto uso de CPU? Aplique los siguientes pasos para establecer la afinidad en modo limitado.

 
  1. Abra el Administrador de tareas:

    • Haga clic con el botón secundario en la barra de tareas y seleccione Administrador de tareas.

    • Haga clic con el botón secundario en el icono Inicio y seleccione Administrador de tareas.

    • Haga clic en el icono Inicio y escriba Administrador de tareas, luego, haga clic en el icono del administrador de tareas en los resultados.

  2. Diríjase a la pestaña Detalles.

  3. Haga clic con el botón secundario en el nombre de proceso msmpeng.exe y seleccione Establecer afinidad.

Administrador de tareas de afinidades msmpeng

(Figura 2: Ventana Establecer afinidad en el Administrador de tareas)

  1. Seleccione el límite de CPU permitido para el proceso.

  1. Abra el Administrador de tareas:

    • Haga clic con el botón secundario en la barra de tareas y seleccione Administrador de tareas.

    • Presione las teclas Ctrl, Alt y Supr para que aparezca un menú en pantalla. Seleccione Task Manager.

    • Tipo Task Manager en el menú Inicio, haga clic en el icono del administrador de tareas o en el comando Abrir en los resultados de búsqueda.

  2. Vaya a la pestaña Procesos.

  3. Haga clic con el botón secundario en el proceso msmpeng.exe y seleccione Establecer afinidad.

  4. Elija cuáles núcleos de la CPU permitirá que el proceso utilice.

Nota: Para el uso normal de CPU, seleccione 50 % para MxMpEng.exe (Ese es un núcleo de una CPU de doble núcleo, dos núcleos de una CPU de cuatro núcleos, etc.).


Volver al principio


 

Método IV: Deshabilitación de Windows Defender a través de políticas de grupo en su laptop o escritorio

 

Desactivar Windows Defender es una respuesta importante que permitirá resolver su problema relacionado con el alto uso de CPU.

Nota: La protección de su laptop o computadora de escritorio se sufre sin ningún software antivirus instalado. Si deshabilita Windows Defender, asegúrese de tener otra aplicación antimalware para instalar en su lugar. Esta puede ser gratuita o pagada, pero asegúrese de tener algo instalado en lugar de Windows Defender.
  1. Abra una ventana de ejecución y escriba gpedit.msc:

    • Presione el logotipo de Windows y las teclas R al mismo tiempo.

    • Abra el menú Inicio y seleccione Run.

  2. Se abrirá el Editor de políticas de grupo. (Esto solo está disponible en las ediciones Enterprise y Pro. Existen varias formas para instalarlo en las ediciones Home, aunque tales opciones no se abordan en este artículo).

msmpeng group-policy windows defender

(Figura 3: Editor de políticas de grupo)

  1. Desplácese hacia abajo por la estructura de árbol a la izquierda de la pantalla hasta llegar a Configuración de la computadora. Ábrala y vaya a Plantillas administrativas y luego a Componentes de Windows. Busque el Antivirus Windows Defender.

  2. En el panel a la derecha de la pantalla, haga doble clic en Desactivar antivirus de Windows Defender.

  3. Se abre una ventana Propiedades , seleccione Activado, haga clic en Aplicar y aceptar para guardar el cambio y, a continuación, cierre todas las ventanas.


Volver al principio

Article Properties
Article Number: 000128249
Article Type: Solution
Last Modified: 29 Jan 2024
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.