Le redémarrage des agents de gestion dans VMware ESXi pour résoudre la création d’une machine virtuelle peut échouer, car l’agent ne parvient pas à récupérer les options de création de machine virtuelle à partir de l’hôte.
Summary:
Guide pas à pas pour résoudre l’erreur « VMware ESXi to resolve Virtual machine creation may fail because agent is unable retrieve VM creation options from the host » lorsqu’un
administrateur ne parvient pas à se connecter directement à l’hôte ESXi ou à le gérer sous vCenter Server.
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Virtual machine creation may fail because agent is unable to retrieve VM creation options from the host.
Avertissement : si LACP est configuré sur le réseau vSAN, ne redémarrez pas les agents de gestion sur les hôtes ESXi exécutant vSAN.
Le redémarrage des agents de gestion peut avoir un impact sur toutes les tâches en cours d’exécution sur l’hôte ESXi au moment du redémarrage.
Vérifiez si vous rencontrez des problèmes de stockage avant de redémarrer le service hôte daemon hostd ou services.sh.
Cause
Les agents ou services sur l’hôte ESXi ont peut-être été interrompus.
Resolution
Redémarrer les agents de gestion dans ESXi à l’aide de l’interface DCUI (Direct Console User Interface)
Connectez-vous à la console de votre hôte ESXi.
Appuyez sur F2 pour personnaliser le système.
Connectez-vous en tant qu’utilisateur root.
Utilisez les flèches haut/bas pour accéder à Troubleshooting Options, puis sélectionnez Restart Management Agents.
Appuyez sur Entrée.
Appuyez sur F11 pour redémarrer les services.
Au redémarrage du service, appuyez sur Entrée.
Appuyez sur Échap pour vous déconnecter.
Remarque : vous pouvez également redémarrer les services à l’aide du client hôte. Dans le client hôte, sélectionnez Host, puis Manage > Services, puis sélectionnez le service à redémarrer.
Redémarrer les agents de gestion dans ESXi à l’aide du shell ESXi ou de SSH
si LACP est activé et configuré, ne redémarrez pas les services de gestion à l’aide de la commande services.sh. Utilisez plutôt la commande /etc/init.d/module restart pour redémarrer les services indépendants.
Si le problème n’est pas résolu et que vous redémarrez tous les services qui font partie du script services.sh, déclenchez une interruption de service avant de passer au script.
Si NSX est configuré dans l’environnement, n’exécutez pas la commande /sbin/services.sh restart, car celle-ci entraîne le redémarrage de tous les services sur l’hôte ESXi.
Si vous devez redémarrer les agents de gestion sur l’hôte ESXi, redémarrez vpxa, host.d et fdm individuellement.
Si vous devez également exécuter la commande /sbin/services.sh restart car le redémarrage de chaque agent de gestion ne fonctionne pas, migrez toutes les machines virtuelles hors de l’hôte ESXi et, si possible, basculez l’hôte en mode maintenance.
Si vous n’êtes pas sûr que NSX for vSphere est installé sur un hôte ESXi, exécutez la commande suivante pour le vérifier :
esxcli software vib list --rebooting-image | grep esx-*
Recherchez les VIB suivants pour déterminer si NSX est installé sur l’hôte ESXi :
vsip-esx
esx-vxlan
Si vous utilisez des cartes graphiques partagées dans un environnement d’affichage (VGPU, vDGA, vSGA), n’utilisez pas la commande services.sh. Cette opération arrête le service xorg qui est responsable des cartes graphiques au niveau du système d’exploitation invité. En déconnectant les cartes graphiques du système d’exploitation invité, vous provoquez le blocage de la charge applicative VDI qui utilise les cartes graphiques partagées. Vérifiez que vous utilisez des cartes graphiques partagées uniquement pour redémarrer hostd et vpxa si vous n’êtes pas en mode maintenance.