Symptoms
The NetWorker VMware Protection integration is configured with the vProxy Appliance. A virtual machine backup (VM) fails with the following error in the 'session log':
vProxy: /opt/emc/vproxy/runtime/logs/vbackupd/<session-uuid>.log
YYYY/MM/DD HH:MM:SS INFO: [@(#) Build number: 101] Creating snapshot of virtual machine ...
YYYY/MM/DD HH:MM:SS TRACE: [@(#) Build number: 101] Sending create snapshot request to Snapshot Manager ...
YYYY/MM/DD HH:MM:SS ERROR: [@(#) Build number: 101] Failed to create snapshot.
YYYY/MM/DD HH:MM:SS ERROR: [@(#) Build number: 101] Unable to create snapshot of virtual machine: Failed to create snapshot.
YYYY/MM/DD HH:MM:SS INFO: [@(#) Build number: 101] Enabling storage migration of virtual machine ...
The vSphere Client shows the "Create virtual machine snapshot" tasks shows an error with details of "insufficient disk space on datastore".
Cause
The datastore where the VM resides did not have enough disk space to create the snapshot.
To verify this post backup, log into either the vSphere web client or vSphere thick client, and perform a manual snapshot of the issue virtual machine. It should fail with: insufficient disk space on datastore
Resolution
If the VM snapshot is failing due to space space restraints on the datastore, the following are some options available to accomplish the backup:
- Add more storage to the datastore where the VM resides.
- Storage vMotion the failing VM to a datastore that has enough space for the snapshot creation.
If the snapshot creation failing is not do to space restraints on the datastore, then looking under the 'Tasks/Events' tab in vSphere for the client, will provide reasoning as to why the snapshot is failing. Note: At this point, the snapshot failing will need to be troubleshot from VMware perspective.
Affected Products
VSI for VMware vSphere Web Client
Products
VMware vSphere Client Plug-ins