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Solución de problemas de DNS y problemas de resolución de nombres

Summary: Guía de solución de problemas de resolución de nombres

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Esta es una guía de solución de problemas de resolución de nombres.
 
Los problemas incluyen (pero no se limitan a):
  • El servidor no puede comunicarse con el cliente para realizar el respaldo.
  • El respaldo falla con cualquiera de los siguientes mensajes de error:
    • "Nombre del cliente": No se pudo buscar el nombre de address:'Backup_server_IP': nombre del nodo o nombre de servicio desconocidos.
    • El nombre de host para la dirección < IP IP_address> no se pudo determinar a través de DNS
    • Advertencia: no se puede resolver el < nombre >de host a <la dirección> IP; es posible que el servidor de nombres esté configurado erróneamente.
    • La dirección IP para el host '<host>' no se pudo determinar a través de DNS.
    • Error "Se agotó el tiempo de espera de la solicitud"
    • No se pudo abrir la conexión de DDBoost al host "DATA_DOMAIN_FQDN" de Data Domain: [5037]
    • Error: No se puede abrir la sesión en el dispositivo de ruta de respaldo "DATA_DOMAIN_FQDN": [5037] operación ilegal.

Cause

Puede haber varias causas:
  • Problemas de hardware o de LAN y WAN.
    • Un cable de red en algún lugar de la ruta está dañado, dañado o desconectado. (Cable CAT5 o conector RJ45, etc.)
    • Una NIC no funciona o no es compatible con el sistema operativo. (Falla del controlador o del hardware)
    • La intensidad de la señal no es buena. (pérdida de intensidad de atenuación con cable o inalámbrico)
  • Problemas con el servidor DNS.
  • Una computadora se movió de una VLAN a otra, pero mantuvo su configuración anterior.
  • Los archivos de host tienen entradas incorrectas,
  • La máquina local tiene una configuración de DNS antigua en la caché y no se ha actualizado.
  • El método de autenticación en el cliente y el servidor de NetWorker se cambió a oldauth.
  • Se cambió la configuración del firewall, DNS o ACL.

Resolution

Antes de iniciar cualquier solución de problemas de DNS, realice los siguientes tres pasos:

Si hay algún problema con estos tres pasos, entonces es un problema de hardware o conexión, no de DNS.
  1. Reinicie la máquina que presenta el problema. Esto le permite volver a la red.
  2. En "Administrador de dispositivos", compruebe los controladores y el estado del hardware y la conexión de red.
  3. Verifique que la dirección IP sea válida en la red local. 
Linux: ifconfig -a
Windows: ipconfig /all

Para obtener información adicional sobre la terminología y las herramientas del DNS, consulte: DNS: términos y herramientas

de soporteEl campo de resolución proporciona algunos pasos para solucionar problemas a nivel del sistema operativo. Para obtener documentación específica del producto, consulte la sección Información adicional de esta base de conocimientos.

NOTA: Cuando utilice el "Símbolo del sistema" de Microsoft Windows, haga clic con el botón secundario y seleccione "Ejecutar como administrador". Para los sistemas Linux, utilice privilegios elevados con sudo o cambie a root: sudo su - root

Comprobación 1 : Confirme el servidor DNS utilizado por los sistemas involucrados.

1. Ejecute la consulta nslookup en los hosts que observan problemas de conexión. Esto se debe hacer mediante el FQDN, el nombre corto y la dirección IP. Es posible que el FQDN se resuelva correctamente, pero si existen varias direcciones de búsqueda inversa, es posible que se devuelvan varias direcciones IP para un solo nombre de host, lo que puede causar un problema; Además, en algunos casos, la resolución del FQDN funcionará, pero el nombre corto no. Todo esto es indicativo de un problema de DNS.

FQDN
de nslookup nombre corto
nslookup IP_ADDRESS


2. Los comandos anteriores devuelven la dirección del servidor DNS utilizada. Asegúrese de que puede resolver el servidor DNS (FQDN, nombre corto, dirección IP) y haga ping al servidor DNS. Si se utiliza más de un servidor DNS, haga PING a cada servidor DNS. A continuación, haga ping con su dirección IP para verificar si la IP funciona, pero Name no.  

Haga ping DNS_SERVER_ADDRESS
 

Comprobación 2: compruebe el archivo HOSTS local del sistema.

  • Para Windows, localice: C:\Windows\System32\drivers\etc\hosts
  • Para Linux, localice: /etc/hosts
Si hay entradas para los sistemas involucrados, asegúrese de que las direcciones IP, los nombres de host y los alias se ingresen correctamente. Corrija o elimine las entradas incorrectas. Si hay varias entradas en un archivo de hosts para un solo sistema, solo se lee la primera entrada. Evite usar varias líneas para resolver una dirección en un solo sistema. Si se observa un problema de DNS, es posible que pueda solucionar el problema mediante la creación de entradas de archivos de hosts para que el sistema pueda resolver un nombre de host (o alias) en una dirección IP. 


Comprobación 3: haga ping a dos computadoras locales en la misma subred.  A continuación, haga ping en dos computadoras de diferentes subredes:  Haga ping al servidor desde el cliente, y al cliente desde el servidor, etc. Ping usando su "Nombre largo" y "Nombre corto": En ambas direcciones. A continuación, haga ping con la dirección IP de cada máquina para verificar si la IP funciona, pero Name no.

Comprobación 4 - Haga ping a "GOOGLE.COM" solo para verificar su conexión fuera de su edificio. Esto solo es necesario si la conexión no está en un networker local (LAN) aislado y se transmite a través de Internet (WAN).

    Comprobación 5 : en el servidor DNS, ingrese el nombre largo (FQDN) y también el nombre corto para que se resuelva en la misma dirección IP (hágalo para el servidor y el cliente). 

    Comprobación 6 : en el servidor DNS, la búsqueda directa e inversa debe funcionar. ¿Cómo configurar las zonas de búsqueda directa e inversa de DNS?

    Comprobación 7 : si el DNS está asignado estáticamente (ingresado manualmente en la máquina local), debe verificar los valores correctos en las propiedades de la red. Asegúrese de que esté dentro de su rango de IP local sin conflictos. 

    En Windows, haga clic en Inicio, busque el Panel de control y, a continuación, haga clic en Conexionesde redCambiar la configuración de TCP/IP Este hipervínculo lo redirige a un sitio web fuera de Dell Technologies.

    • Marque la casilla IP en la configuración de conexión de red en el sistema operativo. Verifique si alguien ingresó una dirección IP "Estática" o configúrela como no "Obtener automáticamente una dirección IP". Si utiliza una "IP estática" (dirección ingresada manualmente), asegúrese de que sea una IP válida en su LAN o VLAN. 

    En Linux, la configuración de los ajustes de IP y DNS puede variar según la distribución de Linux y los paquetes instalados en el sistema. Consulte la documentación específica del proveedor. 
     

    Comprobación 8 : Si el servidor DHCP asigna dinámicamente el DNS y accede a un cliente o servidor (o a cualquier host) con un nombre distinto de su nombre de host DNS, se necesita un registro de alias de DNS. 

    Comprobación 9: Configure las reglas de firewall para permitir paquetes TCP entrantes y salientes hacia y desde los puertos de servicio. Configure el rango de puertos de servicio y puerto de conexión para un servidor, cliente o nodo. En el caso de los productos Dell, consulte las guías oficiales de productos disponibles en Dell Support-NetWorker.  

    Comprobación 10: compruebe cualquier configuración de red local , como la lista de control de acceso (ACL) o las redes de área local virtual (VLAN). ¿Las dos máquinas se encuentran en diferentes VLAN o redes diferentes que no se comunican? Puede mencionar esto por los diferentes rangos de direcciones IP que se utilizan. El grupo de TI local modifica la ACL o las VLAN, si es necesario. Consulte la configuración del puerto "interno" y "externo" para comunicarse a través de un firewall.   


    Comprobación 11: Borre la caché de DNS mediante los siguientes comandos para Windows: 

    ¿Cómo vaciar la caché de DNS y volver a registrarse con DNS?

    Abra un "Símbolo del sistema", haga clic con el botón secundario y seleccione el tipo "Ejecutar como administrador" o "Usuario raíz"
    : IPCONFIG
    IPCONFIG /all: muestra la información de configuración completa.
    IPCONFIG /release [adapter]: libera la dirección IP del adaptador especificado.
    IPCONFIG /renew [adapter]: renueve la dirección IP del adaptador especificado.
    IPCONFIG /flushdns: depura la caché de resolución de DNS.
    IPCONFIG /registerdns: actualice todas las concesiones de DHCP y vuelva a registrar los nombres DNS.
    IPCONFIG /displaydns: muestra el contenido de la caché de resolución de DNS.
    IPCONFIG /showclassid adapter: muestra todos los ID de clase DHCP permitidos para el adaptador.
    IPCONFIG /setclassid adapter [classid]: modifica el ID de la clase DHCP.


    En Linux, el vaciado del DNS puede variar según la distribución de Linux y los paquetes instalados en el sistema. Consulte la documentación específica del proveedor. 


    Comprobación 12 : Utilice una prueba de ruta de seguimiento para verificar que la NIC esté activa y si el DNS funciona: 

    Linux: sudo traceroute TARGET_IP_ADDRESS
    Windows: tracert TARGET_IP_ADDRESS


    Comprobación 13 - Ahora pruebe su búsqueda de DNS en el DNS de Google con: nslookup 8.8.8.8

    • Debería devolver google=public-dns-a.google.com


    Comprobación 14 : el reenvío de puertos es cuando se conecta a un puerto en una máquina de gateway o enrutador y lo reenvía automáticamente a otro puerto en otra máquina. Si se utilizan "Port Mapping" o "Port Forwarding", verifique los números de puerto y si se encuentra dentro del rango de puertos necesario. Si estos están mal configurados o apuntan a puertos no válidos, no puede conectarse. 

    Comprobación 15 : Una dirección MAC es una dirección de hardware que identifica de manera exclusiva a cada nodo de una red. Cada NIC tendría una dirección MAC. Verifique si hay direcciones MAC en conflicto o si una de las direcciones MAC se colocó en una lista de bloqueo. Si es posible, pruebe la conexión con una tarjeta NIC diferente. 

    Additional Information

    Affected Products

    NetWorker

    Products

    NetWorker
    Article Properties
    Article Number: 000041288
    Article Type: Solution
    Last Modified: 09 Apr 2024
    Version:  6
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