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Troubleshooting DNS and Name Resolution Issues

Summary: Troubleshooting Guide for Name Resolution issues

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

This is a Troubleshooting Guide for Name Resolution issues.
 
Issues Include (but not limited to):
  • Server not able to communicate with Client to perform the backup.
  • Backup fails with any of the following error messages:
    • 'Client name': Couldn't look up the name of address:'Backup_server_IP':node name or service name unknown.
    • Host name for IP address <IP_address> could not be determined through DNS
    • Warning, cannot resolve host <hostname> to <IP address>, name server may be misconfigured.
    • IP address for host '<host>' could not be determined through DNS.
    • Error "Request timed out"
    • Failed to open DDBoost connection to DataDomain host "DATA_DOMAIN_FQDN": [5037]
    • Error: Unable to open session to backup path device "DATA_DOMAIN_FQDN": [5037] illegal operation.

Cause

There may be multiple causes:
  • Hardware or LAN and WAN problems.
    • A network cable somewhere in the path is bad or damaged or disconnected. (CAT5 cable or RJ45 connector, so forth)
    • A NIC is not working or not supported by your operating system. (Driver or Hardware failure)
    • The signal strength is not good. (wired or wireless attenuation loss of intensity)
  • DNS server problems.
  • A computer got moved from one VLAN to another but kept its old settings.
  • Host files have wrong entries,
  • Local machine has old DNS settings in the cache and has not updated itself.
  • The authentication method on both NetWorker server and client was changed to oldauth.
  • Settings in the Firewall, or DNS, or ACL have been changed.

Resolution

Before starting any DNS troubleshooting, perform the below three steps:

If there are any issues with these three steps, then it is a hardware or connection issue, not DNS.
  1. Reboot the machine having the problem. This allows it to bring itself back into the network.
  2. In "Device Manger" Check the Drivers and the status of your network hardware and connection.
  3. Verify that the IP address is valid in your local network. 
Linux: ifconfig -a
Windows: ipconfig /all

Additional information about DNS terminology and tools, see: DNS - Support Terms and Tools

The resolution field provides some operating system level troubleshooting steps. For Product Specific documentation, see the Additional Info section of this KB.

NOTE: When using Microsoft Windows "Command Prompt" right-click and choose "Run As Administrator". For Linux systems, use elevated privileges with sudo, or switch to root: sudo su - root

Check 1 - Confirm the DNS server used by the systems involved.

1. Run the nslookup query against the hosts observing connection issues. This should be done using the FQDN, shortname, and IP address. It is possible to have FQDN resolve correctly, but if multiple reverse lookup addresses exist, multiple IPs may be returned for a single hostname which can cause an issue; furthermore, in some instances FQDN resolution will work, but shortname does not. All these are indicative of a DNS issue.

nslookup FQDN
nslookup ShortName
nslookup IP_ADDRESS


2. The above commands return the DNS server address used. Make sure you can resolve the DNS server (FQDN, shortname, IP address) and ping the DNS server. If more than one DNS server is used, PING each DNS server. Then Ping using its IP Address to verify if the IP works but Name does not.  

ping DNS_SERVER_ADDRESS
 

Check 2 - Check the system's local HOSTS File.

  • For Windows locate: C:\Windows\System32\drivers\etc\hosts
  • For Linux locate: /etc/hosts
If there are any entries for the systems involved, make sure the IP addresses, hostnames, and aliases are entered correctly. Correct or remove any incorrect entries. If there are multiple entries in a hosts file for a single system, only the first entry is read. Avoid using multiple lines to resolve an address to a single system. If a DNS issue is observed, you may be able to work around the issue by creating hosts file entries so that the system can resolve a hostname (or alias) to an IP address. 


Check 3 - Ping two local computers in the same subnet.  Then ping two computers in different subnets:  Ping the Server from the Client, and the Client from the Server, so forth Ping using its "Long Name" and "Short Name": Both Directions. Then ping using the IP Address of each machine to verify if IP works but Name does not.

Check 4 - Ping 'GOOGLE.COM' just to verify your connection outside your building. This is only required if the connection is not on an isolated local networker (LAN) and goes over the Internet (WAN).

    Check 5 - In the DNS Server, enter long name (FQDN) and also the short name so that it resolves to the same IP Address (do this for the Server and Client). 

    Check 6 - In the DNS Server, both forward and reverse lookup must work. How to Configure DNS Forward & Reverse Lookup Zones?

    Check 7 - If your DNS is statically assigned, (manually entered on the local machine) you must verify the correct values in your network properties. Make sure it is within your local IP range with NO Conflicts. 

    On Windows, click Start, locate the Control Panel, and then click Network ConnectionsChange TCP/IP settings This hyperlink is taking you to a website outside of Dell Technologies.

    • Check the IP box in the Network Connection settings in the operating system. Verify if someone entered a 'Static' IP address or set it as not "Automatically Obtain an IP address." If you use a "Static IP" (manually entered address) make sure, it is a valid IP in your LAN or VLAN. 

    On Linux, Configuring IP and DNS settings can vary depending on the Linux distribution and packages installed on the system. See vendor-specific documentation. 
     

    Check 8 - If your DNS is dynamically assigned (by the DHCP server) and you access a Client or Server (or any host) by using a name other than its DNS hostname, a DNS Alias record is needed. 

    Check 9 - Set the Firewall rules to allow inbound and outbound TCP packets both to-and-from the Service ports. Set the connection port and service port range for a server, client, or node. For Dell products, see the official product guides available on Dell Support-NetWorker.  

    Check 10 - Check any Local Network Settings such as Access Control List (ACL), Virtual Local Area Networks (VLANs). Are the two machines on different VLAN's or different Networks that are not communicating? You can mention this by the different IP address ranges being used. Your local IT group modifies ACL or VLANS if needed. See the 'Inside' and 'Outside' Port settings to communicate through a Firewall.   


    Check 11 - Clear DNS Cache using the commands below for Windows: 

    How to flush the DNS Cache and Re-register with DNS?

    Open a "Command Prompt" right-click and choose "Run As Administrator" or "Root User"
    type: IPCONFIG
    IPCONFIG /all  - Display full configuration information.
    IPCONFIG /release [adapter] - Release the IP address for the specified adapter.
    IPCONFIG /renew [adapter] - Renew the IP address for the specified adapter.
    IPCONFIG /flushdns  - Purge the DNS Resolver cache.
    IPCONFIG /registerdns  - Refresh all DHCP leases and re-register DNS names.
    IPCONFIG /displaydns  - Display the contents of the DNS Resolver Cache.
    IPCONFIG /showclassid adapter  - Display all the DHCP class IDs allowed for adapter.
    IPCONFIG /setclassid adapter [classid]  - Modify the DHCP class id.


    On Linux, flushing DNS can vary depending on the Linux distribution and packages installed on the system. See vendor-specific documentation. 


    Check 12 - Use a Trace Route test to verify your NIC is active and if DNS is working: 

    Linux: sudo traceroute TARGET_IP_ADDRESS
    Windows: tracert TARGET_IP_ADDRESS


    Check 13 - Now test your DNS lookup to Google's DNS with: nslookup 8.8.8.8

    • It should return google=public-dns-a.google.com


    Check 14Port forwarding is where you connect to a port on a gateway machine or router and it automatically forwards you to another port on another machine. If 'Port Mapping' or 'Port Forwarding' is in use, verify port numbers and if it is within the required Port Range. If these are misconfigured or pointing to invalid Ports, you cannot connect. 

    Check 15 - A MAC address is a hardware address that uniquely identifies each node of a network. Each NIC would have a MAC address. Verify if there are conflicting MAC addresses or if one of the MAC addresses have been put on a block list. If possible, test the connection using a different NIC card. 

    Additional Information

    Affected Products

    NetWorker

    Products

    NetWorker
    Article Properties
    Article Number: 000041288
    Article Type: Solution
    Last Modified: 09 Apr 2024
    Version:  6
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