Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

External monitor blanking or flickering on TB16 and WD15 docks

Summary: Firmware updates available to resolve this blanking issue with the Dell TB16 and WD15 docking stations.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

TB16 Dell Thunderbolt or WD15 Type-C dock may experience the external monitor(s) randomly blank out. This can occur when you are on the newest BIOS and have installed all of the latest drivers.  The problem is not limited to a specific video output connection or host system. The problem may also be intermittent and change after a reboot.

Cause

Cause information is not available.

Resolution

Dell Engineering have created a new MST hub Firmware update for the TB16 and WD15 docks to resolve this problem.  Please download the FW from the Dell Support website to resolve the issue:

The TB16 Firmware is here: https://www.dell.com/support/home/drivers/driversdetails?driverid=h3yg7

The WD15 Firmware is here: https://www.dell.com/support/home/drivers/driversdetails?driverId=PM4JN

Additional Information

Affected Products

Dell Dock WD15, Dell Thunderbolt Dock TB16
Article Properties
Article Number: 000178068
Article Type: Solution
Last Modified: 30 aug 2024
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.