PowerFlex 3.x Windows Log Collection Fails

Summary: Automatic log collection, using the Gateway, from a Windows SDC host fails. A log bundle created during manual log collection, by running get_info.bat on a Windows host, does not contain ScaleIO components' logs. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Automatic log collection, using the Gateway, from Windows SDC fail with an error message similar to the following:

Command failed: Could not query installed components on node 10.0.0.1 due to: Invalid LIA session A login is required.
LIA service on the Windows host restarts automatically.

Manual execution of get_info.bat on a Windows host produces one or more messages similar to the following:

Cleaning c:\Windows\Temp\PRODUCT_NAME-getinfo
can not find directory c:\Progra~1\COMPANY_NAME\PRODUCT_NAME\TB
Gathering information from c:\Progra~1\COMPANY_NAME\PRODUCT_NAME\sds
can not find directory c:\Progra~1\COMPANY_NAME\PRODUCT_NAME\sds
can not find directory c:\Progra~1\COMPANY_NAME\PRODUCT_NAME\SDC
can not find directory c:\Progra~1\COMPANY_NAME\PRODUCT_NAME\lia
Zip "c:\Windows\Temp\PRODUCT_NAME-getinfo-tmp\WIN-787FF5MSK6U" --> c:\Windows\Temp\PRODUCT_NAME-getinfo\getInfoDump.zip
Archive c:\Windows\Temp\PRODUCT_NAME-getinfo\getInfoDump.zip created successfully
Note the messages include either or both of the strings COMPANY_NAME and PRODUCT_NAME.

 

Impact
Support information cannot be collected.

Cause

A software issue in LIA causes the service to restart during automatic log collection.

Incorrect configuration in get_info.bat causes logs from ScaleIO components to be skipped during log bundle creation.

Resolution

Perform the following steps:

1- In get_info.bat, locate the following line:

set PRODUCT=PRODUCT_NAME

If the line exists, replace it with the following line:

set PRODUCT=ScaleIO

2- In get_info.bat, locate the following line:

set COMPANY=COMPANY_NAME

If the line exists, replace it with the following line:

set COMPANY=EMC

3- Perform a manual log collection from the Windows host.

Execute get_info.bat.

 

Impacted Versions
VxFlex OS versions 3.0.x
PowerFlex version 3.5

Fixed in Version
PowerFlex version 3.5.1

Affected Products

PowerFlex Software

Products

VxFlex Product Family, VxFlex Ready Node
Article Properties
Article Number: 000193061
Article Type: Solution
Last Modified: 17 Apr 2025
Version:  3
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