Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

Keyboard Intermittently Does Not Work on the Alienware m15 R5 Ryzen, R6, x15, and x17 Laptops

Summary: The following article provides information about an intermittent fault with the keyboard. The keyboard stops working on the Alienware m15 R5 Ryzen, R6, x15, and x17 laptops.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

Alienware m15 R5, R6, x15, and x17 laptop keyboard either stops working or will not start up after sitting idle

Owners of Alienware m15 R5 Ryzen, m15 R6, x15, or x17 laptops may experience the following symptoms with your keyboard:

  • The keyboard intermittently stops working during use.
  • The keyboard intermittently does not work after sitting idle for a time.

Cause

An issue was identified with the keyboard firmware.

Resolution

Updating to the latest keyboard firmware for your laptop helps resolve the issue. To download and install the latest keyboard firmware, follow the steps that are mentioned below.

WARNING: Downloading and installing Dell-developed drivers or software from third-party or unknown sources can cause the laptop or device not to work correctly. The laptop may crash, fail to boot into the operating system, or in rare instances infect the laptop with viruses, trojans, or other malicious software.
NOTE: Download drivers from the device manufacturer's website for third-party or non-Dell products. (Such as non-Dell branded printers, docking stations, webcams, scanners, monitors.)
  1. Browse to: https://www.dell.com/support/drivers
  2. Identify your Dell laptop:
    1. To auto-detect your Dell laptop, follow the on-screen instructions.
    2. Enter the Service Tag of the laptop and click Search.
    3. Or, click Browse all products and select your Dell laptop from the catalog.
  3. Select the Operating System that is installed on the Dell laptop.
  4. Under Category, select System Utilities.
  5. Locate the latest Cherry Keyboard Firmware Update Utility firmware (Version v20 or newer).
  6. Click Download and save the file to your laptop.
  7. Open File Explorer and browse to the location where the downloaded file is saved.
  8. Double-click the downloaded firmware setup file and follow the on-screen instructions to complete the installation process.

If the issue is not resolved by updating the firmware, go to the: Support page for Dell keyboards

Additional Information

Recommended Articles

Here are some recommended articles related to this topic that might be of interest to you:

Article Properties


Affected Product

Alienware m15 Ryzen Edition R5, Alienware m15 R6, Alienware x15, Alienware x17

Last Published Date

11 Jan 2024

Version

6

Article Type

Solution