Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products

インテルXeonスケーラブル プロセッサー搭載Dell PowerEdgeサーバーのDDR4自己修復機能について

Summary: DDR4搭載PowerEdgeサーバーでの修正可能および修正不可能なメモリー エラー、およびトラブルシューティング手順の変更

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

BIOSバージョン2.1.x以降でインテルXeonスケーラブル・プロセッサー(第1世代または第2世代)を搭載したDell PowerEdgeサーバーのDDR4「自動修復」とは何ですか?

これらのDDR4の「自動修復」機能(BIOS拡張機能)は、サーバーでメモリー エラーが発生した場合に推奨されるお客様およびテクニカル サポートのアクションをどのように変えますか?

新しいBIOSバージョンの「自動修復」機能拡張とは何ですか?

Cause

サーバーの再起動時に発生するメモリー イベント メッセージング、エラー処理、および「自己修復」を改善するために、Dell PowerEdge BIOSに継続的な改善と機能拡張が提供されています。これにより、エラー イベントをログに記録していたDDR4メモリーDIMMを交換するために、スケジュールされたメンテナンス ウィンドウやオンサイトの存在が不要になります。

Resolution

BIOSバージョン2.1.x以降を実行している、DDR4を搭載したPowerEdgeサーバーには、重要な2つのメモリー関連「自己修復」BIOS拡張機能が実装されています。これらの機能拡張により、メモリー イベントが発生してLifeCycleログに記録された場合に実行する推奨手順またはアクションが変更されます。

注:
  • BIOS 2.0以前のDDR4でメモリー エラーが発生した場合は、多くのメモリー自己修復機能と継続的な機能強化を含む最新のリビジョンにBIOSをアップデートしてください。最新の自動修復機能拡張を活用できるように、利用可能な最新のBIOSリリース(およびiDRACファームウェア)にアップデートすることを常にお勧めします。
  • 以前のメモリーのトラブルシューティング手順には、障害が発生したDIMMを別のスロットに移動して、エラーがDIMMに続くか、DIMMスロットに残るかを確認する方法が含まれていました。BIOS 2.1.x以降のバージョンでは、推奨される最初のステップは再開です(DIMMを別スロットに移動する必要はありません)。これにより、BIOSの新しい拡張機能を実行できるようになり、DIMMの交換をスケジュール設定することなく、DIMMエラーを解決(自己修復)できる可能性があります。

1.メモリーの再トレーニングの機能拡張

起動中に発生するメモリーの再トレーニング(「メモリーの構成」ステップの早い段階)は、各DIMM/スロットの信号タイミングとマージンを最適化して、最適なアクセスを実現します。DIMMのメモリー信号のタイミングとマージニング特性は、いくつかの理由で時間の経過とともに変化する可能性があります。

  • サーバー メモリー構成の変更
  • BIOSの変更(メモリー リファレンス コード - MRC)
  • サーバーまたはDIMMの動作温度の違い
  • DIMMの一般的な使用年数

これまでは、BIOSのアップデートやメモリー構成の変更が検出されると、次回の起動時にメモリーの再トレーニングが発生していました。BIOS 2.1.x以降では、再トレーニングをスケジュール設定するための、修正可能および修正不能メモリー エラー「トリガー」が追加されました。

Warning - MEM0701 - "Correctable memory error rate exceeded for DIMM_XX."
Critical - MEM0702 - "Correctable memory error rate exceeded for DIMM_XX."
Critical - MEM0005 - "Persistent correctable memory error limit reached for a memory device at location XX."
 

これらのエラーがSEL/LifeCycleログに記録されると、メモリーの再トレーニングが次回の再起動(ウォームまたはコールド)時にスケジュール設定されます。何が起動されたかに関わりなく、BIOSは自動的に強制コールド再起動を実行します。

Critical - MEM0001 - "Multi-bit memory errors detected on memory device at location DIMM_XX."
 

このマルチビット エラーは、オペレーティング システムがそのエラーを処理できない場合、致命的なエラーが原因でサーバーが再起動する場合があります。メモリーの再トレーニングは、起動中に自動的に実行されます。オペレーティング システムが処理できる重要でないメモリーの場所でマルチビット エラーが発生した場合は、再起動をスケジュールする必要があります。

POST中のメモリーの再トレーニングは、信号のタイミングとマージンを最適化することで、障害が発生したDIMMおよび関連スロットを「自己修復」します。起動中のメモリーの再トレーニングが失敗するか(UEFI0106)、同じエラーが継続する場合を除き、これらのエラーに対してDIMMを交換する必要ありません
 

2.ポスト パッケージ修復(PPR)

2つ目の「自己修復」記憶強化はPPRです。PPRは、ハードウェア層でその場所またはアドレスを無効にすることによって、障害が発生したメモリー位置を修復し、代わりにスペア メモリー行を使用できるようにします。使用可能なスペア メモリー行の正確な数は、DRAMデバイスとDIMMサイズによって異なります。

これまでは、この機能は製造プロセス限定でした。前述のメモリー再トレーニング拡張機能と同様に、次回の再起動(ウォームまたはコールド)時に特定のDIMMスロットでPPRがスケジュール設定される、修正可能なメモリー エラーがあります。何が起動されたかに関わりなく、BIOSは自動的に強制コールド再起動を実行します。PPRオペレーションは特定のDIMMスロットにスケジュール設定されるため、PPR操作が実行されるまで、DIMMスロットの場所を変更しないでください。エラーの例は次のとおりです。

Warning - MEM0701- "Correctable memory error rate exceeded for DIMM_XX."
Critical - MEM0702 - "Correctable memory error rate exceeded for DIMM_XX."
Critical - MEM0005 - "Persistent correctable memory error limit reached for a memory device at location XX."
 

これらのイベントのいずれかがログに記録されると、メモリー構成フェーズの早い段階で、次回の再起動(ウォームまたはコールド)時にPPRがスケジュール設定されます。

注:同じDIMMの場所に、対応するMEM0005/MEM0701/MEM0702がないメッセージID MEM8000(位置DIMM_XXのメモリー デバイスに対して修正可能なメモリー エラー ログが無効になっています)が発生しても、次回の再起動時にPPRがスケジュール設定されません。

MEM8000 イベントの変更点と更新されたバージョン 1.1 以降のホワイト ペーパーについては、2020 年 7 月 10 日の更新プログラムを参照してください。

再起動後に、PPRオペレーションが完了していることを確認してください。通常のPPRオペレーションは、次の例のようになります。

MEM9060 - "The Post Package Repair operation is successfully completed on the Dual In-line Memory Module (DIMM) device that was failing earlier."

これらの修正可能なメモリー エラーに対するDIMMの交換は、PPR操作がない限り必要ありません。障害が発生した場合のクリティカルPPRメッセージの例を次に示します。
UEFI0278 - "Unable to complete the Post Package Repair (PPR) operation because of an issue in the DIMM memory slot X."
 

Dell PowerEdgeサーバーのメモリー関連の信頼性、可用性、保守性(RAS)機能について説明するホワイトペーパー(バージョン1.0)が新たに公開されました。このホワイトペーパーでは、PowerEdgeサーバーで使用可能なさまざまなRAS機能( メモリー エラーおよびDell EMC PowerEdge YX4Xサーバー メモリーRAS機能)について説明しています。

修正可能なエラーしきい値イベントの詳細については、「 14Gおよび15Gインテル/AMD PowerEdgeサーバー: DDR4メモリー:修正可能なエラーしきい値イベントの管理」を参照してください。

2020年4月24日更新

Dellは「自己修復」機能を継続的に強化しています。次のセクションでは、さまざまなBIOSバージョンに関連するアップデートと機能拡張のリストを示します。

BIOS 2.1.x - BIOS 2.1.6以降で使用可能な「自動修復」機能について、最初の記事で公開(エラー メッセージの例や推奨されるアクションを含む)。

BIOS 2.4.x以降の変更(2019年12月)

  • MEM0702(修正可能なエラー率超過...) - メッセージが重要から警告にアップデートされました。推奨されるアクションがアップデートされ、サーバーが再起動され、「自己修復」が実行されます(例:ポスト パッケージ リペア)。
    • アップデートされたメッセージを取得するには、2019年12月以降のiDRACもインストールする必要があります
    • 推奨される処置:サーバーを再起動してPPRの実行を許可する
  • MEM9060 - メッセージの説明が「自動修復」が正常に完了したことを示すように更新されました

BIOS 2.5.x以降の変更(2020年2月)

  • お客様が修正可能なエラーに関連するすべてのLifeCycle/SELログを無効にできるように、[Correctable Error Logging]BIOSオプションが追加されました。すべての「自動修復」機能は引き続き機能します。たとえば、PPRとメモリーの再トレーニングは、次回の再起動時(メモリーの構成プロセスの早い段階)でもスケジュール設定され、実行されます。
  • 既存のエラー メッセージとアクションを置き換えるRDIMMおよびLRDIMMに対するMEM08xxエラーの追加。「自動修復」機能をサポートしていないプラットフォームでは、既存のエラー メッセージが引き続き使用されます。
    • 新しいメッセージをログに記録するには、2020年2月以降のiDRAC が必要です
注:アップデートされたiDRACがないと、SELまたはLifeCycleログに新しいBIOSメッセージが「不明」として記録されます。
  • MEM0802 - MEM0702を置き換え - 修正可能なエラー率超過
    • 推奨される処置:PPRの実行を許可するには、サーバーを再起動します。PPRが成功したことを確認します(MEM0802)
  • MEM0804 - PPRが成功したことを示すMEM9060を置き換え。PPRを実行したDIMMスロットの位置が含まれるようになりました
    • 推奨される処置:点灯しているインジケータはありません。このイベントは、「自己修復」が発生したことを示しており、DIMMの交換は必要ありません。
  • MEM0805 - PPRが失敗したことを示すUEFI0278を置き換え
    • 推奨される処置:障害が発生したDIMMを交換する

2020年7月10日更新

BIOS 2.7.x以降の変更(2020年7月ブロックBIOS - 7月中旬のWeb投稿が対象)

  • MEM8000 (修正可能なエラー ログは無効) - BIOS~2.0.x以降、Dellのエンジニアリング チームは、パフォーマンスに影響を与える可能性のある修正可能なエラーの検出率を向上させるためにBIOSを変更しました。この変更により、DIMM障害分析の結果によって実証されなかったMEM8000イベントが増加しました。BIOS 2.7.x以降、MEM8000に関連する2つの変更があります。1 つ目は、MEM8000 イベントのシグナリングが変更されたことです。2つ目は、BIOSが次回の再起動時に自動修復(PPR)をスケジュールすることです。iDRACメッセージは、新しいアクションを反映するためにまだアップデートされていません。
    • 推奨される処置:サーバーを再起動して、自動修復/PPRを実行できるようにします。PPRが成功したことを確認します(MEM0804)。
  • MEM0001 (修正不能エラー):次回の再起動時に自動修復(PPR)がスケジュールされます。iDRACメッセージは、新しいアクションを反映するためにまだアップデートされていません。
    • 推奨される処置:MEM0001が、オペレーティング システムが回復できない重要なページに関連付けられている場合は、必要ありません - これは依然として致命的なエラーであり、再起動が行われます。MEM0001が、オペレーション システムが回復できる重要でないページに関連付けられている場合は、すべての自動修復(PRR)が実行されるように再起動がスケジュール設定される必要があります。PPRが成功したことを確認します(MEM0804)。

2021年1月13日に更新

BIOS 2.8.2以降の変更(2020年9月ブロックBIOS)

  • MEM9072 (メモリー巡回スクラブ プロセスによって識別された修正不能なエラー - ページが消費されていないか使用中) - 次回の再起動時に自動修復(PPR)がスケジュールされます。  iDRACメッセージは、新しいアクションを反映するためにまだアップデートされていません。
    • 推奨される処置:すぐに再起動をスケジュールします。再起動を遅延すると、ページが消費され、MEM0001エラーが発生し、再起動が発生する可能性があります。  その再起動中にメモリー自動修復(PPR)が実行されます。PPRが成功したことを確認します(MEM0804)。
注:エンジニアリング ホワイト ペーパーの最新バージョン(バージョン1.3 - 発行日2020年11月20日)は、次の場所にあります。 https://downloads.dell.com/manuals/common/dellemc_poweredge_yx4x_memoryras.pdf
インテルXeon EおよびAMD EPYCのコンテンツについては、次の場所にあるオリジナルのエンジニアリング ホワイト ペーパー(バージョン1.0)を引き続き参照してください。『PowerEdge YX4X Server Memory RAS Whitepaper v1.0 (dell.com)』

将来のBIOSアップデートに含めるため、追加のRAS機能拡張の評価中です。

メモ: 特定のエラー コード メッセージの詳細な説明と推奨される処置については、次のリンクを参照してください。検索(dell.com)エラー コード(MEM0001など)は複数の世代のサーバーとプラットフォームに適用されるため、特定のBIOSバージョンで推奨される処置が最新ではない場合があります。追加された新しいエラー コード(MEM0802、MEM0804、MEM0805など)は、インテルXeonスケーラブル・プロセッサー(第1世代または第2世代)を搭載したサーバーにのみ適用されます。

この記事は、新しい情報が公開されたときに更新されます。

関連項目: スワップ テストによるメモリーのトラブルシューティングに関するガイダンス - スワップ テスト

によるPowerEdgeシステムのメモリー エラーのトラブルシューティングダウンロードおよびドライバー: ドライバおよびダウンロード |Dell US

Affected Products

Dell EMC XC Series XC6420 Appliance, Dell EMC XC Core 6420 System, OEMR R240, OEMR R340, OEMR R740xd2, OEMR T140, OEMR T340, OEMR XL R240, OEMR XL R340, PowerEdge C6420, PowerEdge FC640, PowerEdge M640, PowerEdge MX740C, PowerEdge R240 , PowerEdge R340, PowerEdge R440, PowerEdge R540, PowerEdge R640, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R940, PowerEdge T140, PowerEdge T340, PowerEdge T440, Dell EMC vSAN C6420 Ready Node ...

Products

VxRail 460 and 470 Nodes, VxRail E560F, VxRail P570, VxRail P570F, VxRail S570, VxRail V570F
Article Properties
Article Number: 000053203
Article Type: Solution
Last Modified: 13 Nov 2024
Version:  16
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.