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Data Domain : Les sauvegardes SQL natives vers Data Domain échouent une fois le délai d’expiration CIFS atteint

Summary: Le délai d’expiration de session côté client réinitialise la communication avec Data Domain, provoquant des échecs de sauvegarde.

This article applies to   This article does not apply to 

Symptoms

La sauvegarde sur le partage CIFS (Common Internet File System) de Data Domain échoue avec le message suivant en raison d’une erreur réseau inattendue :

BackupIoRequest::ReportIoError: write failure on backup device '\\device\share\Database_full_20240316015305.BAK'. Operating system error 59 (An unexpected network error occurred.).
The operating system returned the error '59(An unexpected network error occurred.)' while attempting 'DiskChangeFileSize' on '\\device\share\Database_full_20240316015305.BAK'
The operating system returned the error '59(An unexpected network error occurred.)' while attempting 'FlushFileBuffers' on '\\device\share\Database_full_20240316015305.BAK'.

Cause

Par défaut, le délai d’expiration de session Windows est de 60 secondes. Ce délai d’expiration dépend non seulement du temps de réponse de Data Domain, mais également de la latence du réseau. En cas de réseau lent ou de traitement Data Domain plus long que prévu (comme l’extension rapide de l’index en cas de charge de sauvegarde importante), Windows réinitialise la connexion et génère des erreurs de sauvegarde.

Resolution

Augmentez le délai d’expiration de session Windows à une valeur plus élevée, par exemple 180 s, en exécutant la commande suivante :
Set-SmbClientConfiguration -SessionTimeout 180 -Force

Affected Products

Data Domain