Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

Re-activating the Trusted Platform Module (TPM) Security Feature After a System Board Replacement

Summary: This article details how to re-activate the Trusted Platform Module feature after a computer system board is replaced.

This article applies to   This article does not apply to 

Symptoms

If TPM Is Disabled in the System Setup, an Error Message Appears
 

When the Trusted Platform Module (TPM) security feature software is installed, but the TPM Security feature is disabled (set to Off) in the System Setup (BIOS), the following error messages may appear.


Broadcom Security Platform Personal Secure Drive Error Message (Click the image to enlarge.)

Broadcom Secure Foundation TPM Status Indication Error Message

The error messages may be seen when one of the following events has occurred:

  • The System Setup (BIOS) has been reset to factory defaults and the TPM Security option has defaulted to OFF.
  • A replacement system board has been installed and the TPM Security option in the System Setup has not been set to ON.
  • The TPM software is installed, but the integrated NIC is disabled, thus disabling the TPM security feature internal to the integrated NIC.

To remove the error message, enable the TPM Security Feature in the System Setup.

 


Cause

Enable the TPM Security Feature in the System Setup

To enable TPM security features in the System Setup (BIOS), perform the following steps:

  1. Reboot the system.
     
  2. When the message Press F2 to enter Setup appears, press the F2 key.
     
  3. When the System Setup appears, navigate to the Security group using the Down arrow key.
     
  4. Press the <+> key to expand the group.
     
  5. Verify that TPM Security is listed under Security.
     
  6. Navigate to the TPM Security section using the Down arrow key.
     
  7. Press the Enter key.
     
  8. Press the Right Arrow key to change the setting to On.
    The TPM is now enabled.
     
  9. Press the Esc key.
     
  10. Using the Down Arrow key, highlight Exit and press Enter key.
    The system will reboot.

Resolution

Restore Encryption Keys for the TPM Security Feature
 

Once the TPM Security Device has been turned on in the System Setup, the user will be able to restore the keys previously used to encrypt. The Broadcom Security Platform Backup Wizard is used to backup or restore Broadcom Security Platform credential data to or from other Broadcom Security Platform. This data consists of information regarding:

  • User-specific keys
  • User-specific certificates

If the user has backed up keys they need to restore, they can do it at this time. 

 

NOTE: If the user did not back up their keys held in the TPM Security Feature from the previous system board, there will be no way to retrieve them or access the encrypted data.
 

To restore the user's keys using the Broadcom Security Platform Backup Wizard, perform the following steps:

  1. Click the Start button, then click Programs.
     
  2. Click Broadcom Security Platform Tools.
     
  3. Click Security Platfom Settings.
     
  4. The Broadcom Secure Foundation TPM Settings Tool opens.
     
  5. Click the Backup tab.
     
  6. Click the Restore button.
     
  7. The Broadcom Secure Foundation TPM Backup Wizard opens.
     
  8. Follow the on-screen instructions to complete the restoration.

Article Properties
Article Number: 000155200
Article Type: Solution
Last Modified: 17 Mar 2023
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.
Article Properties
Article Number: 000155200
Article Type: Solution
Last Modified: 17 Mar 2023
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.