Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

How to Download and Install Adobe Products Sold at Dell

Summary: Discover the step-by-step instructions for installing Adobe software on your Dell computer in our comprehensive guide, ensuring a smooth installation process.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Products:

  • Adobe Acrobat
  • Adobe Creative Cloud
  • Adobe Lightroom
  • Adobe Premiere Pro
  • Adobe Premiere Elements
  • Adobe Photoshop Elements

Cause

Adobe products that are purchased through Dell contain a redemption code for a:

  • Perpetual (one time) license
    • Download and activate the software on (1) computer.
    • The license does not expire.
Caution:
  • Cloud (subscription) license.
    • Download and activate the software on (2) computers.
      • Software can only be used on (1) computer at a time.
    • The license expires when the subscription ends.
Note: Subscription licenses must be renewed directly through Adobe. For more information, reference Renew or Restart Your Membership This hyperlink is taking you to a website outside of Dell Technologies..
Warning: Once a redemption code is redeemed, the code is no longer active.

Resolution

Adobe software can be purchased with a Dell Computer or through the Dell Store.

Click the appropriate purchase method for the proper installation steps.

The following Adobe products can be purchased with a Dell commercial or consumer computer running Microsoft Windows:

Click the appropriate link ABOVE for specific installation steps.

Note: Adobe Reader is available for free at https://get.adobe.com/reader/ This hyperlink is taking you to a website outside of Dell Technologies..

The following Adobe products can be purchased at https://www.dell.com/ for computers running Microsoft Windows:

  • Adobe Acrobat
  • Adobe Creative Cloud
  • Adobe Lightroom
  • Adobe Premiere Pro
  • Adobe Photoshop Elements
  • Adobe Premiere Elements

Adobe products that are purchased separately from a Dell computer can be downloaded through Dell Digital Locker with the email that is used at the time of purchase.

Note:
  • If the Adobe product is missing from your Dell Digital Locker account, click your appropriate order number at https://www.dell.com/support/order-status/, and then click Contact Customer Support.
  • Adobe Reader is available for free at https://get.adobe.com/reader/ This hyperlink is taking you to a website outside of Dell Technologies..

Affected Products

Chromebox, Alienware, Inspiron, OptiPlex, Vostro, XPS, G Series, Chromebook, G Series, Alienware, Inspiron, Latitude, Vostro, XPS, Fixed Workstations, Mobile Workstations
Article Properties
Article Number: 000177712
Article Type: Solution
Last Modified: 27 Aug 2024
Version:  21
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.