Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products

iDRACin (Integrated Dell Remote Access Controller) nollaaminen

Summary: Tässä artikkelissa selitetään useita tapoja nollata iDRAC (Integrated Dell Remote Access Controller) sekä paikallisesti että etäyhteyden kautta, esimerkiksi nollaamalla, palauttamalla oletusasetukset ja palauttamalla asiakkaan määritykset. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Integrated Dell Remote Access Controller (iDRAC) vastaa järjestelmän profiiliasetuksista ja kaistan ulkopuolisesta hallinnasta. Joskus iDRAC saattaa lakata vastaamasta useista syistä. iDRAC ei vastaa esimerkiksi seuraaviin:

  • RACADM-komennot palauttavat virheen ERROR: Unable to perform requested operation.
  • Ei SSH-/Telnet-yhteyttä iDRACiin (yhteysyritys aikakatkeaa)
  • Ei selainyhteyttä iDRACiin
  • Ping-kutsu iDRACin IP-osoitteeseen epäonnistuu

Cause

iDRAC saattaa lakata vastaamasta useista syistä. Dell Technologies suosittelee, että järjestelmä pidetään ajan tasalla uusilla iDRAC-laiteohjelmistoilla. Näin varmistetaan paras suorituskyky, uusimmat tietoturvapäivitykset ja -korjaukset. iDRAC-päivitykset eivät edellytä isännän uudelleenkäynnistystä, mikä mahdollistaa käynnistettävät päivitykset. Tietyn palvelinmallin iDRAC-laiteohjelmistoversio saattaa poiketa muista iDRAC-palvelinmalleista. Lataa uusin iDRAC-laiteohjelmisto järjestelmään seuraavasti:

  1. Siirry Dellin tukisivustoon ja valitse palvelinmalli tai anna palvelutunniste.
  2. Valitse Ohjaimet ja ladattavat tiedostot -välilehti.
  3. Valitse iDRAC with Lifecycle Controller -luokka.
  4. Valitse halutessasi järjestelmän käyttöjärjestelmä .
  5. Lataa uusin iDRAC with Lifecycle Controller - laiteohjelmistoversio.
Dell PowerEdge -palvelinten laiteohjelmiston ja ohjainten päivittäminen sisältää luettelon useista tavoista päivittää iDRAC-laiteohjelmisto.

Resolution

iDRAC-ohjaimet voi nollata järjestelmän tunnistepainikkeella, iDRAC-verkkokäyttöliittymässä, iDRAC Service Modulessa tai RACADM-käyttöliittymässä. Katso lisätietoja valitsemalla asianmukainen osio.

Järjestelmän tunnistuspainike

Jos järjestelmässä on iDRAC, järjestelmän etu- ja takapaneelissa on tavallisesti pieni i-painike (kuvat 1 ja 2). Tämä i-painike on Järjestelmän tunniste -painike. Jos haluat nollata iDRACin käynnistämättä käyttöjärjestelmää uudelleen, paina System Identification (Järjestelmän tunniste) -painiketta vähintään 16 sekuntia. Lopeta painikkeen painaminen, kun tuulettimet alkavat pyöriä täydellä nopeudella ja jos etupaneelin LCD-näyttö on sammuksissa. iDRAC käynnistyy uudelleen muuttamatta tallennettuja asetuksia. Voi kestää minuutin tai kauemmin, ennen kuin etäohjain käynnistyy uudelleen.

PowerEdge R640 -palvelimen iDRAC i -painike
Kuva 1: PowerEdge R640 -palvelimen iDRAC i -painike

PowerEdge T620 -palvelimen iDRAC i -painike
Kuva 2: PowerEdge T620 -palvelimen iDRAC i -painike

iDRAC-verkkokäyttöliittymä

Nollaus tehdään eri tavalla iDRAC9-verkkokäyttöliittymässä sekä iDRAC7:n ja iDRAC8:n verkkokäyttöliittymässä. Katso lisätietoja valitsemalla asianmukainen iDRAC.

iDRAC9-verkkokäyttöliittymä

  1. Yhdistä iDRAC-verkkokäyttöliittymään.
  2. Kirjaudu käyttöliittymään antamalla käyttäjätunnus ja salasana.
  3. Valitse Maintenance-välilehti.
  4. Valitse Diagnostics.
  5. Nollaa iDRAC valitsemalla Reset iDRAC (Nollaa iDRAC) tai nollaa iDRAC valitsemalla Reboot iDRAC (Käynnistä iDRAC uudelleen).
Huomautus: Ympäristössä käytettävissä oleva nollauspainike saattaa vaihdella iDRAC-laiteohjelmistoversion mukaan.

Nollaa iDRAC-painike iDRAC9:ssä
Kuva 3: Nollaa iDRAC-painike iDRAC9:ssä

Käynnistä iDRAC uudelleen -painike
Kuva 4: Käynnistä iDRAC uudelleen -painike

  1. Voit myös palauttaa iDRACin oletusasetukset valitsemalla Reset iDRAC to Default Settings . Kun valitset Reset iDRAC to Default Setting, Reset iDRAC to factory default window (Palauta iDRAC oletusasetuksiin) -ikkuna avautuu. Tämä palauttaa iDRACin tehdasasetukset. Valitse jokin seuraavista vaihtoehdoista:
    • Käyttäjä- ja verkkoasetusten säilyttäminen
    • Hylkää kaikki asetukset ja palauta käyttäjien toimitusarvo (root/shipping-arvo).
    • Hylkää kaikki asetukset ja nollaa käyttäjätunnus ja salasana.
    • Hylkää kaikki asetukset ja valitse Mukautettu oletuskokoonpano (mukautettu kokoonpanotiedosto on ladattava).
  2. Näyttöön tulee varoitus. Jatka valitsemalla OK .
Huomautus: iDRAC-komentorivejä voi myös syöttää suoraan tästä näytöstä.

iDRAC7:n ja iDRAC8:n verkkokäyttöliittymä

  1. Yhdistä iDRAC-verkkokäyttöliittymään.
  2. Kirjaudu käyttöliittymään antamalla käyttäjätunnus ja salasana.
  3. Yleiskatsausnäytön oikeassa alakulmassa näkyy Quick Launch Tasks -kohta.
  4. Valitse Reset iDRAC (Nollaa iDRAC).
  5. Vahvista toiminto.

iDRAC7:n ja iDRAC8:n nollaaminen
Kuva 5: iDRAC7:n ja iDRAC8:n nollaaminen

iDRACin (Integrated Dell Remote Access Controller) nollaaminen

Kesto: 00.01.24 (hh:mm:ss)
Kun mahdollista, tekstitys (tekstitys) kieliasetukset voidaan valita tämän videosoittimen CC-kuvakkeen avulla.

iDRAC Service Module

iDRAC Service Module (iSM) on kevyt ohjelmistosovellus, joka voidaan asentaa PowerEdge-palvelimiin, joissa on iDRAC7, iDRAC8 ja iDRAC9. iSM 2.3 :n (ja uudempien) avulla järjestelmänvalvoja voi nollata iDRACin etäyhteyden kautta, kun iDRAC ei vastaa. iDRACin nollaus iDRAC Service Modulella tehdään eri tavalla riippumatta siitä, käytetäänkö Windows-, Linux- vai VMware ESXi -käyttöjärjestelmiä. Katso lisätietoja valitsemalla asianmukainen käyttöjärjestelmä.

Windows

iDRAC Service Module sisältää WMI-tavan, PowerShell-tavan ja Program Menu -pikavalintatavan , jolla iDRACin voi nollata Windows-käyttöjärjestelmässä. Katso lisätietoja valitsemalla asianmukainen tapa.

WMI-menetelmä

Tämän voi tehdä paikallisesti tai etäyhteyden kautta WMI (Windows Management Instrumentation) -komennoilla.

iDRACin nollaaminen WMI-komennoilla:

  1. Asenna iDRAC Service Module isäntäkäyttöjärjestelmään.
  2. Avaa komentokehote järjestelmänvalvojan oikeuksilla.
  3. Suorita joko paikallinen WinRM-komento tai WinRM-etäkomento.
    • Paikallinen WinRM-komento: winrm i iDRACHardReset wmi/root/cimv2/dcim/DCIM_iSMService?InstanceID="iSMExportedFunctions"
    • Suorita WinRM-etäkomento: winrm i iDRACHardReset wmi/root/cimv2/dcim/dcim_ismservice -u:"admin-username" -p:"password" -r:http://"remote-hostname or IP"/wsman -a:Basic -encoding:utf-8 -skipCACheck -skipCNCheck
Huomautus: WinRM-palvelimen tai -kuuntelijan määritys on pakollinen edellä mainitun WinRM-etäkomennon käyttöä varten. WinRM:n määrittäminen kuuntelijaksi: lisätietoja on Windowsin etähallinnan asennuksessa ja määrityksessä.
Powershell

Tämän voi tehdä paikallisesti tai etäyhteyden kautta PowerShell-komennoilla.

iDRACin nollaaminen paikallisilla PowerShell-komennoilla:

Edellytykset

  • Edellyttää vähintään Microsoft .NET Framework -versiota 2.x (64-bittistä).
  • PowerShell-komentosarjojen suorituskäytännön on oltava jompikumpi seuraavista:
    • Set-ExecutionPolicy AllSigned
    • Set-ExecutionPolicy Unrestricted

Lisäksi iDRAC Service Module sisältää PowerShell cmdlet -komennon, jolla iDRACin voi nollata paikallisesti. iDRACin nollaaminen PowerShellin avulla:

  1. Avaa Windows PowerShell -istunto järjestelmänvalvojana.
  2. Kirjoita Invoke-iDRACHardReset ja paina Enter-näppäintä.
Huomautus: Tämän -force asetuksen avulla voit nollata iDRACin komentosarjalla tai ilman vahvistusviestiä.

Komennon Invoke-iDRACHardReset käyttäminen PowerShell-etäistunnossa:

Huomautus: PS-etätoiminnon edellytys on WinRM-määritys kuuntelijaksi.
  1. Käynnistä PowerShell-istunto hallinta-asemassa.
  2. Ota PowerShell käyttöön cmdlet-komennolla Enable PS-Remoting .
Ohjelmavalikon pikavalintamenetelmä

Tämän voi tehdä kirjautumalla käyttöjärjestelmään etätyöpöytäistunnon kautta. Valitse sen jälkeen ohjelmavalikosta iDRAC-nollausvaihtoehto .

Linux

Kaikissa iSM:n tukemissa Linux-käyttöjärjestelmissä iSM sisältää komentoja, jotka voi suorittaa kirjautumalla sisään käyttöjärjestelmään SSH:n tai vastaavan kautta.

Komennot ovat joko

  • $ /opt/dell/srvadmin/iSM/bin/Invoke-iDRACHardReset
  • $ /opt/dell/srvadmin/iSM/bin/Invoke-iDRACHardReset -f
Huomautus: Voit määrittää force (-f) -asetuksen ja komennon. Se ei tarvitse käyttäjän vahvistusta ja jatkaa iDRAC-nollausta.

VMware ESXi -käyttöjärjestelmät

Kaikissa iDRAC Service Modulen tukemissa ESXi-käyttöjärjestelmissä iSM 2.3 ja uudemmat tukevat CMPI-menetelmän tarjoajaa. Tämä mahdollistaa iDRACin etänollauksen WinRM-etäkomennolla. Windows- (paitsi WMI)- ja Linux-käyttöjärjestelmistä poiketen ESXi ei kehota käyttäjää vahvistamaan iDRACin nollausta.

Komento on:

  • winrm i iDRACHardReset http://schemas.dell.com/wbem/wscim/1/cim-schema/2/root/cimv2/dcim/DCIM_iSMService?__cimnamespace=root/cimv2/dcim+InstanceID=iSMExportedFunctions -u:"root-username" -p:"password" -r:https://"Host-IP":443/wsman -a:basic -encoding:utf-8 -skipCNCheck -skipCACheck -skipRevocationcheck

Toiminnon tulos näkyy kokonaislukuarvona, joka ilmaisee toiminnon onnistumista tai epäonnistumista.

Rajoitukset:

ESXi 6.0 U1- ja ESXi 6.0 U2 -versioissa IPMI-ohjain saattaa lakata vastaamasta iDRAC-nollauksen jälkeen. Tiettyjen VMware ESXi -käyttöjärjestelmien laitekäynnistystoiminnon jälkeen IPMI-ohjain (ipmi_si_drv) saattaa lakata vastaamasta IPMI-ohjaimen ongelman vuoksi. Jos IPMI-ohjain lakkaa vastaamasta, lataa IPMI-ohjain uudelleenipmi_si_drv.

Lataa uudelleen seuraavasti ipmi_si_drv:

  1. /etc/init.d/sfcbd-watchdog stop
    esxcfg-module -u ipmi_si_drv => unload ipmi_si_drv
    esxcfg-module ipmi_si_drv => load ipmi_si_drv
    /etc/init.d/sfcbd-watchdog start
Huomautus: Vaihtoehtoisesti järjestelmänvalvoja voi korjata ongelman myös käynnistämällä isäntäkäyttöjärjestelmän uudelleen.

RACADM

Dell REMOTE Access Controller Admin (RACADM) -apuohjelma on komentorivityökalu, jota voi käyttää etähallintaan tai paikalliseen hallintaan iDRACin kautta. RACADM-komentoja voi käyttää etäyhteyden välityksellä hallinta-asemasta tai paikallisesti hallitussa järjestelmässä.

Kaikissa tapauksissa vain iDRAC käynnistyy uudelleen, mikä ei käynnistä palvelinta uudelleen. iDRAC-uudelleenkäynnistys ei vaikuta käynnissä olevaan käyttöjärjestelmään. iDRAC9:n, iDRAC7:nja iDRAC8:n komennoissa on eroja. Katso lisätietoja valitsemalla asianmukainen iDRAC.

iDRAC9

Reset (Nollaa) – iDRAC käynnistyy uudelleen muuttamatta iDRAC-määritysasetuksia.
Esimerkki: racadm racreset

Nollaus (pakotettu) - lisääminen -f mihin tahansa iDRAC-komentoon pakottaa komennon.
Esimerkki: racadm racreset -f

Palauta iDRACin tehdasasetukset. Tämä palauttaa kaikki muutokset tehdasasetuksiin, mutta säilyttää käyttäjä- ja verkkoasetukset.
Esimerkki: racadm racresetcfg

Palauta iDRAC-määritykset oletusasetuksiin ja palauta käyttäjän toimitusarvo.
Esimerkki: racadm racresetcfg -all

Palauta iDRAC-määritykset oletusasetuksiin ja palauta käyttäjän käyttäjätunnus root ja salasana.calvin
Esimerkki:racadm racresetcfg -rc

Palauta iDRAC-määritykset mukautettuihin oletusasetuksiin.
Esimerkki: racadm racrsetcfg -custom

Kaikki iDRAC9-nollauskomennot löytyvät iDRAC9 (Integrated Dell Remote Access Controller 9) -version 3.00.00.00 käyttöoppaasta | Dell Us (sivu 249).

iDRAC7 tai iDRAC8

Reset (Nollaa) – iDRAC käynnistyy uudelleen muuttamatta iDRAC-määritysasetuksia.
Esimerkki: racadm racreset

Komennon -f voi lisätä mihin tahansa iDRAC-komentoon.
Esimerkki: racadm racreset -f

Palauta iDRACin tehdasasetukset– kaikki muutokset palautetaan tehdasasetuksiin. Tämä poistaa käyttäjä- ja verkkoasetukset.
Esimerkki: racadm racresetcfg

Kaikki iDRAC7- tai iDRAC8-nollauskomennot ovat iDRAC 8/7 2.81.81.81 RACADM -komentorivikäyttöliittymän oppaassa (sivu 105).

Affected Products

iDRAC7, iDRAC8, iDRAC9, PowerEdge XR2, PowerEdge C4130, Poweredge C4140, PowerEdge c6320, PowerEdge c6320p, PowerEdge C6420, PowerEdge C6520, PowerEdge C6525, PowerEdge C6615, PowerEdge C6620, Poweredge FC430, Poweredge FC630, PowerEdge FC640 , Poweredge FC830, PowerEdge FD332, PowerEdge FM120x4 (for PE FX2/FX2s), PowerEdge FX2/FX2s, PowerEdge HS5610, PowerEdge HS5620, PowerEdge M420, PowerEdge M520, PowerEdge M520 (for PE VRTX), PowerEdge M620, PowerEdge M620 (for PE VRTX), PowerEdge M630, PowerEdge M630 (for PE VRTX), PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge M820, PowerEdge M820 (for PE VRTX), PowerEdge M830, PowerEdge M830 (for PE VRTX), PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R220, PowerEdge R230, PowerEdge R240, PowerEdge R250, PowerEdge R320, PowerEdge R330, PowerEdge R340, PowerEdge R350, PowerEdge R420, PowerEdge R420XR, PowerEdge R430, PowerEdge R440, PowerEdge R450, PowerEdge R520, PowerEdge R530, PowerEdge R530xd, PowerEdge R540, PowerEdge R550, PowerEdge R620, PowerEdge R630, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R720, PowerEdge R720XD, PowerEdge R730, PowerEdge R730xd, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R820, PowerEdge R830, PowerEdge R840, PowerEdge R860, PowerEdge R920, PowerEdge R930, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T130, PowerEdge T140, PowerEdge T150, PowerEdge T320, PowerEdge T330, PowerEdge T340, PowerEdge T350, PowerEdge T420, PowerEdge T430, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T620, PowerEdge T630, PowerEdge T640, PowerEdge XE2420, PowerEdge XE7420, PowerEdge XE7440, PowerEdge XE8545, PowerEdge XE8640, PowerEdge XE9680, PowerEdge XR11, PowerEdge XR12, PowerEdge XR4510c, PowerEdge XR4520c, PowerEdge XR5610, PowerEdge XR7620, PowerEdge XR8610t, PowerEdge XR8620t ...

Products

iDRAC Service Module
Article Properties
Article Number: 000126703
Article Type: Solution
Last Modified: 21 Sept 2023
Version:  17
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.