Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products

NetWorker-fejlfindingsvejledning: Procesnedbrud og kernedumps

Summary: Omfattende vejledning til fejlfinding af procesnedbrud og Core Dumps

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker-fejlfindingsvejledning: Procesnedbrud og kernedumps

Video: Omfattende vejledning til fejlfinding af procesnedbrud og Core Dumps

Se på YouTubeDette hyperlink fører dig til et websted uden for Dell Technologies.

Cause

Der kan være mange forskellige årsager til, at en NetWorker-proces ikke svarer. Denne artikel beskriver den anbefalede metode til at isolere og løse et problem med NetWorker-processen, hvor der ikke svares.

Resolution

Bekræft, at hvert fejlfindingstrin nedenfor gælder for dit miljø. Hvert trin indeholder instruktioner eller et link til et dokument for at eliminere mulige årsager og foretage korrigerende handlinger efter behov. Trinnene er sorteret i den mest hensigtsmæssige rækkefølge for at isolere problemet og identificere den korrekte løsning. Spring ikke et trin over.

Trin 1: Indsamling af oplysninger - problembeskrivelse
For at generere en komplet problembeskrivelse skal du løse følgende spørgsmål:
    - Under hvilke omstændigheder går processen ned. Er denne adfærd konsekvent?
    - Fungerede dette bedre før.
    - Tidspunkter for forekomster og observeret adfærdstendens
- Opstår problemet kun i tider med stor belastning på backupmiljøet eller sikkerhedskopier eller en bestemt type backupgruppe.
    - Hvornår opstod problemet første gang. Hvad ændrede sig så?
    - Hvad er problemets omfang (alle klienter / nogle klienter, alle backupmål eller nogle)
- Hvad er der hidtil forsøgt at rette, og hvilke konklusioner der er draget af dette.

Trin 2: Indsamling af oplysninger - Miljø
     - Hvilken NetWorker-proces der ikke reagerer, og på hvilken maskine (server, storagenode eller klient).
     - NetWorker-serverversion og platform
- Oversigt over størrelsen og arten af backup-datazonen
- Målmedier til disse sikkerhedskopier

Trin 3: Understøttelse
      - Ved hjælp af online NetWorker Compatibility Guide kan du kontrollere, at alle komponenter (NetWorker-server, filsystemversion, proxy, storagenoder, klienter, mål) understøttes.
      - Kontroller, at der ikke er nogen underliggende operativsystem- eller hardwarefejl, der kan forklare procesnedbrud (diskfejl, disk fuld, netværksfejl osv.).

Trin 4: Bedste praksis
      Planlægningsguiden til NetWorker Performance Optimization indeholder flere forslag til software- og hardwarekrav og anbefalinger, der skal implementeres for at få et optimalt indstillet NetWorker-miljø. Dette bør gennemgås for at sikre, at bedste praksis følges for denne datazone. Dette er relevant, hvis processen, der ikke reagerer, sker på tidspunkter med tungeste belastning.

Trin 5: Isolering af komponenter
       Hvordan vi finder årsagen til, at processen ikke reagerer, afhænger af adfærden som defineret i trin 1. Hvis udløseren er ukendt, kan der udføres test for at forsøge at fastslå, hvad der udløser nedbruddet:

    - Overvåg systemets ydeevne under kraftig belastning
- Undersøg operativsystemets logfiler omkring tidspunktet for nedbruddene for ensartethed i adfærd
- Læs NetWorker-tidsplanen for at afgøre, om der er en sammenhæng mellem tidspunkter for forekomst af en bestemt NetWorker-planlagt aktivitet.
    - Find ud af, hvilke ikke-NetWorker-operationer der kører på denne maskine, der kan påvirke dens adfærd, og om deres tidsplan korrelerer med tidspunkterne for nedbrud.
    - Hvis nedbruddet sker konsekvent, skal du ændre nogle parametre for at forsøge at indsnævre årsagen.  F.eks. sikkerhedskopiering til et andet destinationsmedie eller sikkerhedskopiering af forskellige typer data fra den samme NetWorker-klient

Trin 6: Opløsning
En coredump er en speciel fil, der repræsenterer et dump af arbejdshukommelsen i en proces på et bestemt tidspunkt, normalt når programmet er afsluttet unormalt.  Core dump-filer kan bruges til at diagnosticere årsagen til, at en proces ikke reagerer, ved at analysere, hvilke funktioner i processen der kørte på tidspunktet for nedbruddet, og hvilke data der blev tilgået.

De fleste operativsystemer genererer ikke automatisk kernedumpfiler.  Operativsystemparametrene skal ændres, så der genereres en kernedumpfil på tidspunktet for et procesnedbrud.  Denne ændring skal udføres inden nedbruddet.

1) Kontroller mappen /nsr/cores for de seneste kernedumps af NetWorker-processer i unix eller linux, eller kontroller nedbrudsmappen som defineret i Windows-registreringsdatabasen (se trin 2).

2) Hvis der ikke er nogen, skal du kontrollere, at operativsystemet er konfigureret til at generere centrale dumpfiler, hvis der er et procesnedbrud.  Se dokumentationen til operativsystemet for at få alle oplysninger, men kort fortalt vil dette sandsynligvis indebære ændring af ulimit-c- og -f-værdier i Linux eller Unix og ændring af registreringsdatabasen i Windows.

Windows 2008R2:  
- Opdater registreringsdatabasen med den nye nøgle, der findes i http://msdn.microsoft.com/en-us/library/bb787181(VS.85).aspx.
- Ved hjælp af de anbefalede værdier oprettes dumpfilen i C: \ Brugere \ Administrator \ AppData \ Local \ CrashDumps
- Aktivér fulde crashdumps.

3) Kernefilen kan undersøges på selve værtsmaskinen eller pakkes til analyse på en anden maskine.  Detaljer om, hvordan disse kernefiler pakkes, findes her:

UNIX- og Linux-kernefilemballage:
489272: Sådan indsamler du kerne-/nedbrudsdumpoplysninger og relaterede logfiler

For Windows skal du følge instruktionerne heri:
198564: Sådan indsamles kernen og brugerdumpet for ophængte processer på Windows          

4) Analysér de tilgængelige data:

- Operativsystemets logfiler
- NetWorker-dæmonlogfil fra NetWorker-serveren og den relevante storagenode.  
- Kernefil eller nedbrudsfil

Detaljeret analyse af en kernefil kræver avanceret viden om NetWorkers interne drift og bør udføres af EMC NetWorker Support.  En indledende læsning af kernefilen kan dog udføres for at sammenligne indholdet af kernefilen med kendte problemer.

Linux og HP-UX
gdb [fuld sti til behandling] [kernefil]
(gdb) hvor

AIX
dbx [fuld sti til proces] [kernefil]
(dbx) hvor

Solaris
pstack [kernefil]
dbx [fuld sti til behandling] [kernefil]
(dbx), hvor

Windows
- Start windbg windows debugger-programmet
- Klik på Filer og åbn dumpfil i windbg.
- Skriv analyze --v i det nederste kommandovindue for at hente alle oplysninger.
    
5) Baseret på ovenstående analyse og viden om systemets funktionsmåde kan du sammenligne hændelsen med listen over kendte problemer, der er beskrevet i NetWorker-produktbemærkningerne for den nyeste version.

Trin 7: Avanceret fejlfinding (hvis påkrævet)
Hvis du har mistanke om, at der er en fejl i NetWorker-softwaren, som er ansvarlig for, at processen ikke svarer, skal du pakke nedbrudsfilen (se trin 3) og give den en fuld beskrivelse af den observerede adfærd til Dell Technologies NetWorker-support for at få en detaljeret analyse af problemet.

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000034716
Article Type: Solution
Last Modified: 23 Sept 2024
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.