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Troubleshooting Video Issues With a Graphics Card Fitted in a Dell Desktop

Summary: The following article provides information about identifying if a graphics card is fitted and what ports to use. It provides instructions about how to troubleshoot the software and hardware to identify and resolve video issues. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Table of Contents:

  1. What is a graphics card and what are the issues you may see?
  2. How do I identify if I have a graphics card fitted?
  3. What are the most common software troubleshooting steps?
  4. What are the most common hardware troubleshooting steps?

What is a graphics card and what are the issues you may see?

 

What is a Graphics Card?

Dell NVidia Card

(Figure.1 graphics card)

Graphics Card: It is also known as a video card, a display adapter, a video adapter, a graphics adapter, or a display card.

This is an add-on card that has its own powerful Graphics Processing Unit (GPU) and dedicated Video memory. A graphics card is a common upgrade to many Dell desktops.

The most common cards connect using the Peripheral Component Interface express (PCIe) port on the motherboard.

Old cards would connect using the Accelerated Graphics Port (AGP) port on the motherboard.

What are the faults that you may experience?

You may experience all the same types of video faults with a dedicated video card fitted, as you would when using integrated video:

  • Blank or No video issues
  • Brightness issues
  • Horizontal and Vertical line issues
  • Color issues
  • Contrast and Resolution issues
  • Random Character issues

However, some issues are peculiar to add on cards:

  • The card fan is making noise issues
  • The card fan is making no noise issues
  • The card has heat sink issues

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Cause

How do I identify if I have a graphics card fitted?

How do I identify if I have a card fitted?

Look at the rectangle that is the back view of your Dell desktop. The expansion slots run along the short axis of the rectangular back of your desktop, as does any card fitted to an expansion slot. Follow the short axis to identify any added dedicated cards. (It does not matter whether the device is upright as a tower or on its side as a desktop.)

Empty Expansion Slots

(Figure.2 No cards fitted)

Filled Expansion Slot

(Figure.3 A card fitted)

Note:

Depending on the chassis form factor of your desktop, some expansion slots come in a smaller size than regular slots.

These two types of slot are termed full height and half height. (They both run along the short axis of the chassis.)

What are the Video ports on the back of my desktop?

Dedicated video cards can upgrade your desktop to the best possible graphics output. However, it can be confusing to determine which ports and connectors are going to be the best ones for you to use. (A common rule is to use the latest type of port that your display and card both support. This is because as newer ports and standards are developed they add features and functions that older ports cannot support. Graphics technology is in a state of constant advancement as new standards come out.)

You can identify the different ports by checking what they look like and matching them to known port types. The following link shows a visual guide to every port and connector on a Dell computer. Use this guide as a reference when identifying what the different ports are:

You can use the following links to find out more about the benefits and limitations of the various graphic ports that are available:

Note: Dell Technologies recommends connecting your video cable to one of the dedicated video card ports as your primary video. Connecting a dedicated card tells your desktops Basic Input Output System (BIOS) to automatically disable the integrated video. This is applicable where your desktop has both integrated video and an add-on dedicated video card fitted when it ships from Dell.

If a card has been fitted since the desktop shipped from Dell or you are considering fitting a dedicated card, ensure that the card is:

  • Higher rated than the integrated GPU it is replacing
  • It has a selection of ports for setting up multiple displays
  • Fits in your chassis correctly for proper cooling
  • Does not draw too much power from your Power Supply Unit (PSU)

The only valid reason for adding a dedicated video card to a desktop is to improve the performance of the graphics from when it was shipped. This means that the dedicated card has to have a better GPU than the GPU integrated into the motherboard. Alternatively, if you are looking for multiple ports to set up multiple displays from the desktop. You are making your desktop graphics perform worse than it is designed to when you do one of the following:

  • You fit a card that is not as good as the integrated GPU.
  • You fit a card that draws too much power.
  • You fit a card that does not allow proper cooling.

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Resolution

What are the most common software troubleshooting steps?

Drivers

If your Graphics card came with your Dell desktop, then you can download the latest drivers for that card from the Dell Support Site.

Where you have purchased your card separately and fitted it to the Dell desktop as an upgrade. You get the driver on the Digital Video Disc (DVD) or Manufacturer's link that comes with the device.

Troubleshooting

These steps assume that you have already troubleshot the monitor and cables at the back of the desktop. That you have run the integrated enhanced pre-boot system assessment without getting an error returned. That issue is only seen once the desktop starts to boot into an operating system.

  1. The first step is always to download the most recent revision of your card's driver and install it on your desktop. Do you still see the same issue?

    • No, the issue is resolved with the update.

    • Yes, the issue is still seen, then continue to the next step.

  2. Once the driver is updated, it should also install an application to allow you to configure your graphics card. Open the card application in your operating system.

  3. Configure your video graphics to your preferences, does the issue continue?

    • No, the issue is resolved.

    • The issue continues, continue to the next step.

  4. If your card fault is a blurry screen, fuzzy screen, contrast issues, resolution issues, brightness issues, or color issues, then adjusting the card settings may help to resolve your issue

    • It does resolve the issue.

    • It does not resolve the issue, go to the next step.

  5. You can restart your desktop in Safe Mode in most versions of the Windows Operating system:

    Booting in Safe Mode starts your desktop up with the graphics card turned off and using a generic display driver. What happens to the display fault?

    • If it continues to display the issue, you must rule out a corrupt or faulty operating system. (This could involve a clean install of the Operating System.)

    • If the issue is not seen, then the issue is with the card or port on your motherboard. Try running through the hardware troubleshooting to isolate where the fault lies. (It could be that the card is not compatible with your desktop.)

    • If you have already completed the hardware and software troubleshooting and the fault continues, contact your Dell Support with the troubleshooting completed and they help you further.

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What are the most common hardware troubleshooting steps?

Note: When carrying out any hardware troubleshooting, remember to be careful and follow best practices. You can find disassembly instructions specific to your desktop on the Dell Support Site under Manuals. You can find out more about handling electronic parts on the following link:
Safety precautions when working with electrical equipment

When experiencing any of the issues described in section 1, run through the following steps in order until you have identified the fault:

  1. Identify if you have an add-on card fitted? See the link in section 2:

  2. Is the fault seen before the Operating System loads?

    • If the answer is no, then move to the software troubleshooting section.

    • If the answer is yes, then carry on to the next hardware step.

  3. Remove and reseat all cables between the video card and the external monitors and check the status of the display?

    • The problem is resolved - there was a loose or wrong connection.

    • The issue remains, continue to the next step.

  4. Check the cabling for damage to the cable or connector and if possible swap out for a similar cable from a working desktop. Does the fault continue?

    • If you see damage or the substituted cable resolved the issue, the cabling needs replaced.

    • If there is no damage or the device continues to show this issue with a substituted cable, then go to the next step.

  5. Open the access panel of the desktop and physically check the status of the graphics card.

    • If the card appears damaged, then it must be replaced. However, it is an out of warranty expense.

    • If the fan on the card is not spinning, check that the fan cable is plugged and if so, replace the card for a faulty fan.

    • If the fan is making an abnormal noise, disconnect the fan cable and ensure the noise stops. If so replace the card for a faulty fan.

    • If the card has a heat sink, ensure it is fitted properly and is not loose and that the card is not overheating. If it is loose or overheating, you must replace the card.

    • If there is no damage or abnormal noise, then continue to the next step.

  6. If another card and desktop are available, take the working card from the working device and fit it in the faulty desktop. Take the card from the faulty desktop and fit it into the working device. Turn both desktops on and see where does the fault go?

    • The issue is not seen on either desktop, the card probably was not seated correctly. Put the cards back in their original chassis and confirm that the fault has been resolved.

    • The fault has followed the card from the faulty desktop to the working device - there is an issue with that card, you can try the software troubleshooting, but the card is most likely faulty and must be replaced.

    • The faulty desktop with the card from the working device fitted continues to show the same fault - Go through the Software troubleshooting, but you may have an issue with the port on the motherboard and need a replacement.

    • Both desktops now have a fault - ensure the correct drivers for the video card fitted are installed on both desktops. If the fault on both continues, you could have an issue with both the motherboard and the video card from the faulty desktop.

    • If you do not have a working desktop and card to swap parts with, then go to the hardware steps below.

  7. If you do not have another desktop but have a spare video card, then substituting it into the faulty device allows you to shortcut the troubleshooting. Does the fault go to a working graphics card fitted?

    • If the issue is resolved, you are looking to replace the card.

    • If the issues are not resolved, you can rule out the card and look at the software and the port on the motherboard.

    • If you do not have a working card to install, carry on with the instructions below.

  8. If another card and desktop is not available, remove the card from the device and plug up the external monitor to the integrated video port. Is the same issue seen now?

    • The same issue is seen, move to the software troubleshooting section.

    • If the issue is not seen, go to the next step.

  9. Reseat the card into your desktop. (if you have multiple card ports on the motherboard - try plugging the card into another socket.) Does the issue recur?

    • If the issue does not recur, then the card probably was not seated correctly. (If you plugged it back to a different port, try it in the original - if the fault returns there is an issue with the original port.)

    • If the fault returns, try the software troubleshooting - if that does not resolve the issue, the issue could still be with the card or the port on the motherboard.

Note: If your desktop is under warranty and you identify a faulty hardware part at any point. Note down your troubleshooting and contact Dell Support to help resolve this problem. The Dell Support staff can advise how much it costs for them to resolve the problem if you are out of warranty Contact Us.

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Affected Products

Alienware, Inspiron, OptiPlex, Vostro, XPS, G Series, Fixed Workstations
Article Properties
Article Number: 000175323
Article Type: Solution
Last Modified: 25 Nov 2024
Version:  13
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