Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products

FluidFS-kundemeddelelse: Sådan frigør genvindingstjenesten plads på en NAS-pulje

Summary: Denne kundemeddelelse forklarer, hvordan genvindingstjenesten frigør plads på en NAS-pulje.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Når et snapshot slettes, scannes det for at frigøre de blokke, det udelukkende ejede. Denne proces, også kaldet reclaimer, udføres i baggrunden.
Jo større snapshot - jo længere tid tager denne operation. Når genvindingsprocessen er afsluttet, bliver hele den frigjorte plads tilgængelig for diskenheden.

 

Det skal køre, før blokke kan fjernes ved hjælp af scsi unmap (hvis aktiveret) i backend SAN-diskenhederne.

Reclaimer står i kø for at køre, når data slettes i NAS-puljen, herunder data slettet fra delinger, NAS-diskenheder og sletning af snapshots.

Cause

Kendte begrænsninger og problemer

  • Reclaimer-tjenesten kan ikke køres manuelt eller stoppes i en længere periode, når den begynder, skal den afslutte sin kø, før pladsen frigives til NAS-puljen. 
  • Det er ressourcekrævende at hente snapshots igen. Hvis der opstår meget genvindingsaktivitet samtidigt, kan det forårsage problemer med ydeevnen på tværs af klyngen.  
    • Ressourcekrævende genvindingshandlinger kan blive så præstationspåvirkende, at det kan påvirke klientens adgang til klyngen.
  • Der er en grænse for oprettelse/udløb af snapshots, som varierer afhængigt af enhedens samlede systembelastning. Dette kan direkte påvirke reclaimeren og systemfunktionaliteten.
    • Mens reclaimer er blevet forbedret i FluidFS-firmware v6 til sletning af snapshots, er det muligt for en overbelastet reclaimer-tjeneste at påvirke klientadgangen. Disse hændelser rapporteres som "klienter kan støde på en lang periode med delvis dataadgang"
 

"Klienter kan støde på en lang periode med delvis dataadgang"

Kontrollér, om problemerne med ydeevnen opstår omkring det tidspunkt, hvor nogle snapshots udløber.

Der findes flere typer snapshots:

  • Ad hoc-snapshots – Snapshots, der udløber, når administratoren sletter dem, eller i henhold til den udløbsdato, der er angivet af administratoren. 
  • Planlagte snapshots – snapshots, der udløber i henhold til oplysningerne i tidsplanen. Navnene er baseret på navnet på tidsplanen.
  • NDMP-snapshots – snapshots, der udløber, når NDMP-sikkerhedskopieringen er fuldført. Navnene starter med ndmp.
  • Replikeringssnapshots – Snapshots, der udløber, når den næste replikering er fuldført. (Under en replikering er der to snapshots, det forrige snapshot og det aktuelle snapshot). Navne på replikeringssnapshots begynder med rep.

Resolution

    Forskudte snapshotopgaver (standardsnapshots, replikering, NDMP)

    Hvis mange snapshots udløber samtidigt, kan det medføre problemer med ydeevnen. 

    Færre, men større, snapshots, der udløber samtidigt, kan også forårsage problemer med ydeevnen.

    Det anbefales at fordele snapshots hver time over tid (trin på 10 minutter) og forskyde daglige snapshots i løbet af dagen (helst ved at udløbe om natten). Ugentlige snapshots bør helst udløbe i weekenden.

    Affected Products

    Dell Compellent FS8600
    Article Properties
    Article Number: 000178040
    Article Type: Solution
    Last Modified: 19 Jul 2024
    Version:  4
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.