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NetWorker: Reparieren von inkonsistente NSR-Peer-Informationen

Summary: NSR-Peer-Informations Fehler während Backup und Recovery. Es ist bereits ein Computer mit dem Namen (client_name) vorhanden. Wählen Sie einen anderen Namen für die Maschine aus oder löschen Sie den Eintrag "NSR Peer Information" für (client_name) auf dem Host: (HOST_NAME) ' ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Backups, Wiederherstellungen und Kommunikation schlagen auf dem Client mit den folgenden Fehlern fehl:
 
nsrexecd SYSTEM error Es ist bereits ein Computer mit dem Namen (client_name) vorhanden. Wählen Sie einen anderen Namen für die Maschine aus oder löschen Sie den Eintrag "NSR Peer Information" für (client_name) auf dem Host: (HOST_NAME) '
' nsrexecd: SYSTEM error Verbindungs Zurücksetzung durch Peer '

 
nsrexecd. exe kann zu Anwendungsfehlern auf einem oder mehreren Clients, einschließlich der Server-oder Speicher-Nodes, kommen.

Cause

Der Ordner res\nsrladb ist die Startseite der neuen zertifikatsbasierten Hostauthentifizierung (nsrauth). Er enthält sowohl das lokale Zertifikat des einzelnen Clients als auch eine zwischengespeicherte Kopie aller Hosts, mit denen es kommuniziert hat.

Bei der ersten Verbindung fordert ein Host das Zertifikat für den Host an und empfängt es, mit dem er sich verbindet, und speichert das Zertifikat für den zukünftigen Vergleich. Wenn Sie gesteuerte Recoveries und Speicher-Nodes sperren, müsste in einer Standardumgebung jedes Clientzertifikat auf dem NetWorker-Server und den Speicher-Nodes und das Serverzertifikat auf jedem Client und Speicher-Node zwischengespeichert werden. Diese zwischengespeicherten Zertifikate werden im Zweig lokale Hosts der Konfigurationsstruktur angezeigt.

Wenn ein Client neu installiert wird, wird das Zertifikat lokal auf dem Client neu erzeugt. Dies führt dazu, dass die im Cache gespeicherte Kopie des Clientzertifikats ungültig wird, was zu Fehlern führt. Die gleiche Bedingung ergibt sich aus der einfachen Umbenennung des nsrladb auf dem Client.
 

Resolution

Die NSR-Peer-Informationen werden auf Client-Ebene festgelegt, nicht auf Serverebene. Mit anderen Worten: Sie müssen eine Verbindung mit dem NSRLA, nicht mit der NSR-Datenbank herstellen. Dazu müssen Sie eine Verbindung über "nsradmin-p nsrexec" oder "nsradmin-p nsrexecd" herstellen. "nsradmin" selbst stellt eine Verbindung zum NetWorker-Server her.

Löschen Sie das nicht übereinstimmende/im Cache gespeicherte alte Zertifikat des Clients (client_name) auf dem NetWorker Host, der die Fehlermeldung (HOST_NAME) erzeugt. Für den Fall, dass der NetWorker Server aktualisiert/neu installiert wurde, muss das Serverzertifikat mithilfe der starken Authentifizierung von nsrauth von jedem Client entfernt werden. In beiden Fällen ist der korrigierende Vorgang derselbe und einer der folgenden:
  1. Löschen Sie das Zertifikat für den Client, der von jedem Host mit einer Kopie des alten über lokale Hosts in NMC aktualisiert wurde.
  2. Löschen Sie das alte/zwischengespeicherte Zertifikat vom betroffenen Client über die Befehlszeile.
So löschen Sie die Peer-Informationen des Client-Computers (vom Server)
 
nsradmin-s <HOST_NAME > -p nsrexecnsradmin >
Delete Type: NSR Peer Information; PeerHostName: <client_name>
 
So löschen Sie die Peer-Informationen auf dem Client-Computer
 
nsradmin-p nsrexec
nsradmin > Print-Typ: NSR Peer-Informationen
Löschen 

 
Weitere Informationen finden Sie unter: 

Additional Information

Sie können alle Zertifikate bedenkenlos löschen, da Sie bei der nächsten Verbindung sowieso aktualisiert werden. Möglicherweise gibt es Peer-Informationen für den langen Namen (FQDN) und den Kurznamen. Beachten Sie, dass das Zertifikat-Caching nur für Clients aktiviert ist, deren Authentifizierungsmethode nsrauth als Teil seines Werts umfasst.

Workaround je nach Version:
  1. Die Deaktivierung von nsrauth auf Server-und Speicher-Nodes (und Neustarten von NW) wird dieses Problem für eine gute Lösung beheben.
  2. Setzen Sie den NetWorker-Server auf den Modus nsrauth oder nsrauth/oldauth.
Der Oldauth-Modus kann für NetWorker Server nicht verwendet werden, wenn Sie mit NMC 8,0 verwenden.

Ein NetWorker 7.5. x-, 7.6. x-oder 8,0-Server im oldauth-Modus kann nicht mit NMC 8,0 verwendet werden, der standardmäßig im nsrauth/oldauth-Modus ist.

Affected Products

NetWorker

Products

NetWorker, NetWorker Series
Article Properties
Article Number: 000024312
Article Type: Solution
Last Modified: 21 Jul 2021
Version:  5
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