Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products

How to Use the Dell Support Site to Identify and Install the Drivers for Your Dell Personal Computer

Summary: This article provides information about how to download Dell drivers from the Dell.com/support website for your Dell computer.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Dell recommends that you download the drivers for your Dell computer, printer, tablet, and other Dell devices from the Dell Drivers & Downloads website.

WARNING: Downloading and installing Dell-developed drivers or software from third-party or unknown sources can cause the computer or device not to work correctly, cause the computer to crash or not boot into the operating system, or in some rare instances infect the computer with virus, trojan, or other malicious software.
NOTE: Drivers for third-party or non-Dell products such as non-Dell branded printers, docking stations, webcams, scanners, monitors, and so on must be downloaded from the device manufacturer's website.

Cause

  No cause information available.

Resolution

How to download and install a Dell driver

  1. Browse to the Dell Drivers & Downloads website.
  2. Identify your Dell product
    • Click Download & Install SupportAssist to auto-detect your Dell product. Follow the on-screen instructions to install Dell SupportAssist. For more information, see the Dell knowledge base article Dell SupportAssist (formerly Dell System Detect): Overview and Common Questions.
    • Or, enter the Service Tag, Express Service Code, or the Serial number of the Dell product and click Search.
    • Or, click Browse all products to manually select your Dell product from the catalog.
  3. Click Check for Updates to allow Dell to automatically find driver updates for you.
  4. Alternatively, you can manually locate and download the drivers using:
    • Keyword search box - Enter a keyword of the driver you are looking. For example, BIOS, Chipset, Audio, Video, and so on.
    • Operating System & Category filters - Select the operating system that is installed on the Dell computer and choose a driver category.
    NOTE: To view drivers for your specific Dell computer, turn on the toggle switch "Show downloads for only THIS PC".
  5. Click the Download button next to the driver of your choice and save the file. Click Show All to see the remaining drivers.
  6. Using File Explorer (also known as Windows Explorer), browse to the location where the downloaded file was saved.
  7. Double-click the .exe driver installation file that you downloaded and follow the on-screen instructions to complete the installation process.
  8. Repeat steps 5 to 7 for other drivers (if required).
  9. After the driver installation is complete, restart the computer.

Additional Information

Helpful resources


Out of Warranty support Out of warranty? No problem. Browse to the Dell.com/support website and enter your Dell Service Tag and view our offers.

NOTE: Offers are only available for US, Canada, UK, France, Germany, China, and Japan personal computer customers. Server and Storage not applicable.

Affected Products

Chromebox, Alienware, Inspiron, Legacy Desktop Models, OptiPlex, Vostro, XPS, G Series, Monitors & Accessories, PC & Tablet Accessories, Printers & Accessories, Projectors & Accessories, Chromebook, G Series, Alienware, Inspiron, Latitude, Vostro , XPS, Legacy Laptop Models, Latitude Tablets, XPS Tablets, Fixed Workstations, Mobile Workstations ...
Article Properties
Article Number: 000132380
Article Type: Solution
Last Modified: 16 May 2024
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.