Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Resolving Legacy Boot Mode Issues on Newer Dell Laptops

Summary: Unlock solutions for newer Dell laptops, facing challenges in booting to internal devices in legacy mode. Explore causes, resolutions, and essential BIOS updates for a trouble-free boot experience. ...

This article applies to   This article does not apply to 

Symptoms

Affected Platforms:

  • Latitude
  • Precision Workstation
  • Vostro
  • XPS

Newer Dell computers, such as the Latitude XX90 series laptops are unable to boot to internal boot devices when in Legacy boot mode.

Cause

Legacy Boot mode and internal boot devices

With the Boot option set to Legacy boot mode on newer series of Dell computers, you are unable to boot to internal boot devices (including hard drive, SSD, or eMMC storage devices). This issue may also occur after installing the operating system in Legacy Boot mode. A message to this effect appears in the system BIOS under the General > Boot Sequence settings (Figure 1):

Boot sequence settings
Figure 1: (English Only) Boot Sequence settings

 

Resolution

Use UEFI instead of Legacy boot mode on newer series Dell computers to boot to an internal boot device.

If the highlighted message in Figure 1 is missing from the Boot Sequence page. Update the BIOS to the latest available version at the Dell Support Site.
If the Legacy External Devices setting is missing from the Boot Sequence settings. Update the BIOS.
Select BIOS under the drop-down Category menu and download and install the latest available BIOS update. The Dell computer must be imaged in UEFI mode unless booting to an external boot device.

Note: Some newer computers only support "UEFI." It does not include an option for Legacy at all even with the latest BIOS version installed. This is normal, and it is working as expected.

UEFI mode
Figure 2: (English Only) Boot Sequence settings (Only Support UEFI)

Note: UEFI mode requires a 64-bit operating system be installed (ex, Windows 10 Pro 64-bit, Windows 10 Home 64-bit, Ubuntu 16.04 SP1 LTS 64-bit).

Additional Information

Affected Products

Latitude, Vostro, XPS, Fixed Workstations, Latitude 5290 2-in-1, Latitude 5290, Latitude 7290, Latitude 3390 2-in-1, Latitude 7390 2-in-1, Latitude 7390, Latitude 3490, Latitude 5490, Latitude 7490, Latitude 3590, Latitude 5590
Article Properties
Article Number: 000125414
Article Type: Solution
Last Modified: 15 Mar 2024
Version:  10
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.
Article Properties
Article Number: 000125414
Article Type: Solution
Last Modified: 15 Mar 2024
Version:  10
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.