Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

SD or Memory Card Reader Does Not Read the SD or Memory Cards

Summary: This article provides information about how to troubleshoot and resolve issues with the SD card or memory card reader on your Dell desktop or laptop.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

A memory card is a widely used storage medium in devices such as digital cameras, smartphones, and computers. There are several different types of memory cards, including standard SD cards, mini-SD cards, microSD cards, and so on.

Some Dell laptops and desktops come with an integrated memory card reader that supports specific memory card formats.

NOTE: Before using a memory card, ensure that the memory card reader on your device supports the specific memory card format. Check the supported memory card formats in the documentation of the Dell laptop or desktop.

If you are experiencing any one or more of the following symptoms, follow the instructions in this article to troubleshoot and fix memory card-related issues.

  • The memory card is not detected or not seen in Windows.
  • The memory card reader does not detect or read the memory card.
  • Read/Write error on SD card.
  • Error The disk you inserted was not readable by this computer.
  • Error SD card is not accessible. The file or directory is corrupted and unreadable.
  • SD card drive letter is missing or not seen in File Explorer.
  • A high-capacity SDHC card locks up, or the SDHC card cannot be read.
  • The card reader stops working after using Safely Remove Hardware.
  • Memory card appears in Windows, but errors occur when reading or writing.

Cause

There can be various reasons for an SD card not getting recognized or read by your system such as:

  • Physically damaged SD card.
  • Physical damage to the pins inside the memory card reader causes poor connection.
  • Corrupt SD card.
  • Write-protected SD card.
  • Drivers for memory card reader are not updated.
  • Unsupported SD card file system or improper formatting.

Resolution

There are various types of memory cards such as micro SD cards, SD cards, SDHC cards, SDXC cards, and so on. Not all of them are supported by the card reader on your computer. If you force or incorrectly insert a memory card, they might damage the memory card and/or the card reader.

NOTE: Before using a memory card, ensure that the card reader on your device supports the specific memory card format. Check the supported memory card formats in the documentation of the Dell laptop or desktop.

If the memory card or card reader still does not work, go to the next step.

Ensure that the card reader is not damaged or clogged with dust or debris. A dirty or dusty memory card or card reader causes poor contact between the card and the card reader.

  • Use a can of compressed air to remove any dust or debris from the card reader. Ensure to use a compressed air can that is suitable for use on electronic devices.
  • To clean the memory card, lightly wipe the dirty area with a lint free cloth and isopropyl alcohol or a contact cleaner that is suitable for use on electronic devices.
  • Try the memory card on another compatible device to ensure that the issue is not due to a damaged card reader slot.

If the memory card or card reader still does not work, go to the next step.

Ensure that the card reader is enabled in the BIOS or UEFI settings of your computer. It is possible that your card reader is turned off in the BIOS or UEFI.

NOTE: The BIOS or UEFI configuration screen may vary depending on the model of your Dell device. See the documentation of the Dell laptop or desktop for model-specific information.
  1. Restart your computer and tap the F2 key multiple times at the Dell logo splash screen.
  2. Navigate the BIOS or UEFI settings and look for Secure Digital (SD) card, Card Reader, or SD Reader.
  3. Enable the setting if it is not already enabled, and then save and exit the BIOS or UEFI settings.

Enable Secure Digital (SD) card option the in BIOS or UEFI of OptiPlex 7050

If the memory card or card reader still does not work, go to the next step.

Windows has an integrated hardware and devices troubleshooting feature that helps fix issues related to hardware and external devices.

To run the Windows troubleshooter in Windows 11 version 22H2 and older, or Windows 10, follow these steps.

  1. Press the Windows + R key to open the Run dialog box.
  2. Type msdt.exe -id Device Diagnostic and then select OK.
  3. In the Hardware and Devices troubleshooter window, select Next to allow Windows to automatically detect and repair any problems.
  4. After the troubleshooting process is complete, check if the memory card is recognized.
Hardware and Devices troubleshooter with Next button

If the memory card or card reader still does not work, go to the next step.

If the memory card does not show in Windows File Explorer, assign a new drive letter to it manually. Windows may fail to assign a drive letter to the connected removable media or memory card that is already in use by another removable drive in Windows.

Follow these steps to manually assign a new drive letter to your SD card in Windows 11 or Windows 10.

  1. Press the Windows + X key.
  2. Select Disk Management.
  3. Right-click the SD card and select the Change Drive Letter and Paths option.
  4. Choose a new drive letter and confirm.
Change drive letter and paths option in Disk Management right-click menu

If the memory card or card reader still does not work, go to the next step.

CHKDSK is a useful Windows utility that helps automatically repair file system errors to make a corrupted SD card usable again.

Follow these steps to repair a corrupt file system in Windows 11 or Windows 10.

  1. Press the Windows + X key.
  2. Select Windows PowerShell (Admin) or Terminal (Admin).
  3. In the PowerShell window, type chkdsk D: /R /F /X and press Enter. Make sure to replace D with the letter assigned to your SD card.
  4. Wait for CHKDSK to complete. This process may take several hours, depending on the size and speed of your SD card.

The /F parameter fixes any structural issues with the file system and directory, correcting inconsistencies between the two. The /R parameter tells CHKDSK to check the entire SD card for bad sectors and repair them if possible. The /X parameter dismounts the drive so that it can be checked and fixed.

Windows command prompt with CHKDSK command

If the memory card or card reader still does not work, go to the next step.

One of the most common causes of an unrecognized SD card is an incorrect or outdated card reader driver. Ensure that the drivers are updated.

Dell Technologies recommends updating the device drivers and BIOS as part of your scheduled update cycle. Device drivers and BIOS updates may contain feature enhancements or changes that help keep your system software current and compatible with other system modules (hardware and software) and can increase stability.

If the memory card or card reader still does not work after the drivers are updated, go to the next step.

Many SD cards have a feature called write-protection, toggle switch on the left side of the card. With write-protection enabled, files cannot be modified on the SD card. If the write-protection is enabled, the card is not readable.

Before using the memory card, make sure to set this switch to the unlocked position.

Write protection switch set to unlock status on SD card

If the memory card or card reader still does not work, go to the next step.

Some devices may format the SD card in a way that makes it only readable by that device and nothing else, including a computer. This will not only fix the SD card cannot read error but also make the storage media reusable.

WARNING: Formatting results in the permanent loss of all data on the SD card or memory card. Dell Technologies recommends that you back up all personal data to another storage device, including but not limited to images, videos, documents, and so on.

To format the SD card in Windows 11 or Windows 10, follow these steps:

  1. Insert the SD card into the card reader.
  2. Open This PC.
  3. Right-click the SD card letter under Devices and drives and then select Format.
  4. In the Format window, under File system, choose from the three options - NTFS, FAT32, or exFAT.
  5. Select Start to begin formatting the SD card.
Format window showing drive capacity, file system, allocation unit size, volume label, and quick format option

Malware or virus infection may also cause the SD card not to show up in Windows.

Some malware or viruses may also encrypt or hide the files on an SD card. Learn how to show or recover hidden files on an SD card.

Run a quick scan in Windows Security

  1. Select Start > Settings > Update & Security > Windows Security and then Virus & threat protection.
  2. Under Current threats, select Quick scan (or in early version of Windows 10, under Threat History, select Scan now).
Scan now (quick scan) option in Windows Security

If the scan does not find any issues, but you are still concerned, you may want to check your device more thoroughly.


Run an advanced scan in Windows Security

  1. Select Start > Settings > Update & Security > Windows Security and then Virus & threat protection.
  2. Under Current threats, select Scan options (or in early version of Windows 10, under Threat history, select Run a new advanced scan).
  3. Select one of the scan options:
    • Full scan (checks all files and programs currently on your device)
    • Custom scan (scan specific files or folders)
    • Microsoft Defender Antivirus Offline scan (restarts your computer and runs a deep scan before Windows loads to catch especially sneaky malware).

Full scan, custom scan options in Windows Security


Show or recover encrypted or hidden files on an SD card

If the files are seen on your device such as a camera, but not seen on your computer,

  1. Press the Windows + X key.
  2. Select Windows PowerShell (Admin) or Terminal (Admin).
  3. In the PowerShell window, type attrib -h -r -s /s /d X:*.* and press Enter. Make sure to replace X with the letter assigned to your SD card.
  4. After the process is complete, the SD card appears on your computer.

Windows command prompt with attrib command

Additional Information

Recommended Articles

Here are some recommended articles related to this topic that might be of interest to you.


SLN129159_en_US__2BACKUP Learn more on our Data Storage and Back-Up Solutions support page.

Out of Warranty support Out of warranty? No problem. Go to the Dell.com/support website and enter your Dell Service Tag and view our offers.

NOTE: Offers are only available for US, Canada, UK, and France personal computer customers. Server and Storage not applicable.

Affected Products

Chromebox, Alienware, Inspiron, Legacy Desktop Models, OptiPlex, Vostro, XPS, G Series, Chromebook, G Series, Alienware, Inspiron, Latitude, Vostro, XPS, Legacy Laptop Models, Fixed Workstations, Mobile Workstations
Article Properties
Article Number: 000150063
Article Type: Solution
Last Modified: 27 Aug 2024
Version:  10
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.