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PowerFlex: Cursor Disappears, and Screen Stops Responding When Manually adding IP Address During Deployment

Summary: The PFxM 4.x UI Screen stops responding, and the cursor disappears when manually entering hostnames and IP addresses in the final deployment screen.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Scenario

When deploying a Resource group and manually adding "user entered IP" addresses in the final deployment settings screen, the web browser randomly stops responding and the cursor prompt disappears (stops blinking).


Symptoms

When adding IP addresses or hostnames in the final M and O deployment screen, the browser stops responding and can eventually become unresponsive.

The not responding and cursor disappearance may get worse throughout the process of entering information for other nodes.

The PFxM UI session may timeout if the pause is too long:

Session timeout message

The deployment wizard shows a 401 error:

Deployment wizard shows 401 error:

Message seen in the thin-deployer log:

2023-11-10 17:18:24 - Sequel::DatabaseConnectionError - Java::OrgPostgresqlUtil::PSQLException: The connection attempt failed.:         java.lang.Thread.run(java/lang/Thread.java:834)
2023-11-10 17:18:24 - Sequel::DatabaseConnectionError - Java::OrgPostgresqlUtil::PSQLException: The connection attempt failed.:         java.lang.Thread.run(java/lang/Thread.java:834)
2023-11-10 17:18:24 - Sequel::DatabaseConnectionError - Java::OrgPostgresqlUtil::PSQLException: The connection attempt failed.: ERROR


Impacted Versions

PowerFlex 4.5.1 and earlier


Impact

Unable to manually enter all the IP addresses before the browser times out.

Cause

Installed browser extensions along with the deployment wizard portion of the code are contributing to the browser not responding:

Screenshot of browser extensions along with the deployment wizard

Resolution

Workaround

Instead of manually adding all the IP addresses for nodes or SVMs, check off "PowerFlex Manager Selected IP,"  which uses DNS for a hostname to ESXi IP address translation. Also, all other IP addresses should be pulled from the pool of IP addresses defined in the Networks section.


Fixed In Version

The wizard is being rewritten, and the issue should be resolved in an upcoming PowerFlex release.

Affected Products

PowerFlex rack, PowerFlex Appliance, PowerFlex custom node, PowerFlex Software
Article Properties
Article Number: 000220094
Article Type: Solution
Last Modified: 18 Mar 2024
Version:  4
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